Upstream information

CVE-2018-1084 at MITRE

Description

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1089346 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP4-SAP-Azure
Image SLES12-SP4-SAP-Azure-BYOS
Image SLES12-SP4-SAP-Azure-LI-BYOS-Production
Image SLES12-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES12-SP4-SAP-EC2-HVM
Image SLES12-SP4-SAP-EC2-HVM-BYOS
Image SLES12-SP4-SAP-GCE
Image SLES12-SP4-SAP-GCE-BYOS
Image SLES12-SP4-SAP-OCI-BYOS
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-EC2-SAP-BYOS
Image SLES12-SP5-EC2-SAP-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
Image SLES12-SP5-OCI-BYOS-SAP-BYOS
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • corosync >= 2.3.6-9.13.1
  • libcorosync4 >= 2.3.6-9.13.1
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libcorosync-devel >= 2.3.6-9.13.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-771
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libcorosync-devel >= 2.3.6-9.13.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libcorosync-devel-2.3.6-9.13.1
SUSE Linux Enterprise High Availability Extension 12 SP2
  • corosync >= 2.3.5-6.23.1
  • libcorosync4 >= 2.3.5-6.23.1
Patchnames:
SUSE-SLE-HA-12-SP2-2018-775
SUSE Linux Enterprise High Availability Extension 12 SP3
  • corosync >= 2.3.6-9.13.1
  • libcorosync4 >= 2.3.6-9.13.1
Patchnames:
SUSE-SLE-HA-12-SP3-2018-771
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libcorosync-devel >= 2.3.6-9.13.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libcorosync-devel-2.3.6-9.13.1
openSUSE Tumbleweed
  • corosync >= 2.4.5+git70.64010f57-1.2
  • corosync-qdevice >= 2.4.5+git70.64010f57-1.2
  • corosync-qnetd >= 2.4.5+git70.64010f57-1.2
  • corosync-testagents >= 2.4.5+git70.64010f57-1.2
  • libcfg6 >= 2.4.5+git70.64010f57-1.2
  • libcfg6-32bit >= 2.4.5+git70.64010f57-1.2
  • libcmap4 >= 2.4.5+git70.64010f57-1.2
  • libcmap4-32bit >= 2.4.5+git70.64010f57-1.2
  • libcorosync-devel >= 2.4.5+git70.64010f57-1.2
  • libcorosync_common4 >= 2.4.5+git70.64010f57-1.2
  • libcorosync_common4-32bit >= 2.4.5+git70.64010f57-1.2
  • libcpg4 >= 2.4.5+git70.64010f57-1.2
  • libcpg4-32bit >= 2.4.5+git70.64010f57-1.2
  • libquorum5 >= 2.4.5+git70.64010f57-1.2
  • libquorum5-32bit >= 2.4.5+git70.64010f57-1.2
  • libsam4 >= 2.4.5+git70.64010f57-1.2
  • libsam4-32bit >= 2.4.5+git70.64010f57-1.2
  • libtotem_pg5 >= 2.4.5+git70.64010f57-1.2
  • libtotem_pg5-32bit >= 2.4.5+git70.64010f57-1.2
  • libvotequorum8 >= 2.4.5+git70.64010f57-1.2
  • libvotequorum8-32bit >= 2.4.5+git70.64010f57-1.2
Patchnames:
openSUSE Tumbleweed GA corosync-2.4.5+git70.64010f57-1.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Availability Extension 12 SP5 corosync Released
SUSE Linux Enterprise High Availability Extension 15 SP4 corosync Not affected
SUSE Linux Enterprise Server 12 SP5 corosync Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 corosync Released
SUSE Linux Enterprise Software Development Kit 12 SP5 corosync Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Availability Extension 12 SP4 corosync Released
SUSE Linux Enterprise High Availability Extension 15 SP3 corosync Not affected
SUSE Linux Enterprise Server 12 SP4 corosync Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 corosync Released
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 12 SP1 corosync Unsupported
SUSE Linux Enterprise Desktop 12 SP2 corosync Affected
SUSE Linux Enterprise Desktop 12 SP3 corosync Released
SUSE Linux Enterprise Desktop 12 SP4 corosync Affected
SUSE Linux Enterprise High Availability Extension 11 SP4 corosync Not affected
SUSE Linux Enterprise High Availability Extension 12 SP1 corosync Unsupported
SUSE Linux Enterprise High Availability Extension 12 SP2 corosync Released
SUSE Linux Enterprise High Availability Extension 12 SP3 corosync Released
SUSE Linux Enterprise High Availability Extension 15 corosync Already fixed
SUSE Linux Enterprise Server 12 SP1 corosync Unsupported
SUSE Linux Enterprise Server 12 SP2 corosync Affected
SUSE Linux Enterprise Server 12 SP3 corosync Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 corosync Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 corosync Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 corosync Released
SUSE Linux Enterprise Software Development Kit 12 SP1 corosync Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 corosync Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 corosync Released
SUSE Linux Enterprise Software Development Kit 12 SP4 corosync Affected


SUSE Timeline for this CVE

CVE page created: Thu Apr 12 14:16:55 2018
CVE page last modified: Sun Apr 30 21:28:03 2023