Upstream information

CVE-2018-1083 at MITRE

Description

Zsh before version 5.4.2-test-1 is vulnerable to a buffer overflow in the shell autocomplete functionality. A local unprivileged user can create a specially crafted directory path which leads to code execution in the context of the user who tries to use autocomplete to traverse the before mentioned path. If the user affected is privileged, this leads to privilege escalation.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.5
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low High
Privileges Required Low Low
User Interaction None Required
Scope Unchanged Changed
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
SUSE Bugzilla entry: 1087026 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • zsh >= 5.0.5-6.7.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-733
SUSE Linux Enterprise Module for Basesystem 15
  • zsh >= 5.5-3.3.15
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1268
SUSE Linux Enterprise Server 12 SP3
  • zsh >= 5.0.5-6.7.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-733
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • zsh >= 5.0.5-6.7.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-733
openSUSE Leap 15.0
  • zsh >= 5.5-lp150.2.3.1
  • zsh-debuginfo >= 5.5-lp150.2.3.1
  • zsh-debugsource >= 5.5-lp150.2.3.1
  • zsh-htmldoc >= 5.5-lp150.2.3.1
Patchnames:
openSUSE-2018-699
openSUSE Leap 42.3
  • zsh >= 5.6.2-9.6.1
  • zsh-debuginfo >= 5.6.2-9.6.1
  • zsh-debugsource >= 5.6.2-9.6.1
  • zsh-htmldoc >= 5.6.2-9.6.1
Patchnames:
openSUSE-2018-1094
openSUSE-2018-399


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 zsh Affected
SUSE Linux Enterprise Desktop 12 SP3 zsh Released
SUSE Linux Enterprise Module for Basesystem 15 GA zsh Released
SUSE Linux Enterprise Server 11 SP3 LTSS zsh Affected
SUSE Linux Enterprise Server 11 SP4 zsh Affected
SUSE Linux Enterprise Server 12 GA LTSS zsh Affected
SUSE Linux Enterprise Server 12 SP1 LTSS zsh Affected
SUSE Linux Enterprise Server 12 SP2 zsh Affected
SUSE Linux Enterprise Server 12 SP3 zsh Released