Upstream information

CVE-2018-1083 at MITRE

Description

Zsh before version 5.4.2-test-1 is vulnerable to a buffer overflow in the shell autocomplete functionality. A local unprivileged user can create a specially crafted directory path which leads to code execution in the context of the user who tries to use autocomplete to traverse the before mentioned path. If the user affected is privileged, this leads to privilege escalation.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.5
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
Attack Vector Local Local
Attack Complexity Low High
Privileges Required Low Low
User Interaction None Required
Scope Unchanged Changed
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1087026 [RESOLVED / FIXED], 1189668 [NEW], 1200209 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP4-Azure-BYOS
Image SLES12-SP4-EC2-HVM-BYOS
Image SLES12-SP4-GCE-BYOS
Image SLES12-SP4-OCI-BYOS
Image SLES12-SP4-SAP-Azure
Image SLES12-SP4-SAP-Azure-BYOS
Image SLES12-SP4-SAP-Azure-LI-BYOS-Production
Image SLES12-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES12-SP4-SAP-EC2-HVM
Image SLES12-SP4-SAP-EC2-HVM-BYOS
Image SLES12-SP4-SAP-GCE
Image SLES12-SP4-SAP-GCE-BYOS
Image SLES12-SP4-SAP-OCI-BYOS
Image SLES12-SP5-Azure-BYOS
Image SLES12-SP5-Azure-Basic-On-Demand
Image SLES12-SP5-Azure-HPC-BYOS
Image SLES12-SP5-Azure-HPC-On-Demand
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-Azure-Standard-On-Demand
Image SLES12-SP5-EC2-BYOS
Image SLES12-SP5-EC2-On-Demand
Image SLES12-SP5-EC2-SAP-BYOS
Image SLES12-SP5-EC2-SAP-On-Demand
Image SLES12-SP5-GCE-BYOS
Image SLES12-SP5-GCE-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
Image SLES12-SP5-OCI-BYOS-BYOS
Image SLES12-SP5-OCI-BYOS-SAP-BYOS
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • zsh >= 5.0.5-6.7.2
Image SLES15-Azure-BYOS
Image SLES15-EC2-HVM-BYOS
Image SLES15-GCE-BYOS
Image SLES15-OCI-BYOS
Image SLES15-SAP-Azure
Image SLES15-SAP-Azure-BYOS
Image SLES15-SAP-Azure-LI-BYOS-Production
Image SLES15-SAP-Azure-VLI-BYOS-Production
Image SLES15-SAP-EC2-HVM
Image SLES15-SAP-EC2-HVM-BYOS
Image SLES15-SAP-GCE
Image SLES15-SAP-GCE-BYOS
Image SLES15-SAP-OCI-BYOS
  • zsh >= 5.5-3.3.15
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • zsh >= 5.6-5.17
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA zsh-5.6-5.17
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • zsh >= 5.6-5.17
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA zsh-5.6-5.17
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • zsh >= 5.6-5.17
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA zsh-5.6-5.17
SUSE Liberty Linux 7
  • zsh >= 5.0.2-31.el7
  • zsh-html >= 5.0.2-31.el7
Patchnames:
RHSA-2018:3073
SUSE Linux Enterprise Desktop 12 SP3
  • zsh >= 5.0.5-6.7.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-733
SUSE Linux Enterprise Desktop 12 SP4
  • zsh >= 5.0.5-6.7.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA zsh-5.0.5-6.7.2
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • zsh >= 5.6-7.5.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA zsh-5.6-7.5.1
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • zsh >= 5.6-7.5.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP5 GA zsh-5.6-7.5.1
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • zsh >= 5.5-3.3.15
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1268
SUSE Linux Enterprise High Performance Computing 12 SP5
  • zsh >= 5.0.5-6.7.2
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA zsh-5.0.5-6.7.2
SUSE Linux Enterprise Point of Sale 11 SP3
  • zsh >= 4.3.6-67.9.8.1
Patchnames:
sleposp3-zsh-14910
SUSE Linux Enterprise Server 11 SP4-LTSS
  • zsh >= 4.3.6-67.9.8.1
Patchnames:
slessp4-zsh-14910
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • zsh >= 5.0.5-6.7.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-733
SUSE Linux Enterprise Server 12 SP4
  • zsh >= 5.0.5-6.7.2
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA zsh-5.0.5-6.7.2
SUSE Linux Enterprise Server 12 SP5
  • zsh >= 5.0.5-6.7.2
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA zsh-5.0.5-6.7.2
openSUSE Leap 15.0
  • zsh >= 5.5-lp150.2.3.1
  • zsh-htmldoc >= 5.5-lp150.2.3.1
Patchnames:
openSUSE-2019-501
openSUSE Tumbleweed
  • zsh >= 5.8-7.7
  • zsh-htmldoc >= 5.8-7.7
Patchnames:
openSUSE-Tumbleweed-2024-11543


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 zsh Not affected
SUSE Linux Enterprise Desktop 15 SP5 zsh Not affected
SUSE Linux Enterprise Desktop 15 SP6 zsh Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 zsh Affected
SUSE Linux Enterprise High Performance Computing 15 SP5 zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP6 zsh Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP5 zsh Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP6 zsh Not affected
SUSE Linux Enterprise Server 12 SP5 zsh Affected
SUSE Linux Enterprise Server 15 SP5 zsh Not affected
SUSE Linux Enterprise Server 15 SP6 zsh Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 zsh Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 zsh Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 zsh Not affected
SUSE Manager Proxy 4.3 zsh Not affected
SUSE Manager Retail Branch Server 4.3 zsh Not affected
SUSE Manager Server 4.3 zsh Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS zsh Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 zsh Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 zsh Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 zsh Not affected
SUSE Linux Enterprise Server 15 SP2 zsh Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS zsh Not affected
SUSE Linux Enterprise Server 15 SP3 zsh Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS zsh Not affected
SUSE Linux Enterprise Server 15 SP4 zsh Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS zsh Not affected
SUSE Linux Enterprise Server 15-ESPOS zsh Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 zsh Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 zsh Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 zsh Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 zsh Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 zsh Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 zsh Affected
SUSE CaaS Platform 4.0 zsh Released
SUSE CaaS Platform 4.5 zsh Not affected
SUSE Enterprise Storage 6 zsh Released
SUSE Enterprise Storage 7 zsh Not affected
SUSE Linux Enterprise Desktop 12 zsh Affected
SUSE Linux Enterprise Desktop 12 SP1 zsh Affected
SUSE Linux Enterprise Desktop 12 SP2 zsh Unsupported
SUSE Linux Enterprise Desktop 12 SP3 zsh Released
SUSE Linux Enterprise Desktop 12 SP4 zsh Unsupported
SUSE Linux Enterprise Desktop 15 zsh Released
SUSE Linux Enterprise Desktop 15 SP1 zsh Not affected
SUSE Linux Enterprise Desktop 15 SP2 zsh Not affected
SUSE Linux Enterprise Desktop 15 SP3 zsh Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 zsh Affected
SUSE Linux Enterprise High Performance Computing 15 zsh Released
SUSE Linux Enterprise High Performance Computing 15 SP1 zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS zsh Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS zsh Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS zsh Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS zsh Released
SUSE Linux Enterprise Module for Basesystem 15 zsh Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 zsh Not affected
SUSE Linux Enterprise Point of Sale 11 SP3 zsh Released
SUSE Linux Enterprise Point of Service 11 SP3 zsh Released
SUSE Linux Enterprise Real Time 15 SP2 zsh Not affected
SUSE Linux Enterprise Real Time 15 SP3 zsh Not affected
SUSE Linux Enterprise Real Time 15 SP4 zsh Not affected
SUSE Linux Enterprise Server 11 SP1 zsh Unsupported
SUSE Linux Enterprise Server 11 SP3 zsh Unsupported
SUSE Linux Enterprise Server 11 SP3 LTSS zsh Unsupported
SUSE Linux Enterprise Server 11 SP3-LTSS zsh Affected
SUSE Linux Enterprise Server 11 SP4 zsh Affected
SUSE Linux Enterprise Server 11 SP4 LTSS zsh Released
SUSE Linux Enterprise Server 11 SP4-LTSS zsh Released
SUSE Linux Enterprise Server 12 zsh Affected
SUSE Linux Enterprise Server 12 SP1 zsh Affected
SUSE Linux Enterprise Server 12 SP1-LTSS zsh Unsupported
SUSE Linux Enterprise Server 12 SP2 zsh Affected
SUSE Linux Enterprise Server 12 SP2-BCL zsh Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS zsh Affected
SUSE Linux Enterprise Server 12 SP2-LTSS zsh Unsupported
SUSE Linux Enterprise Server 12 SP3 zsh Released
SUSE Linux Enterprise Server 12 SP3-BCL zsh Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS zsh Unsupported
SUSE Linux Enterprise Server 12 SP3-LTSS zsh Unsupported
SUSE Linux Enterprise Server 12 SP4 zsh Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS zsh Affected
SUSE Linux Enterprise Server 12 SP4-LTSS zsh Affected
SUSE Linux Enterprise Server 12-LTSS zsh Unsupported
SUSE Linux Enterprise Server 15 zsh Released
SUSE Linux Enterprise Server 15 SP1 zsh Not affected
SUSE Linux Enterprise Server 15 SP1-BCL zsh Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS zsh Not affected
SUSE Linux Enterprise Server 15 SP2-BCL zsh Not affected
SUSE Linux Enterprise Server 15 SP3-BCL zsh Not affected
SUSE Linux Enterprise Server 15-LTSS zsh Released
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 zsh Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 zsh Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 zsh Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 zsh Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 zsh Affected
SUSE Linux Enterprise Server for SAP Applications 15 zsh Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 zsh Not affected
SUSE Manager Proxy 4.0 zsh Not affected
SUSE Manager Proxy 4.1 zsh Not affected
SUSE Manager Proxy 4.2 zsh Not affected
SUSE Manager Retail Branch Server 4.0 zsh Not affected
SUSE Manager Retail Branch Server 4.1 zsh Not affected
SUSE Manager Retail Branch Server 4.2 zsh Not affected
SUSE Manager Server 4.0 zsh Not affected
SUSE Manager Server 4.1 zsh Not affected
SUSE Manager Server 4.2 zsh Not affected
SUSE OpenStack Cloud 7 zsh Affected
SUSE OpenStack Cloud 8 zsh Affected
SUSE OpenStack Cloud 9 zsh Affected
SUSE OpenStack Cloud Crowbar 8 zsh Affected
SUSE OpenStack Cloud Crowbar 9 zsh Affected


SUSE Timeline for this CVE

CVE page created: Mon Mar 26 17:52:09 2018
CVE page last modified: Sat Jun 15 23:52:13 2024