Upstream information

CVE-2018-10392 at MITRE

Description

mapping0_forward in mapping0.c in Xiph.Org libvorbis 1.3.6 does not validate the number of channels, which allows remote attackers to cause a denial of service (heap-based buffer overflow or over-read) or possibly have unspecified other impact via a crafted file.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 5.5
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1091070 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libvorbis >= 1.3.3-10.14.1
  • libvorbis0 >= 1.3.3-10.14.1
  • libvorbis0-32bit >= 1.3.3-10.14.1
  • libvorbisenc2 >= 1.3.3-10.14.1
  • libvorbisenc2-32bit >= 1.3.3-10.14.1
  • libvorbisfile3 >= 1.3.3-10.14.1
  • libvorbisfile3-32bit >= 1.3.3-10.14.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1081
SUSE Linux Enterprise Server 11 SP4
  • libvorbis >= 1.2.0-79.20.14.1
  • libvorbis-32bit >= 1.2.0-79.20.14.1
  • libvorbis-doc >= 1.2.0-79.20.14.1
  • libvorbis-x86 >= 1.2.0-79.20.14.1
Patchnames:
slessp4-libvorbis-13641
SUSE Linux Enterprise Server 12 SP3
  • libvorbis >= 1.3.3-10.14.1
  • libvorbis-doc >= 1.3.3-10.14.1
  • libvorbis0 >= 1.3.3-10.14.1
  • libvorbis0-32bit >= 1.3.3-10.14.1
  • libvorbisenc2 >= 1.3.3-10.14.1
  • libvorbisenc2-32bit >= 1.3.3-10.14.1
  • libvorbisfile3 >= 1.3.3-10.14.1
  • libvorbisfile3-32bit >= 1.3.3-10.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1081
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libvorbis >= 1.2.0-79.20.14.1
  • libvorbis-devel >= 1.2.0-79.20.14.1
Patchnames:
sdksp4-libvorbis-13641
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libvorbis >= 1.3.3-10.14.1
  • libvorbis-devel >= 1.3.3-10.14.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1081
openSUSE Leap 42.3
  • libvorbis >= 1.3.3-17.1
  • libvorbis-debugsource >= 1.3.3-17.1
  • libvorbis-devel >= 1.3.3-17.1
  • libvorbis-doc >= 1.3.3-17.1
  • libvorbis0 >= 1.3.3-17.1
  • libvorbis0-32bit >= 1.3.3-17.1
  • libvorbis0-debuginfo >= 1.3.3-17.1
  • libvorbis0-debuginfo-32bit >= 1.3.3-17.1
  • libvorbisenc2 >= 1.3.3-17.1
  • libvorbisenc2-32bit >= 1.3.3-17.1
  • libvorbisenc2-debuginfo >= 1.3.3-17.1
  • libvorbisenc2-debuginfo-32bit >= 1.3.3-17.1
  • libvorbisfile3 >= 1.3.3-17.1
  • libvorbisfile3-32bit >= 1.3.3-17.1
  • libvorbisfile3-debuginfo >= 1.3.3-17.1
  • libvorbisfile3-debuginfo-32bit >= 1.3.3-17.1
Patchnames:
openSUSE-2018-591

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Module for Basesystem 15
  • libvorbis >= 1.3.6-4.3.1
  • libvorbis-debugsource >= 1.3.6-4.3.1
  • libvorbis-devel >= 1.3.6-4.3.1
  • libvorbis0 >= 1.3.6-4.3.1
  • libvorbis0-debuginfo >= 1.3.6-4.3.1
  • libvorbisenc2 >= 1.3.6-4.3.1
  • libvorbisenc2-debuginfo >= 1.3.6-4.3.1
  • libvorbisfile3 >= 1.3.6-4.3.1
  • libvorbisfile3-debuginfo >= 1.3.6-4.3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 libvorbis Unsupported
SUSE Linux Enterprise Desktop 12 SP3 libvorbis Released
SUSE Linux Enterprise Module for Basesystem 15 GA libvorbis In progress
SUSE Linux Enterprise SDK 11 SP4 libvorbis Released
SUSE Linux Enterprise SDK 12 SP2 libvorbis Unsupported
SUSE Linux Enterprise SDK 12 SP3 libvorbis Released
SUSE Linux Enterprise Server 11 SP3 LTSS libvorbis Affected
SUSE Linux Enterprise Server 11 SP4 libvorbis Released
SUSE Linux Enterprise Server 12 GA LTSS libvorbis Affected
SUSE Linux Enterprise Server 12 SP1 LTSS libvorbis Affected
SUSE Linux Enterprise Server 12 SP2 libvorbis Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS libvorbis Affected
SUSE Linux Enterprise Server 12 SP3 libvorbis Released