Upstream information

CVE-2018-1000656 at MITRE

Description

The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 3.3
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1106279 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • python3-Flask >= 0.12.4-3.3.26
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-657
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • python2-Flask >= 0.12.4-3.3.26
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2019-657
openSUSE Leap 15.0
  • python2-Flask >= 0.12.4-lp150.2.3.1
  • python2-Flask-doc >= 0.12.4-lp150.2.3.1
  • python3-Flask >= 0.12.4-lp150.2.3.1
  • python3-Flask-doc >= 0.12.4-lp150.2.3.1
Patchnames:
openSUSE-2019-1112


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 python-Flask Affected
SUSE CaaS Platform 4.5 python-Flask Analysis
SUSE Enterprise Storage 4 python-Flask Affected
SUSE Enterprise Storage 5 python-Flask Unsupported
SUSE Enterprise Storage 7 python-Flask Analysis
SUSE Linux Enterprise High Performance Computing 15 LTSS python-Flask Released
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS python-Flask Analysis
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS python-Flask Analysis
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS python-Flask Analysis
SUSE Linux Enterprise Module for Basesystem 15 python-Flask Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 python-Flask Analysis
SUSE Linux Enterprise Module for Basesystem 15 SP4 python-Flask Analysis
SUSE Linux Enterprise Module for Public Cloud 12 python-Flask Affected
SUSE Linux Enterprise Real Time 15 SP2 python-Flask Analysis
SUSE Linux Enterprise Server 15 ESPOS python-Flask Released
SUSE Linux Enterprise Server 15 LTSS python-Flask Released
SUSE Linux Enterprise Server 15 SP2 LTSS python-Flask Analysis
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 python-Flask Analysis
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 python-Flask Analysis
SUSE Linux Enterprise Server for SAP Applications 15 python-Flask Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 python-Flask Analysis
SUSE Linux Enterprise Software Bootstrap Kit 12 python-Flask Affected
SUSE Manager Proxy 4.1 python-Flask Analysis
SUSE Manager Retail Branch Server 4.1 python-Flask Analysis
SUSE Manager Server 4.1 python-Flask Analysis
SUSE OpenStack Cloud 6 LTSS python-Flask Unsupported
SUSE OpenStack Cloud 7 python-Flask Unsupported
SUSE OpenStack Cloud 8 python-Flask Affected
SUSE OpenStack Cloud Crowbar 8 python-Flask Affected
SUSE Package Hub 15 python-Flask Released
SUSE Package Hub 15 SP1 python-Flask Analysis
SUSE Package Hub 15 SP3 python-Flask Analysis
SUSE Package Hub 15 SP4 python-Flask Analysis