Upstream information

CVE-2018-1000156 at MITRE

Description

GNU Patch version 2.7.6 contains an input validation vulnerability when processing patch files, specifically the EDITOR_PROGRAM invocation (using ed) can result in code execution. This attack appear to be exploitable via a patch file processed via the patch utility. This is similar to FreeBSD's CVE-2015-1418 however although they share a common ancestry the code bases have diverged over time.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.8
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1088420 [RESOLVED / FIXED], 1093615 [RESOLVED / FIXED], 1101128 [RESOLVED / FIXED], 1142513 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • patch >= 2.7.5-8.5.1
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • patch >= 2.7.6-3.5
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA patch-2.7.6-3.5
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • patch >= 2.7.6-3.5
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA patch-2.7.6-3.5
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • patch >= 2.7.6-3.5
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA patch-2.7.6-3.5
SUSE Liberty Linux 7
  • patch >= 2.7.1-10.el7_5
Patchnames:
RHSA-2018:1200
SUSE Linux Enterprise Desktop 12 SP3
  • patch >= 2.7.5-8.5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-777
SUSE Linux Enterprise Desktop 12 SP4
  • patch >= 2.7.5-8.5.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA patch-2.7.5-8.5.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • patch >= 2.7.6-3.5
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA patch-2.7.6-3.5
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • patch >= 2.7.6-150000.5.3.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP5 GA patch-2.7.6-150000.5.3.1
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Development Tools 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • patch >= 2.7.6-3.5
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA patch-2.7.6-3.5
SUSE Linux Enterprise High Performance Computing 12 SP5
  • patch >= 2.7.5-8.5.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA patch-2.7.5-8.5.1
SUSE Linux Enterprise Point of Sale 11 SP3
  • patch >= 2.5.9-252.22.7.1
Patchnames:
sleposp3-patch-13589
SUSE Linux Enterprise Server 11 SP3-LTSS
  • patch >= 2.5.9-252.22.7.1
Patchnames:
slessp3-patch-13589
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • patch >= 2.5.9-252.22.7.1
Patchnames:
slessp4-patch-13589
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • patch >= 2.7.5-8.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-777
SUSE Linux Enterprise Server 12 SP4
  • patch >= 2.7.5-8.5.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA patch-2.7.5-8.5.1
SUSE Linux Enterprise Server 12 SP5
  • patch >= 2.7.5-8.5.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA patch-2.7.5-8.5.1
openSUSE Tumbleweed
  • bosh >= 2021.09.01-44.2
  • btcflash >= 2021.09.01-44.2
  • cdda2wav >= 3.02~a10-44.2
  • cdrecord >= 3.02~a10-44.2
  • libcdrdeflt1_0 >= 3.02~a10-44.2
  • libdeflt1_0 >= 2021.09.01-44.2
  • libedc_ecc1_0 >= 3.02~a10-44.2
  • libedc_ecc_dec1_0 >= 3.02~a10-44.2
  • libfile1_0 >= 2021.09.01-44.2
  • libfind4_0 >= 1.8-44.2
  • libparanoia1_0 >= 3.02~a10-44.2
  • librmt-devel-doc >= 2021.09.01-44.2
  • librmt1_0 >= 2021.09.01-44.2
  • librscg1_0 >= 2021.09.01-44.2
  • libscg-devel >= 2021.09.01-44.2
  • libscg1_0 >= 2021.09.01-44.2
  • libscgcmd1_0 >= 2021.09.01-44.2
  • libschily-devel >= 2021.09.01-44.2
  • libschily-devel-doc >= 2021.09.01-44.2
  • libschily2_0 >= 2021.09.01-44.2
  • libxtermcap1_0 >= 2021.09.01-44.2
  • mkisofs >= 3.02~a10-44.2
  • patch >= 2.7.6-3.43
  • readcd >= 3.02~a10-44.2
  • rscsi >= 2021.09.01-44.2
  • sccs >= 2021.09.01-44.2
  • schily-ctags >= 2021.09.01-44.2
  • schily-mt >= 2021.09.01-44.2
  • schily-rmt >= 2021.09.01-44.2
  • smake >= 2021.09.01-44.2
  • spax >= 1.6.1-44.2
  • star >= 1.6.1-44.2
  • ved >= 1.8-44.2
Patchnames:
openSUSE Tumbleweed GA bosh-2021.09.01-44.2
openSUSE Tumbleweed GA patch-2.7.6-3.43


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 patch Already fixed
SUSE Linux Enterprise Desktop 15 SP5 patch Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 patch Affected
SUSE Linux Enterprise High Performance Computing 15 SP5 patch Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP5 patch Already fixed
SUSE Linux Enterprise Real Time 15 SP3 patch Already fixed
SUSE Linux Enterprise Server 12 SP5 patch Affected
SUSE Linux Enterprise Server 12-LTSS patch Unsupported
SUSE Linux Enterprise Server 15 SP5 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 patch Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP5 patch Already fixed
SUSE Manager Proxy 4.3 patch Already fixed
SUSE Manager Retail Branch Server 4.3 patch Already fixed
SUSE Manager Server 4.3 patch Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SLES15-SP1-CHOST-BYOS-GCE patch Already fixed
SUSE Linux Enterprise Desktop 15 SP4 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15-ESPOS patch Already fixed
SUSE Linux Enterprise High Performance Computing 15-LTSS patch Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 patch Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP3 patch Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 patch Already fixed
SUSE Linux Enterprise Server 15 SP2 patch Already fixed
SUSE Linux Enterprise Server 15 SP2-LTSS patch Already fixed
SUSE Linux Enterprise Server 15 SP3 patch Already fixed
SUSE Linux Enterprise Server 15 SP3-LTSS patch Already fixed
SUSE Linux Enterprise Server 15 SP4 patch Already fixed
SUSE Linux Enterprise Server 15 SP4-LTSS patch Already fixed
SUSE Linux Enterprise Server 15-ESPOS patch Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 patch Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 patch Already fixed
SUSE OpenStack Cloud 8 patch Affected
SUSE OpenStack Cloud 9 patch Affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 patch Affected
SUSE CaaS Platform 4.0 patch Already fixed
SUSE Enterprise Storage 6 patch Already fixed
SUSE Enterprise Storage 7 patch Already fixed
SUSE Linux Enterprise Desktop 12 patch Affected
SUSE Linux Enterprise Desktop 12 SP1 patch Affected
SUSE Linux Enterprise Desktop 12 SP2 patch Unsupported
SUSE Linux Enterprise Desktop 12 SP3 patch Released
SUSE Linux Enterprise Desktop 12 SP4 patch Affected
SUSE Linux Enterprise Desktop 15 patch Already fixed
SUSE Linux Enterprise Desktop 15 SP1 patch Already fixed
SUSE Linux Enterprise Desktop 15 SP2 patch Already fixed
SUSE Linux Enterprise Desktop 15 SP3 patch Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP1 patch Already fixed
SUSE Linux Enterprise Module for Development Tools 15 patch Already fixed
SUSE Linux Enterprise Point of Sale 11 SP3 patch Released
SUSE Linux Enterprise Point of Service 11 SP3 patch Released
SUSE Linux Enterprise Real Time 15 SP2 patch Already fixed
SUSE Linux Enterprise Real Time 15 SP4 patch Already fixed
SUSE Linux Enterprise Server 11 SP3 patch Affected
SUSE Linux Enterprise Server 11 SP3 LTSS patch Unsupported
SUSE Linux Enterprise Server 11 SP3-LTSS patch Released
SUSE Linux Enterprise Server 11 SP4 patch Released
SUSE Linux Enterprise Server 11 SP4 LTSS patch Released
SUSE Linux Enterprise Server 11 SP4-LTSS patch Unsupported
SUSE Linux Enterprise Server 12 patch Affected
SUSE Linux Enterprise Server 12 SP1 patch Affected
SUSE Linux Enterprise Server 12 SP1-LTSS patch Unsupported
SUSE Linux Enterprise Server 12 SP2 patch Affected
SUSE Linux Enterprise Server 12 SP2-BCL patch Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS patch Affected
SUSE Linux Enterprise Server 12 SP2-LTSS patch Affected
SUSE Linux Enterprise Server 12 SP3 patch Released
SUSE Linux Enterprise Server 12 SP3-BCL patch Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS patch Unsupported
SUSE Linux Enterprise Server 12 SP3-LTSS patch Unsupported
SUSE Linux Enterprise Server 12 SP4 patch Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS patch Affected
SUSE Linux Enterprise Server 12 SP4-LTSS patch Affected
SUSE Linux Enterprise Server 15 patch Already fixed
SUSE Linux Enterprise Server 15 SP1 patch Already fixed
SUSE Linux Enterprise Server 15 SP1-BCL patch Already fixed
SUSE Linux Enterprise Server 15 SP1-LTSS patch Already fixed
SUSE Linux Enterprise Server 15 SP2-BCL patch Already fixed
SUSE Linux Enterprise Server 15 SP3-BCL patch Already fixed
SUSE Linux Enterprise Server 15-LTSS patch Already fixed
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 patch Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 patch Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 patch Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 patch Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 patch Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 patch Affected
SUSE Manager Proxy 4.0 patch Already fixed
SUSE Manager Proxy 4.1 patch Already fixed
SUSE Manager Proxy 4.2 patch Already fixed
SUSE Manager Retail Branch Server 4.0 patch Already fixed
SUSE Manager Retail Branch Server 4.1 patch Already fixed
SUSE Manager Retail Branch Server 4.2 patch Already fixed
SUSE Manager Server 4.0 patch Already fixed
SUSE Manager Server 4.1 patch Already fixed
SUSE Manager Server 4.2 patch Already fixed
SUSE OpenStack Cloud 7 patch Affected
SUSE OpenStack Cloud Crowbar 8 patch Affected
SUSE OpenStack Cloud Crowbar 9 patch Affected
Container Status
bci/bci-sle15-kernel-module-devel
suse/manager/5.0/x86_64/server
patchAlready fixed


SUSE Timeline for this CVE

CVE page created: Fri Apr 6 03:30:10 2018
CVE page last modified: Fri Apr 19 18:03:58 2024