Upstream information

CVE-2018-1000132 at MITRE

Description

Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.1 6.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact None None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1085211 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • mercurial >= 2.8.2-15.10.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-630
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • mercurial >= 2.8.2-15.13.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA mercurial-2.8.2-15.13.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • mercurial >= 5.9.1-150400.1.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA mercurial-5.9.1-150400.1.8
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Development Tools 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • mercurial >= 4.5.2-1.19
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA mercurial-4.5.2-1.19
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • mercurial >= 2.8.2-15.13.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA mercurial-2.8.2-15.13.1
openSUSE Tumbleweed
  • mercurial >= 5.9.1-2.1
  • mercurial-lang >= 5.9.1-2.1
  • mercurial-tests >= 5.9.1-2.1
Patchnames:
openSUSE Tumbleweed GA mercurial-5.9.1-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 mercurial Already fixed
SUSE Enterprise Storage 7.1 mercurial Already fixed
SUSE Linux Enterprise Server 12 SP5 mercurial Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 mercurial Released
SUSE Linux Enterprise Software Development Kit 12 SP5 mercurial Released
SUSE Manager Proxy 4.2 mercurial Already fixed
SUSE Manager Retail Branch Server 4.2 mercurial Already fixed
SUSE Manager Server 4.2 mercurial Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 mercurial Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 mercurial Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS mercurial Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS mercurial Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 mercurial Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS mercurial Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS mercurial Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 mercurial Already fixed
SUSE Linux Enterprise High Performance Computing 15-ESPOS mercurial Already fixed
SUSE Linux Enterprise High Performance Computing 15-LTSS mercurial Already fixed
SUSE Linux Enterprise Module for Python 2 15 SP1 mercurial Already fixed
SUSE Linux Enterprise Module for Python 2 15 SP2 mercurial Already fixed
SUSE Linux Enterprise Module for Python 2 15 SP3 mercurial Already fixed
SUSE Linux Enterprise Server 12 SP4 mercurial Affected
SUSE Linux Enterprise Server 15 SP1 mercurial Already fixed
SUSE Linux Enterprise Server 15 SP1-LTSS mercurial Already fixed
SUSE Linux Enterprise Server 15 SP2 mercurial Already fixed
SUSE Linux Enterprise Server 15 SP2-LTSS mercurial Already fixed
SUSE Linux Enterprise Server 15 SP3 mercurial Already fixed
SUSE Linux Enterprise Server 15-ESPOS mercurial Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 mercurial Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 mercurial Affected
SUSE Linux Enterprise Server for SAP Applications 15 mercurial Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 mercurial Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 mercurial Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 mercurial Already fixed
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 mercurial Already fixed
SUSE Enterprise Storage 6 mercurial Already fixed
SUSE Linux Enterprise Desktop 11 SP4 mercurial Ignore
SUSE Linux Enterprise Desktop 12 mercurial Affected
SUSE Linux Enterprise Desktop 12 SP1 mercurial Affected
SUSE Linux Enterprise Desktop 12 SP2 mercurial Affected
SUSE Linux Enterprise Desktop 12 SP3 mercurial Released
SUSE Linux Enterprise Desktop 12 SP4 mercurial Affected
SUSE Linux Enterprise Desktop 15 mercurial Already fixed
SUSE Linux Enterprise Desktop 15 SP1 mercurial Already fixed
SUSE Linux Enterprise Desktop 15 SP2 mercurial Already fixed
SUSE Linux Enterprise Desktop 15 SP3 mercurial Already fixed
SUSE Linux Enterprise Module for Development Tools 15 mercurial Already fixed
SUSE Linux Enterprise Server 11 SP4 mercurial Ignore
SUSE Linux Enterprise Server 12 mercurial Affected
SUSE Linux Enterprise Server 12 SP1 mercurial Affected
SUSE Linux Enterprise Server 12 SP2 mercurial Affected
SUSE Linux Enterprise Server 12 SP3 mercurial Released
SUSE Linux Enterprise Server 15 mercurial Already fixed
SUSE Linux Enterprise Server 15 SP1-BCL mercurial Already fixed
SUSE Linux Enterprise Server 15-LTSS mercurial Already fixed
SUSE Linux Enterprise Server for SAP Applications 11 SP4 mercurial Ignore
SUSE Linux Enterprise Server for SAP Applications 12 mercurial Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 mercurial Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 mercurial Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 mercurial Released
SUSE Linux Enterprise Software Development Kit 11 SP4 mercurial Ignore
SUSE Linux Enterprise Software Development Kit 12 mercurial Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 mercurial Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 mercurial Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 mercurial Released
SUSE Linux Enterprise Software Development Kit 12 SP4 mercurial Affected
SUSE Manager Proxy 4.0 mercurial Already fixed
SUSE Manager Proxy 4.1 mercurial Already fixed
SUSE Manager Retail Branch Server 4.0 mercurial Already fixed
SUSE Manager Retail Branch Server 4.1 mercurial Already fixed
SUSE Manager Server 4.0 mercurial Already fixed
SUSE Manager Server 4.1 mercurial Already fixed


SUSE Timeline for this CVE

CVE page created: Wed Mar 14 04:30:10 2018
CVE page last modified: Mon Jan 16 19:20:29 2023