Upstream information

CVE-2018-0361 at MITRE

Description

ClamAV before 0.100.1 lacks a PDF object length check, resulting in an unreasonably long time to parse a relatively small file.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 3.3 5.3
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Local Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Low Low
SUSE Bugzilla entries: 1101410 [RESOLVED / FIXED], 1101412 [RESOLVED / FIXED], 1103091 [RESOLVED / DUPLICATE], 1103092 [RESOLVED / DUPLICATE], 1103099 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-Storage-4-2018-1561
SUSE Linux Enterprise Desktop 12 SP3
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1561
SUSE Linux Enterprise Module for Basesystem 15
  • clamav >= 0.100.1-3.3.1
  • clamav-devel >= 0.100.1-3.3.1
  • libclamav7 >= 0.100.1-3.3.1
  • libclammspack0 >= 0.100.1-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1509
SUSE Linux Enterprise Point of Sale 11 SP3
  • clamav >= 0.100.1-0.20.15.1
Patchnames:
sleposp3-clamav-13716
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-1561
SUSE Linux Enterprise Server 11 SP3-LTSS
  • clamav >= 0.100.1-0.20.15.1
Patchnames:
slessp3-clamav-13716
SUSE Linux Enterprise Server 11 SP4
  • clamav >= 0.100.1-0.20.15.1
Patchnames:
slessp4-clamav-13716
SUSE Linux Enterprise Server 12 SP1-LTSS
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-1561
SUSE Linux Enterprise Server 12 SP2-BCL
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-1561
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-1561
SUSE Linux Enterprise Server 12 SP2-LTSS
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1561
SUSE Linux Enterprise Server 12 SP3
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1561
SUSE Linux Enterprise Server 12-LTSS
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SERVER-12-2018-1561
SUSE Linux Enterprise Server for SAP Applications 11 SP3-LTSS
  • clamav >= 0.100.1-0.20.15.1
Patchnames:
slessp3-clamav-13716
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • clamav >= 0.100.1-0.20.15.1
Patchnames:
slessp4-clamav-13716
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SAP-12-SP1-2018-1561
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-1561
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-1561
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-1561
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-1561
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1561
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1561
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-SLE-SERVER-12-2018-1561
SUSE OpenStack Cloud 7
  • clamav >= 0.100.1-33.15.2
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1561
openSUSE Leap 15.0
  • clamav >= 0.100.1-lp150.2.3.1
  • clamav-debuginfo >= 0.100.1-lp150.2.3.1
  • clamav-debugsource >= 0.100.1-lp150.2.3.1
  • clamav-devel >= 0.100.1-lp150.2.3.1
  • libclamav7 >= 0.100.1-lp150.2.3.1
  • libclamav7-debuginfo >= 0.100.1-lp150.2.3.1
  • libclammspack0 >= 0.100.1-lp150.2.3.1
  • libclammspack0-debuginfo >= 0.100.1-lp150.2.3.1
Patchnames:
openSUSE-2018-838
openSUSE Leap 42.3
  • clamav >= 0.100.1-29.1
  • clamav-debuginfo >= 0.100.1-29.1
  • clamav-debugsource >= 0.100.1-29.1
Patchnames:
openSUSE-2018-889


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 clamav Released
SUSE Linux Enterprise Module for Basesystem 15 GA clamav Released
SUSE Linux Enterprise Server 11 SP3 LTSS clamav Released
SUSE Linux Enterprise Server 11 SP4 clamav Released
SUSE Linux Enterprise Server 12 GA LTSS clamav Released
SUSE Linux Enterprise Server 12 SP1 LTSS clamav Released
SUSE Linux Enterprise Server 12 SP2 LTSS clamav Released
SUSE Linux Enterprise Server 12 SP3 clamav Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 clamav Released