Upstream information

CVE-2017-9831 at MITRE

Description

An integer overflow vulnerability in the ptp_unpack_EOS_CustomFuncEx function of the ptp-pack.c file of libmtp (version 1.1.12 and below) allows attackers to cause a denial of service (out-of-bounds memory access) or maybe remote code execution by inserting a mobile device into a personal computer through a USB cable.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.6 3.7
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P AV:L/AC:H/Au:N/C:P/I:P/A:P
Access Vector Local Local
Access Complexity Low High
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.8 4.1
Vector CVSS:3.0/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:P/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Physical Physical
Access Complexity Low Low
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1045916 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.5 libmtp Not affected
SUSE Enterprise Storage 7 libmtp Not affected
SUSE Linux Enterprise Desktop 12 SP2 libmtp Affected
SUSE Linux Enterprise Desktop 15 SP3 libmtp Not affected
SUSE Linux Enterprise Desktop 15 SP4 libmtp Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS libmtp Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS libmtp Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS libmtp Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 libmtp Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 libmtp Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 libmtp Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 libmtp Not affected
SUSE Linux Enterprise Real Time 15 SP2 libmtp Not affected
SUSE Linux Enterprise Server 12 LTSS libmtp Unsupported
SUSE Linux Enterprise Server 12 SP1 LTSS libmtp Unsupported
SUSE Linux Enterprise Server 12 SP2 libmtp Affected
SUSE Linux Enterprise Server 12 SP2 BCL libmtp Affected
SUSE Linux Enterprise Server 12 SP3 BCL libmtp Affected
SUSE Linux Enterprise Server 12 SP4 LTSS libmtp Affected
SUSE Linux Enterprise Server 15 SP2 LTSS libmtp Not affected
SUSE Linux Enterprise Server 15 SP3 libmtp Not affected
SUSE Linux Enterprise Server 15 SP4 libmtp Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libmtp Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 libmtp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libmtp Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libmtp Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libmtp Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libmtp Not affected
SUSE Linux Enterprise Storage 7.1 libmtp Not affected
SUSE Manager Proxy 4.1 libmtp Not affected
SUSE Manager Proxy 4.2 libmtp Not affected
SUSE Manager Proxy 4.3 libmtp Not affected
SUSE Manager Retail Branch Server 4.1 libmtp Not affected
SUSE Manager Retail Branch Server 4.2 libmtp Not affected
SUSE Manager Retail Branch Server 4.3 libmtp Not affected
SUSE Manager Server 4.1 libmtp Not affected
SUSE Manager Server 4.2 libmtp Not affected
SUSE Manager Server 4.3 libmtp Not affected