Upstream information

CVE-2017-9776 at MITRE

Description

Integer overflow leading to Heap buffer overflow in JBIG2Stream.cc in pdftocairo in Poppler before 0.56 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PDF document.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 4.3
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 6.5
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack Vector Local Network
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1045721 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libpoppler-cpp0 >= 0.43.0-16.5.1
  • libpoppler-devel >= 0.43.0-16.5.1
  • libpoppler-glib-devel >= 0.43.0-16.5.1
  • libpoppler-glib8 >= 0.43.0-16.5.1
  • libpoppler-qt4-4 >= 0.43.0-16.5.1
  • libpoppler-qt4-devel >= 0.43.0-16.5.1
  • libpoppler44 >= 0.24.4-14.6.1
  • libpoppler60 >= 0.43.0-16.5.1
  • poppler-tools >= 0.43.0-16.5.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1236
SUSE-SLE-DESKTOP-12-SP2-2017-1237
SUSE-SLE-SDK-12-SP2-2017-1237
SUSE Linux Enterprise Desktop 12 SP3
  • libpoppler-cpp0 >= 0.43.0-16.5.1
  • libpoppler-devel >= 0.43.0-16.5.1
  • libpoppler-glib-devel >= 0.43.0-16.5.1
  • libpoppler-glib8 >= 0.43.0-16.5.1
  • libpoppler-qt4-4 >= 0.43.0-16.5.1
  • libpoppler-qt4-devel >= 0.43.0-16.5.1
  • libpoppler44 >= 0.24.4-14.6.1
  • libpoppler60 >= 0.43.0-16.5.1
  • poppler-tools >= 0.43.0-16.5.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1237
SUSE-SLE-SDK-12-SP3-2017-1236
SUSE-SLE-SDK-12-SP3-2017-1237
SUSE Linux Enterprise Desktop 12 SP4
  • libpoppler-cpp0 >= 0.43.0-16.15.1
  • libpoppler-devel >= 0.43.0-16.15.1
  • libpoppler-glib-devel >= 0.43.0-16.15.1
  • libpoppler-glib8 >= 0.43.0-16.15.1
  • libpoppler-qt4-4 >= 0.43.0-16.15.1
  • libpoppler-qt4-devel >= 0.43.0-16.15.1
  • libpoppler44 >= 0.24.4-14.13.1
  • libpoppler60 >= 0.43.0-16.15.1
  • poppler-tools >= 0.43.0-16.15.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.15.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libpoppler-glib8-0.43.0-16.15.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libpoppler-cpp0-0.43.0-16.15.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libpoppler44-0.24.4-14.13.1
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libpoppler-glib8 >= 0.43.0-16.15.1
  • libpoppler-qt4-4 >= 0.43.0-16.15.1
  • libpoppler60 >= 0.43.0-16.15.1
  • poppler-tools >= 0.43.0-16.15.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libpoppler-glib8-0.43.0-16.15.1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libpoppler-cpp0 >= 0.43.0-16.5.1
  • libpoppler-devel >= 0.43.0-16.5.1
  • libpoppler-glib-devel >= 0.43.0-16.5.1
  • libpoppler-glib8 >= 0.43.0-16.5.1
  • libpoppler-qt4-4 >= 0.43.0-16.5.1
  • libpoppler-qt4-devel >= 0.43.0-16.5.1
  • libpoppler44 >= 0.24.4-14.6.1
  • libpoppler60 >= 0.43.0-16.5.1
  • poppler-tools >= 0.43.0-16.5.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.5.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1237
SUSE-SLE-SERVER-12-SP2-2017-1236
SUSE-SLE-SERVER-12-SP2-2017-1237
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libpoppler-cpp0 >= 0.43.0-16.5.1
  • libpoppler-devel >= 0.43.0-16.5.1
  • libpoppler-glib-devel >= 0.43.0-16.5.1
  • libpoppler-glib8 >= 0.43.0-16.5.1
  • libpoppler-qt4-4 >= 0.43.0-16.5.1
  • libpoppler-qt4-devel >= 0.43.0-16.5.1
  • libpoppler44 >= 0.24.4-14.6.1
  • libpoppler60 >= 0.43.0-16.5.1
  • poppler-tools >= 0.43.0-16.5.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.5.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1236
SUSE-SLE-SDK-12-SP3-2017-1237
SUSE-SLE-SERVER-12-SP3-2017-1237
SUSE Linux Enterprise Server 12 SP4
  • libpoppler-cpp0 >= 0.43.0-16.15.1
  • libpoppler-devel >= 0.43.0-16.15.1
  • libpoppler-glib-devel >= 0.43.0-16.15.1
  • libpoppler-glib8 >= 0.43.0-16.15.1
  • libpoppler-qt4-4 >= 0.43.0-16.15.1
  • libpoppler-qt4-devel >= 0.43.0-16.15.1
  • libpoppler44 >= 0.24.4-14.13.1
  • libpoppler60 >= 0.43.0-16.15.1
  • poppler-tools >= 0.43.0-16.15.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.15.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libpoppler-glib8-0.43.0-16.15.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libpoppler-cpp0-0.43.0-16.15.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libpoppler44-0.24.4-14.13.1
SUSE Linux Enterprise Server 12 SP5
  • libpoppler-cpp0 >= 0.43.0-16.15.1
  • libpoppler-devel >= 0.43.0-16.15.1
  • libpoppler-glib-devel >= 0.43.0-16.15.1
  • libpoppler-glib8 >= 0.43.0-16.15.1
  • libpoppler-qt4-4 >= 0.43.0-16.15.1
  • libpoppler-qt4-devel >= 0.43.0-16.15.1
  • libpoppler44 >= 0.24.4-14.13.1
  • libpoppler60 >= 0.43.0-16.15.1
  • poppler-tools >= 0.43.0-16.15.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.15.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libpoppler-glib8-0.43.0-16.15.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libpoppler-cpp0-0.43.0-16.15.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libpoppler44-0.24.4-14.13.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpoppler-glib8 >= 0.43.0-16.5.1
  • libpoppler-qt4-4 >= 0.43.0-16.5.1
  • libpoppler44 >= 0.24.4-14.6.1
  • libpoppler60 >= 0.43.0-16.5.1
  • poppler-tools >= 0.43.0-16.5.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1236
SUSE-SLE-RPI-12-SP2-2017-1237
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libpoppler-cpp0 >= 0.43.0-16.15.1
  • libpoppler-devel >= 0.43.0-16.15.1
  • libpoppler-glib-devel >= 0.43.0-16.15.1
  • libpoppler-qt4-devel >= 0.43.0-16.15.1
  • libpoppler44 >= 0.24.4-14.13.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.15.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libpoppler-cpp0-0.43.0-16.15.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libpoppler44-0.24.4-14.13.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libpoppler-cpp0 >= 0.43.0-16.15.1
  • libpoppler-devel >= 0.43.0-16.15.1
  • libpoppler-glib-devel >= 0.43.0-16.15.1
  • libpoppler-qt4-devel >= 0.43.0-16.15.1
  • libpoppler44 >= 0.24.4-14.13.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.15.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libpoppler-cpp0-0.43.0-16.15.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libpoppler44-0.24.4-14.13.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libpoppler-cpp0 >= 0.43.0-16.5.1
  • libpoppler-devel >= 0.43.0-16.5.1
  • libpoppler-glib-devel >= 0.43.0-16.5.1
  • libpoppler-qt4-devel >= 0.43.0-16.5.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.5.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1237
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libpoppler-cpp0 >= 0.43.0-16.5.1
  • libpoppler-devel >= 0.43.0-16.5.1
  • libpoppler-glib-devel >= 0.43.0-16.5.1
  • libpoppler-qt4-devel >= 0.43.0-16.5.1
  • libpoppler44 >= 0.24.4-14.6.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.5.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1236
SUSE-SLE-SDK-12-SP3-2017-1237


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 poppler Affected
SUSE CaaS Platform 4.0 poppler Not affected
SUSE CaaS Platform 4.5 poppler Not affected
SUSE Enterprise Storage 6 poppler Not affected
SUSE Enterprise Storage 7 poppler Not affected
SUSE Enterprise Storage 7.1 poppler Not affected
SUSE Linux Enterprise Desktop 11 SP4 poppler Affected
SUSE Linux Enterprise Desktop 12 poppler Affected
SUSE Linux Enterprise Desktop 12 SP1 poppler Affected
SUSE Linux Enterprise Desktop 12 SP2 poppler Released
SUSE Linux Enterprise Desktop 12 SP2 poppler-qt Released
SUSE Linux Enterprise Desktop 12 SP3 poppler Released
SUSE Linux Enterprise Desktop 12 SP3 poppler-qt Released
SUSE Linux Enterprise Desktop 12 SP4 poppler Affected
SUSE Linux Enterprise Desktop 15 poppler Not affected
SUSE Linux Enterprise Desktop 15 SP1 poppler Not affected
SUSE Linux Enterprise Desktop 15 SP2 poppler Not affected
SUSE Linux Enterprise Desktop 15 SP3 poppler Not affected
SUSE Linux Enterprise Desktop 15 SP4 poppler Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 poppler Affected
SUSE Linux Enterprise High Performance Computing 15 poppler Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 poppler Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS poppler Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS poppler Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 poppler Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS poppler Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS poppler Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 poppler Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 poppler Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS poppler Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS poppler Not affected
SUSE Linux Enterprise Module for Basesystem 15 poppler Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 poppler Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 poppler Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 poppler Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 poppler Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 poppler Not affected
SUSE Linux Enterprise Point of Service 11 SP3 poppler Affected
SUSE Linux Enterprise Real Time 15 SP2 poppler Not affected
SUSE Linux Enterprise Real Time 15 SP3 poppler Not affected
SUSE Linux Enterprise Server 11 SP1 poppler Unsupported
SUSE Linux Enterprise Server 11 SP3 poppler Unsupported
SUSE Linux Enterprise Server 11 SP3 LTSS poppler Affected
SUSE Linux Enterprise Server 11 SP3-LTSS poppler Affected
SUSE Linux Enterprise Server 11 SP4 poppler Affected
SUSE Linux Enterprise Server 11 SP4 LTSS poppler Affected
SUSE Linux Enterprise Server 11 SP4-LTSS poppler Affected
SUSE Linux Enterprise Server 12 poppler Affected
SUSE Linux Enterprise Server 12 SP1 poppler Affected
SUSE Linux Enterprise Server 12 SP1-LTSS poppler Unsupported
SUSE Linux Enterprise Server 12 SP2 poppler Released
SUSE Linux Enterprise Server 12 SP2 poppler-qt Released
SUSE Linux Enterprise Server 12 SP2-BCL poppler Released
SUSE Linux Enterprise Server 12 SP2-ESPOS poppler Affected
SUSE Linux Enterprise Server 12 SP2-LTSS poppler Affected
SUSE Linux Enterprise Server 12 SP3 poppler Released
SUSE Linux Enterprise Server 12 SP3 poppler-qt Released
SUSE Linux Enterprise Server 12 SP3-BCL poppler Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS poppler Affected
SUSE Linux Enterprise Server 12 SP3-LTSS poppler Affected
SUSE Linux Enterprise Server 12 SP4 poppler Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS poppler Affected
SUSE Linux Enterprise Server 12 SP4-LTSS poppler Affected
SUSE Linux Enterprise Server 12 SP5 poppler Affected
SUSE Linux Enterprise Server 12-LTSS poppler Unsupported
SUSE Linux Enterprise Server 15 poppler Not affected
SUSE Linux Enterprise Server 15 SP1 poppler Not affected
SUSE Linux Enterprise Server 15 SP1-BCL poppler Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS poppler Not affected
SUSE Linux Enterprise Server 15 SP2 poppler Not affected
SUSE Linux Enterprise Server 15 SP2-BCL poppler Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS poppler Not affected
SUSE Linux Enterprise Server 15 SP3 poppler Not affected
SUSE Linux Enterprise Server 15 SP4 poppler Not affected
SUSE Linux Enterprise Server 15-LTSS poppler Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 poppler Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 poppler Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 poppler Released
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 poppler-qt Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 12 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 poppler Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 poppler-qt Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 poppler Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 poppler-qt Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 15 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 poppler Not affected
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 poppler Released
SUSE Linux Enterprise Software Bootstrap Kit 12 poppler Released
SUSE Linux Enterprise Software Development Kit 11 SP4 poppler Affected
SUSE Linux Enterprise Software Development Kit 12 poppler Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 poppler Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 poppler Released
SUSE Linux Enterprise Software Development Kit 12 SP2 poppler-qt Released
SUSE Linux Enterprise Software Development Kit 12 SP3 poppler Released
SUSE Linux Enterprise Software Development Kit 12 SP3 poppler-qt Released
SUSE Linux Enterprise Software Development Kit 12 SP4 poppler Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 poppler Affected
SUSE Linux Enterprise Workstation Extension 15 SP2 poppler Not affected
SUSE Manager Proxy 4.0 poppler Not affected
SUSE Manager Proxy 4.1 poppler Not affected
SUSE Manager Proxy 4.2 poppler Not affected
SUSE Manager Proxy 4.3 poppler Not affected
SUSE Manager Retail Branch Server 4.0 poppler Not affected
SUSE Manager Retail Branch Server 4.1 poppler Not affected
SUSE Manager Retail Branch Server 4.2 poppler Not affected
SUSE Manager Retail Branch Server 4.3 poppler Not affected
SUSE Manager Server 4.0 poppler Not affected
SUSE Manager Server 4.1 poppler Not affected
SUSE Manager Server 4.2 poppler Not affected
SUSE Manager Server 4.3 poppler Not affected
SUSE OpenStack Cloud 7 poppler Affected
SUSE OpenStack Cloud 8 poppler Affected
SUSE OpenStack Cloud 9 poppler Affected
SUSE OpenStack Cloud Crowbar 8 poppler Affected
SUSE OpenStack Cloud Crowbar 9 poppler Affected


SUSE Timeline for this CVE

CVE page created: Fri Jun 23 01:21:38 2017
CVE page last modified: Thu Dec 1 12:11:58 2022