Upstream information

CVE-2017-9772 at MITRE

Description

Insufficient sanitisation in the OCaml compiler versions 4.04.0 and 4.04.1 allows external code to be executed with raised privilege in binaries marked as setuid, by setting the CAML_CPLUGINS, CAML_NATIVE_CPLUGINS, or CAML_BYTE_CPLUGINS environment variable.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • ocaml >= 4.05.0-4.25
  • ocaml-compiler-libs >= 4.05.0-4.25
  • ocaml-compiler-libs-devel >= 4.05.0-4.25
  • ocaml-ocamldoc >= 4.05.0-4.25
  • ocaml-rpm-macros >= 4.05.0-4.25
  • ocaml-runtime >= 4.05.0-4.25
SUSE Linux Enterprise Module for Development Tools 15 SP2
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • ocaml >= 4.05.0-13.5
  • ocaml-compiler-libs >= 4.05.0-13.5
  • ocaml-compiler-libs-devel >= 4.05.0-13.5
  • ocaml-ocamldoc >= 4.05.0-13.5
  • ocaml-runtime >= 4.05.0-13.5
SUSE Linux Enterprise Module for Development Tools 15
  • ocaml >= 4.05.0-4.25
  • ocaml-compiler-libs >= 4.05.0-4.25
  • ocaml-compiler-libs-devel >= 4.05.0-4.25
  • ocaml-rpm-macros >= 4.05.0-4.25
  • ocaml-runtime >= 4.05.0-4.25
openSUSE Tumbleweed
  • ocaml >= 4.12.1-1.1
  • ocaml-compiler-libs >= 4.12.1-1.1
  • ocaml-compiler-libs-devel >= 4.12.1-1.1
  • ocaml-ocamldoc >= 4.12.1-1.1
  • ocaml-runtime >= 4.12.1-1.1
  • ocaml-source >= 4.12.1-1.1
Patchnames:
openSUSE Tumbleweed GA ocaml-4.12.1-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 ocaml Already fixed
SUSE Enterprise Storage 6 ocaml Already fixed
SUSE Linux Enterprise High Performance Computing 15 LTSS ocaml Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS ocaml Already fixed
SUSE Linux Enterprise Server 15 ESPOS ocaml Already fixed
SUSE Linux Enterprise Server 15 LTSS ocaml Already fixed
SUSE Linux Enterprise Server 15 SP1 LTSS ocaml Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 ocaml Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 ocaml Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 ocaml Already fixed
SUSE Linux Enterprise Software Bootstrap Kit 12 ocaml Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 ocaml Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 ocaml Not affected
SUSE Manager Proxy 4.0 ocaml Already fixed
SUSE Manager Retail Branch Server 4.0 ocaml Already fixed
SUSE Manager Server 4.0 ocaml Already fixed