Upstream information

CVE-2017-9300 at MITRE

Description

plugins\codec\libflac_plugin.dll in VideoLAN VLC media player 2.2.4 allows remote attackers to cause a denial of service (heap corruption and application crash) or possibly have unspecified other impact via a crafted FLAC file.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1041907 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.2
  • libvlc5 >= 2.2.6-32.3.1
  • libvlc5-debuginfo >= 2.2.6-32.3.1
  • libvlccore8 >= 2.2.6-32.3.1
  • libvlccore8-debuginfo >= 2.2.6-32.3.1
  • vlc >= 2.2.6-32.3.1
  • vlc-codec-gstreamer >= 2.2.6-32.3.1
  • vlc-codec-gstreamer-debuginfo >= 2.2.6-32.3.1
  • vlc-debuginfo >= 2.2.6-32.3.1
  • vlc-debugsource >= 2.2.6-32.3.1
  • vlc-devel >= 2.2.6-32.3.1
  • vlc-lang >= 2.2.6-32.3.1
  • vlc-noX >= 2.2.6-32.3.1
  • vlc-noX-debuginfo >= 2.2.6-32.3.1
  • vlc-qt >= 2.2.6-32.3.1
  • vlc-qt-debuginfo >= 2.2.6-32.3.1
Patchnames:
openSUSE-2017-1101
openSUSE Leap 42.3
  • libvlc5 >= 2.2.6-3.1
  • libvlc5-debuginfo >= 2.2.6-3.1
  • libvlccore8 >= 2.2.6-3.1
  • libvlccore8-debuginfo >= 2.2.6-3.1
  • vlc >= 2.2.6-3.1
  • vlc-codec-gstreamer >= 2.2.6-3.1
  • vlc-codec-gstreamer-debuginfo >= 2.2.6-3.1
  • vlc-debuginfo >= 2.2.6-3.1
  • vlc-debugsource >= 2.2.6-3.1
  • vlc-devel >= 2.2.6-3.1
  • vlc-lang >= 2.2.6-3.1
  • vlc-noX >= 2.2.6-3.1
  • vlc-noX-debuginfo >= 2.2.6-3.1
  • vlc-qt >= 2.2.6-3.1
  • vlc-qt-debuginfo >= 2.2.6-3.1
Patchnames:
openSUSE-2017-1100