Upstream information

CVE-2017-9148 at MITRE

Description

The TLS session cache in FreeRADIUS 2.1.1 through 2.1.7, 3.0.x before 3.0.14, 3.1.x before 2017-02-04, and 4.0.x before 2017-02-04 fails to reliably prevent resumption of an unauthenticated session, which allows remote attackers (such as malicious 802.1X supplicants) to bypass authentication via PEAP or TTLS.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.8
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 7.4
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High None
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1041445 [RESOLVED / FIXED], 1046141 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • freeradius-server >= 3.0.19-1.48
  • freeradius-server-doc >= 3.0.19-1.48
  • freeradius-server-krb5 >= 3.0.19-1.48
  • freeradius-server-ldap >= 3.0.19-1.48
  • freeradius-server-libs >= 3.0.19-1.48
  • freeradius-server-mysql >= 3.0.19-1.48
  • freeradius-server-perl >= 3.0.19-1.48
  • freeradius-server-postgresql >= 3.0.19-1.48
  • freeradius-server-python >= 3.0.19-1.48
  • freeradius-server-sqlite >= 3.0.19-1.48
  • freeradius-server-utils >= 3.0.19-1.48
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • freeradius-server >= 3.0.16-3.3.1
  • freeradius-server-devel >= 3.0.16-3.3.1
  • freeradius-server-krb5 >= 3.0.16-3.3.1
  • freeradius-server-ldap >= 3.0.16-3.3.1
  • freeradius-server-libs >= 3.0.16-3.3.1
  • freeradius-server-mysql >= 3.0.16-3.3.1
  • freeradius-server-perl >= 3.0.16-3.3.1
  • freeradius-server-postgresql >= 3.0.16-3.3.1
  • freeradius-server-python >= 3.0.16-3.3.1
  • freeradius-server-sqlite >= 3.0.16-3.3.1
  • freeradius-server-utils >= 3.0.16-3.3.1
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • freeradius-server >= 3.0.21-1.33
  • freeradius-server-devel >= 3.0.21-1.33
  • freeradius-server-krb5 >= 3.0.21-1.33
  • freeradius-server-ldap >= 3.0.21-1.33
  • freeradius-server-libs >= 3.0.21-1.33
  • freeradius-server-mysql >= 3.0.21-1.33
  • freeradius-server-perl >= 3.0.21-1.33
  • freeradius-server-postgresql >= 3.0.21-1.33
  • freeradius-server-python3 >= 3.0.21-1.33
  • freeradius-server-sqlite >= 3.0.21-1.33
  • freeradius-server-utils >= 3.0.21-1.33
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • freeradius-server >= 3.0.21-3.6.1
  • freeradius-server-devel >= 3.0.21-3.6.1
  • freeradius-server-krb5 >= 3.0.21-3.6.1
  • freeradius-server-ldap >= 3.0.21-3.6.1
  • freeradius-server-libs >= 3.0.21-3.6.1
  • freeradius-server-mysql >= 3.0.21-3.6.1
  • freeradius-server-perl >= 3.0.21-3.6.1
  • freeradius-server-postgresql >= 3.0.21-3.6.1
  • freeradius-server-python3 >= 3.0.21-3.6.1
  • freeradius-server-sqlite >= 3.0.21-3.6.1
  • freeradius-server-utils >= 3.0.21-3.6.1
SUSE Linux Enterprise Module for Server Applications 15
  • freeradius-server >= 3.0.16-1.41
  • freeradius-server-devel >= 3.0.16-1.41
  • freeradius-server-krb5 >= 3.0.16-1.41
  • freeradius-server-ldap >= 3.0.16-1.41
  • freeradius-server-libs >= 3.0.16-1.41
  • freeradius-server-mysql >= 3.0.16-1.41
  • freeradius-server-perl >= 3.0.16-1.41
  • freeradius-server-postgresql >= 3.0.16-1.41
  • freeradius-server-python >= 3.0.16-1.41
  • freeradius-server-sqlite >= 3.0.16-1.41
  • freeradius-server-utils >= 3.0.16-1.41
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • freeradius-server >= 2.1.1-7.24.1
  • freeradius-server-dialupadmin >= 2.1.1-7.24.1
  • freeradius-server-doc >= 2.1.1-7.24.1
  • freeradius-server-libs >= 2.1.1-7.24.1
  • freeradius-server-utils >= 2.1.1-7.24.1
Patchnames:
slessp4-freeradius-server-13192
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • freeradius-server >= 3.0.3-17.4.1
  • freeradius-server-doc >= 3.0.3-17.4.1
  • freeradius-server-krb5 >= 3.0.3-17.4.1
  • freeradius-server-ldap >= 3.0.3-17.4.1
  • freeradius-server-libs >= 3.0.3-17.4.1
  • freeradius-server-mysql >= 3.0.3-17.4.1
  • freeradius-server-perl >= 3.0.3-17.4.1
  • freeradius-server-postgresql >= 3.0.3-17.4.1
  • freeradius-server-python >= 3.0.3-17.4.1
  • freeradius-server-sqlite >= 3.0.3-17.4.1
  • freeradius-server-utils >= 3.0.3-17.4.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1056
SUSE Linux Enterprise Server 12 SP3
  • freeradius-server >= 3.0.14-1.8
  • freeradius-server-doc >= 3.0.14-1.8
  • freeradius-server-krb5 >= 3.0.14-1.8
  • freeradius-server-ldap >= 3.0.14-1.8
  • freeradius-server-libs >= 3.0.14-1.8
  • freeradius-server-mysql >= 3.0.14-1.8
  • freeradius-server-perl >= 3.0.14-1.8
  • freeradius-server-postgresql >= 3.0.14-1.8
  • freeradius-server-python >= 3.0.14-1.8
  • freeradius-server-sqlite >= 3.0.14-1.8
  • freeradius-server-utils >= 3.0.14-1.8
SUSE Linux Enterprise Server 12 SP4
  • freeradius-server >= 3.0.15-2.8.2
  • freeradius-server-doc >= 3.0.15-2.8.2
  • freeradius-server-krb5 >= 3.0.15-2.8.2
  • freeradius-server-ldap >= 3.0.15-2.8.2
  • freeradius-server-libs >= 3.0.15-2.8.2
  • freeradius-server-mysql >= 3.0.15-2.8.2
  • freeradius-server-perl >= 3.0.15-2.8.2
  • freeradius-server-postgresql >= 3.0.15-2.8.2
  • freeradius-server-python >= 3.0.15-2.8.2
  • freeradius-server-sqlite >= 3.0.15-2.8.2
  • freeradius-server-utils >= 3.0.15-2.8.2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • freeradius-server >= 3.0.3-17.4.1
  • freeradius-server-doc >= 3.0.3-17.4.1
  • freeradius-server-krb5 >= 3.0.3-17.4.1
  • freeradius-server-ldap >= 3.0.3-17.4.1
  • freeradius-server-libs >= 3.0.3-17.4.1
  • freeradius-server-mysql >= 3.0.3-17.4.1
  • freeradius-server-perl >= 3.0.3-17.4.1
  • freeradius-server-postgresql >= 3.0.3-17.4.1
  • freeradius-server-python >= 3.0.3-17.4.1
  • freeradius-server-sqlite >= 3.0.3-17.4.1
  • freeradius-server-utils >= 3.0.3-17.4.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1056
SUSE Linux Enterprise Software Development Kit 11 SP4
  • freeradius-server-devel >= 2.1.1-7.24.1
  • freeradius-server-libs >= 2.1.1-7.24.1
Patchnames:
sdksp4-freeradius-server-13192
SUSE Linux Enterprise Software Development Kit 12 SP2
  • freeradius-server-devel >= 3.0.3-17.4.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1056
SUSE Linux Enterprise Software Development Kit 12 SP3
  • freeradius-server-devel >= 3.0.14-1.8
SUSE Linux Enterprise Software Development Kit 12 SP4
  • freeradius-server-devel >= 3.0.15-2.8.2
SUSE Linux Enterprise Software Development Kit 12 SP5
  • freeradius-server-devel >= 3.0.19-1.48
openSUSE Tumbleweed
  • freeradius-server >= 3.0.23-1.5
  • freeradius-server-devel >= 3.0.23-1.5
  • freeradius-server-doc >= 3.0.23-1.5
  • freeradius-server-krb5 >= 3.0.23-1.5
  • freeradius-server-ldap >= 3.0.23-1.5
  • freeradius-server-ldap-schemas >= 3.0.23-1.5
  • freeradius-server-libs >= 3.0.23-1.5
  • freeradius-server-mysql >= 3.0.23-1.5
  • freeradius-server-perl >= 3.0.23-1.5
  • freeradius-server-postgresql >= 3.0.23-1.5
  • freeradius-server-python3 >= 3.0.23-1.5
  • freeradius-server-sqlite >= 3.0.23-1.5
  • freeradius-server-utils >= 3.0.23-1.5
Patchnames:
openSUSE Tumbleweed GA freeradius-server-3.0.23-1.5


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 freeradius-server Already fixed
SUSE Linux Enterprise Point of Service 11 SP3 freeradius-server Released
SUSE Linux Enterprise Point of Service Image Server 12 freeradius-server Released
SUSE Linux Enterprise Server 11 SP3 LTSS freeradius-server Affected
SUSE Linux Enterprise Server 11 SP4 freeradius-server Released
SUSE Linux Enterprise Server 11 SP4 LTSS freeradius-server Released
SUSE Linux Enterprise Server 12 LTSS freeradius-server Affected
SUSE Linux Enterprise Server 12 SP1 freeradius-server Unsupported
SUSE Linux Enterprise Server 12 SP2 freeradius-server Released
SUSE Linux Enterprise Server 12 SP2 BCL freeradius-server Released
SUSE Linux Enterprise Server 12 SP2 ESPOS freeradius-server Released
SUSE Linux Enterprise Server 12 SP2 LTSS freeradius-server Released
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON freeradius-server Released
SUSE Linux Enterprise Server 12 SP2 LTSS SAP freeradius-server Released
SUSE Linux Enterprise Server 12 SP3 BCL freeradius-server Already fixed
SUSE Linux Enterprise Server 12 SP3 ESPOS freeradius-server Already fixed
SUSE Linux Enterprise Server 12 SP3 LTSS freeradius-server Already fixed
SUSE Linux Enterprise Server 12 SP4 ESPOS freeradius-server Already fixed
SUSE Linux Enterprise Server 12 SP4 LTSS freeradius-server Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 freeradius-server Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 freeradius-server Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 freeradius-server Already fixed
SUSE Linux Enterprise Server for the Raspberry Pi freeradius-server Released
SUSE Linux Enterprise Software Development Kit 11 SP4 freeradius-server Released
SUSE Linux Enterprise Software Development Kit 12 freeradius-server Released
SUSE Linux Enterprise Software Development Kit 12 SP1 freeradius-server Unsupported
SUSE OpenStack Cloud 7 freeradius-server Released
SUSE OpenStack Cloud 8 freeradius-server Already fixed
SUSE OpenStack Cloud 9 freeradius-server Already fixed
SUSE OpenStack Cloud Crowbar 8 freeradius-server Already fixed
SUSE OpenStack Cloud Crowbar 9 freeradius-server Already fixed