Upstream information

CVE-2017-9122 at MITRE

Description

The quicktime_read_moov function in moov.c in libquicktime 1.2.4 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted mp4 file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.1 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:C AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Complete Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 5.3
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low High
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1044000 [RESOLVED / FIXED], 1044002 [RESOLVED / FIXED], 1044006 [RESOLVED / FIXED], 1044008 [RESOLVED / FIXED], 1044009 [RESOLVED / FIXED], 1044077 [RESOLVED / FIXED], 1044122 [RESOLVED / FIXED], 1051855 [RESOLVED / WORKSFORME], 1051859 [RESOLVED / WORKSFORME]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libquicktime >= 1.2.4cvs20150223-4.42
  • libquicktime-devel >= 1.2.4cvs20150223-4.42
  • libquicktime0 >= 1.2.4cvs20150223-4.42
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA libquicktime-1.2.4cvs20150223-4.42
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libquicktime >= 1.2.4+git20180804.fff99cd-1.19
  • libquicktime-devel >= 1.2.4+git20180804.fff99cd-1.19
  • libquicktime0 >= 1.2.4+git20180804.fff99cd-1.19
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA libquicktime-1.2.4+git20180804.fff99cd-1.19
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libquicktime >= 1.2.4+git20180804.fff99cd-1.19
  • libquicktime-devel >= 1.2.4+git20180804.fff99cd-1.19
  • libquicktime0 >= 1.2.4+git20180804.fff99cd-1.19
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA libquicktime-1.2.4+git20180804.fff99cd-1.19
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libquicktime >= 1.0.3-6.5.1
  • libquicktime-devel >= 1.0.3-6.5.1
Patchnames:
sdksp4-libquicktime-13222
SUSE Linux Enterprise Desktop 12 SP2
  • libquicktime-devel >= 1.2.4-13.1
  • libquicktime0 >= 1.2.4-13.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1107
SUSE-SLE-SDK-12-SP2-2017-1107
SUSE Linux Enterprise Desktop 12 SP4
  • libquicktime-devel >= 1.2.4-14.3.1
  • libquicktime0 >= 1.2.4-14.3.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libquicktime0-1.2.4-14.3.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libquicktime-devel-1.2.4-14.3.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libquicktime >= 1.2.4+git20180804.fff99cd-1.19
  • libquicktime-devel >= 1.2.4+git20180804.fff99cd-1.19
  • libquicktime0 >= 1.2.4+git20180804.fff99cd-1.19
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA libquicktime-1.2.4+git20180804.fff99cd-1.19
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Desktop Applications 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libquicktime >= 1.2.4cvs20150223-4.42
  • libquicktime-devel >= 1.2.4cvs20150223-4.42
  • libquicktime0 >= 1.2.4cvs20150223-4.42
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libquicktime-1.2.4cvs20150223-4.42
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libquicktime0 >= 1.2.4-14.3.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libquicktime0-1.2.4-14.3.1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libquicktime-devel >= 1.2.4-13.1
  • libquicktime0 >= 1.2.4-13.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1107
SUSE-SLE-SERVER-12-SP2-2017-1107
SUSE Linux Enterprise Server 12 SP4
  • libquicktime-devel >= 1.2.4-14.3.1
  • libquicktime0 >= 1.2.4-14.3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libquicktime0-1.2.4-14.3.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libquicktime-devel-1.2.4-14.3.1
SUSE Linux Enterprise Server 12 SP5
  • libquicktime-devel >= 1.2.4-14.3.1
  • libquicktime0 >= 1.2.4-14.3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libquicktime0-1.2.4-14.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libquicktime-devel-1.2.4-14.3.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libquicktime0 >= 1.2.4-13.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1107
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libquicktime-devel >= 1.2.4-14.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libquicktime-devel-1.2.4-14.3.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libquicktime-devel >= 1.2.4-14.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libquicktime-devel-1.2.4-14.3.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libquicktime-devel >= 1.2.4-13.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1107
openSUSE Leap 15.0
  • libquicktime0 >= 1.2.4cvs20150223-lp150.3.7
Patchnames:
openSUSE Leap 15.0 GA libquicktime0-1.2.4cvs20150223-lp150.3.7
openSUSE Leap 15.2
  • libquicktime0 >= 1.2.4+git20180804.fff99cd-lp152.1.5
Patchnames:
openSUSE Leap 15.2 GA libquicktime0-1.2.4+git20180804.fff99cd-lp152.1.2
openSUSE Leap 15.3
  • libquicktime0 >= 1.2.4+git20180804.fff99cd-1.19
Patchnames:
openSUSE Leap 15.3 GA libquicktime0-1.2.4+git20180804.fff99cd-1.19
openSUSE Leap 15.4
  • libquicktime0 >= 1.2.4+git20180804.fff99cd-1.19
Patchnames:
openSUSE Leap 15.4 GA libquicktime0-1.2.4+git20180804.fff99cd-1.19
openSUSE Tumbleweed
  • libquicktime >= 1.2.4+git20180804.fff99cd-2.10
  • libquicktime-32bit >= 1.2.4+git20180804.fff99cd-2.10
  • libquicktime-devel >= 1.2.4+git20180804.fff99cd-2.10
  • libquicktime-lang >= 1.2.4+git20180804.fff99cd-2.10
  • libquicktime-tools >= 1.2.4+git20180804.fff99cd-2.10
  • libquicktime0 >= 1.2.4+git20180804.fff99cd-2.10
  • libquicktime0-32bit >= 1.2.4+git20180804.fff99cd-2.10
Patchnames:
openSUSE Tumbleweed GA libquicktime-1.2.4+git20180804.fff99cd-2.10


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP5 libquicktime Affected
SUSE Linux Enterprise Server 12 SP5 libquicktime Affected
SUSE Linux Enterprise Server 12-LTSS libquicktime Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libquicktime Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 libquicktime Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 12 SP2-BCL libquicktime Affected
SUSE Linux Enterprise Server 12 SP4 libquicktime Affected
SUSE Linux Enterprise Server 12 SP4-LTSS libquicktime Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libquicktime Affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 libquicktime Affected
SUSE Linux Enterprise Desktop 11 SP4 libquicktime Released
SUSE Linux Enterprise Desktop 12 libquicktime Affected
SUSE Linux Enterprise Desktop 12 SP1 libquicktime Affected
SUSE Linux Enterprise Desktop 12 SP2 libquicktime Released
SUSE Linux Enterprise Desktop 12 SP3 libquicktime Affected
SUSE Linux Enterprise Desktop 12 SP4 libquicktime Affected
SUSE Linux Enterprise Server 11 SP4 libquicktime Released
SUSE Linux Enterprise Server 12 libquicktime Affected
SUSE Linux Enterprise Server 12 SP1 libquicktime Affected
SUSE Linux Enterprise Server 12 SP1-LTSS libquicktime Affected
SUSE Linux Enterprise Server 12 SP2 libquicktime Released
SUSE Linux Enterprise Server 12 SP2-ESPOS libquicktime Affected
SUSE Linux Enterprise Server 12 SP2-LTSS libquicktime Affected
SUSE Linux Enterprise Server 12 SP3 libquicktime Affected
SUSE Linux Enterprise Server 12 SP3-BCL libquicktime Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS libquicktime Affected
SUSE Linux Enterprise Server 12 SP3-LTSS libquicktime Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS libquicktime Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 libquicktime Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 libquicktime Released
SUSE Linux Enterprise Server for SAP Applications 12 libquicktime Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libquicktime Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libquicktime Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libquicktime Affected
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 libquicktime Released
SUSE Linux Enterprise Software Development Kit 11 SP4 libquicktime Released
SUSE Linux Enterprise Software Development Kit 12 libquicktime Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libquicktime Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 libquicktime Released
SUSE Linux Enterprise Software Development Kit 12 SP3 libquicktime Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libquicktime Affected
SUSE OpenStack Cloud 7 libquicktime Affected
SUSE OpenStack Cloud 8 libquicktime Affected
SUSE OpenStack Cloud 9 libquicktime Affected
SUSE OpenStack Cloud Crowbar 8 libquicktime Affected
SUSE OpenStack Cloud Crowbar 9 libquicktime Affected


SUSE Timeline for this CVE

CVE page created: Mon Jun 12 13:16:50 2017
CVE page last modified: Fri Jan 20 13:36:22 2023