Upstream information

CVE-2017-7585 at MITRE

Description

In libsndfile before 1.0.28, an error in the "flac_buffer_copy()" function (flac.c) can be exploited to cause a stack-based buffer overflow via a specially crafted FLAC file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 6.8
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None Partial
Integrity Impact None Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 7.3
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Access Vector Local Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None Low
Integrity Impact None Low
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1033054 [RESOLVED / FIXED], 1033914 [RESOLVED / FIXED], 1033915 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libsndfile1 >= 1.0.25-35.1
  • libsndfile1-32bit >= 1.0.25-35.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-607
SUSE-SLE-DESKTOP-12-SP1-2017-834
SUSE Linux Enterprise Desktop 12 SP2
  • libsndfile1 >= 1.0.25-35.1
  • libsndfile1-32bit >= 1.0.25-35.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-607
SUSE-SLE-DESKTOP-12-SP2-2017-834
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP3
  • libsndfile1 >= 1.0.25-35.1
  • libsndfile1-32bit >= 1.0.25-35.1
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • libsndfile1 >= 1.0.25-36.16.1
  • libsndfile1-32bit >= 1.0.25-36.16.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libsndfile-devel >= 1.0.28-5.5.1
  • libsndfile1 >= 1.0.28-5.5.1
SUSE Linux Enterprise Module for Basesystem 15
  • libsndfile-devel >= 1.0.28-3.24
  • libsndfile1 >= 1.0.28-3.24
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP3
  • libsndfile1-32bit >= 1.0.28-5.5.1
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libsndfile >= 1.0.20-2.18.1
  • libsndfile-32bit >= 1.0.20-2.18.1
  • libsndfile-x86 >= 1.0.20-2.18.1
Patchnames:
slessp4-libsndfile-13064
slessp4-libsndfile-13099
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libsndfile1 >= 1.0.25-35.1
  • libsndfile1-32bit >= 1.0.25-35.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-607
SUSE-SLE-SERVER-12-SP1-2017-834
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libsndfile1 >= 1.0.25-35.1
  • libsndfile1-32bit >= 1.0.25-35.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-607
SUSE-SLE-SERVER-12-SP2-2017-834
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libsndfile1 >= 1.0.25-35.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-607
SUSE-SLE-RPI-12-SP2-2017-834
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libsndfile-devel >= 1.0.20-2.18.1
Patchnames:
sdksp4-libsndfile-13064
sdksp4-libsndfile-13099
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libsndfile-devel >= 1.0.25-35.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-607
SUSE-SLE-SDK-12-SP1-2017-834
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libsndfile-devel >= 1.0.25-35.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-607
SUSE-SLE-SDK-12-SP2-2017-834
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libsndfile-devel >= 1.0.25-35.1
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libsndfile-devel >= 1.0.25-36.16.1
openSUSE Leap 15.0
  • libsndfile1 >= 1.0.28-lp150.2.5
Patchnames:
openSUSE Leap 15.0 GA libsndfile1-1.0.28-lp150.2.5
openSUSE Tumbleweed
  • libsndfile-devel >= 1.0.31-2.2
  • libsndfile1 >= 1.0.31-2.2
  • libsndfile1-32bit >= 1.0.31-2.2
Patchnames:
openSUSE Tumbleweed GA libsndfile-devel-1.0.31-2.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libsndfile In progress
SUSE Linux Enterprise Desktop 12 SP1 libsndfile Released
SUSE Linux Enterprise Desktop 12 SP2 libsndfile Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libsndfile Released
SUSE Linux Enterprise Point of Service 11 SP3 libsndfile In progress
SUSE Linux Enterprise Server 11 SP3 LTSS libsndfile Not affected
SUSE Linux Enterprise Server 11 SP4 libsndfile Released
SUSE Linux Enterprise Server 11 SP4 LTSS libsndfile In progress
SUSE Linux Enterprise Server 12 LTSS libsndfile Already fixed
SUSE Linux Enterprise Server 12 SP1 libsndfile Released
SUSE Linux Enterprise Server 12 SP2 libsndfile Released
SUSE Linux Enterprise Server 12 SP2 BCL libsndfile In progress
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON libsndfile In progress
SUSE Linux Enterprise Server 12 SP2 LTSS SAP libsndfile In progress
SUSE Linux Enterprise Server 12 SP3 BCL libsndfile In progress
SUSE Linux Enterprise Server 12 SP3 ESPOS libsndfile In progress
SUSE Linux Enterprise Server 12 SP3 LTSS libsndfile In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS libsndfile In progress
SUSE Linux Enterprise Server 12 SP4 LTSS libsndfile In progress
SUSE Linux Enterprise Server 12 SP5 libsndfile Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libsndfile In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libsndfile In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libsndfile Released
SUSE Linux Enterprise Server for the Raspberry Pi libsndfile Released
SUSE Linux Enterprise Software Development Kit 11 SP4 libsndfile Released
SUSE Linux Enterprise Software Development Kit 12 libsndfile Released
SUSE Linux Enterprise Software Development Kit 12 SP1 libsndfile Released
SUSE OpenStack Cloud 8 libsndfile In progress
SUSE OpenStack Cloud 9 libsndfile In progress
SUSE OpenStack Cloud Crowbar 8 libsndfile In progress
SUSE OpenStack Cloud Crowbar 9 libsndfile In progress