Upstream information

CVE-2017-7546 at MITRE

Description

PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to incorrect authentication flaw allowing remote attackers to gain access to database accounts with an empty password.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.4
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:N/C:P/I:P/A:N
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 6.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High None
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1051684 [RESOLVED / FIXED], 1054365 [RESOLVED / FIXED], 1140876 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • postgresql94-devel >= 9.4.13-0.23.5.1
Patchnames:
sdksp4-postgresql94-13247
SUSE Linux Enterprise Desktop 12 SP2
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-devel >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-devel >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1460
SUSE-SLE-DESKTOP-12-SP2-2017-1461
SUSE-SLE-SDK-12-SP2-2017-1460
SUSE-SLE-SDK-12-SP2-2017-1461
SUSE Linux Enterprise Desktop 12 SP3
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-devel >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1461
SUSE-SLE-SDK-12-SP3-2017-1461
SUSE Linux Enterprise Desktop 12 SP4
  • libecpg6 >= 10.5-1.3.1
  • libpq5 >= 10.5-1.3.1
  • libpq5-32bit >= 10.5-1.3.1
  • postgresql10 >= 10.5-1.3.2
  • postgresql10-devel >= 10.5-1.3.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libecpg6-10.5-1.3.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA postgresql10-devel-10.5-1.3.1
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libecpg6 >= 10.10-1.15.1
  • libpq5 >= 10.10-1.15.1
  • libpq5-32bit >= 10.10-1.15.1
  • postgresql10 >= 10.10-1.15.1
  • postgresql10-contrib >= 10.10-1.15.1
  • postgresql10-docs >= 10.10-1.15.1
  • postgresql10-plperl >= 10.10-1.15.1
  • postgresql10-plpython >= 10.10-1.15.1
  • postgresql10-pltcl >= 10.10-1.15.1
  • postgresql10-server >= 10.10-1.15.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libecpg6-10.10-1.15.1
SUSE Linux Enterprise Point of Sale 11 SP3
  • libecpg6 >= 9.4.13-0.23.5.1
  • libpq5 >= 9.4.13-0.23.5.1
  • postgresql94 >= 9.4.13-0.23.5.1
  • postgresql94-contrib >= 9.4.13-0.23.5.1
  • postgresql94-docs >= 9.4.13-0.23.5.1
  • postgresql94-server >= 9.4.13-0.23.5.1
Patchnames:
sleposp3-postgresql94-13247
SUSE Linux Enterprise Server 11 SP3-LTSS
  • libecpg6 >= 9.4.13-0.23.5.1
  • libpq5 >= 9.4.13-0.23.5.1
  • libpq5-32bit >= 9.4.13-0.23.5.1
  • postgresql94 >= 9.4.13-0.23.5.1
  • postgresql94-contrib >= 9.4.13-0.23.5.1
  • postgresql94-docs >= 9.4.13-0.23.5.1
  • postgresql94-server >= 9.4.13-0.23.5.1
Patchnames:
slessp3-postgresql94-13247
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libecpg6 >= 9.4.13-0.23.5.1
  • libpq5 >= 9.4.13-0.23.5.1
  • libpq5-32bit >= 9.4.13-0.23.5.1
  • postgresql94 >= 9.4.13-0.23.5.1
  • postgresql94-contrib >= 9.4.13-0.23.5.1
  • postgresql94-devel >= 9.4.13-0.23.5.1
  • postgresql94-docs >= 9.4.13-0.23.5.1
  • postgresql94-server >= 9.4.13-0.23.5.1
Patchnames:
sdksp4-postgresql94-13247
slessp4-postgresql94-13247
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1460
SUSE-SLE-SERVER-12-SP1-2017-1461
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-devel >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-devel >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1460
SUSE-SLE-SDK-12-SP2-2017-1461
SUSE-SLE-SERVER-12-SP2-2017-1460
SUSE-SLE-SERVER-12-SP2-2017-1461
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-devel >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1461
SUSE-SLE-SERVER-12-SP3-2017-1461
SUSE Linux Enterprise Server 12 SP4
  • libecpg6 >= 10.5-1.3.1
  • libpq5 >= 10.5-1.3.1
  • libpq5-32bit >= 10.5-1.3.1
  • postgresql10 >= 10.5-1.3.2
  • postgresql10-contrib >= 10.5-1.3.2
  • postgresql10-devel >= 10.5-1.3.1
  • postgresql10-docs >= 10.5-1.3.2
  • postgresql10-server >= 10.5-1.3.2
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libecpg6-10.5-1.3.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA postgresql10-devel-10.5-1.3.1
SUSE Linux Enterprise Server 12 SP5
  • libecpg6 >= 10.10-1.15.1
  • libpq5 >= 10.10-1.15.1
  • libpq5-32bit >= 10.10-1.15.1
  • postgresql10 >= 10.10-1.15.1
  • postgresql10-contrib >= 10.10-1.15.1
  • postgresql10-devel >= 10.10-1.15.1
  • postgresql10-docs >= 10.10-1.15.1
  • postgresql10-plperl >= 10.10-1.15.1
  • postgresql10-plpython >= 10.10-1.15.1
  • postgresql10-pltcl >= 10.10-1.15.1
  • postgresql10-server >= 10.10-1.15.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libecpg6-10.10-1.15.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA postgresql10-devel-10.10-1.15.1
SUSE Linux Enterprise Server 12-LTSS
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql93 >= 9.3.18-25.5.1
  • postgresql93-contrib >= 9.3.18-25.5.1
  • postgresql93-docs >= 9.3.18-25.5.1
  • postgresql93-server >= 9.3.18-25.5.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-2017-1368
SUSE-SLE-SERVER-12-2017-1460
SUSE-SLE-SERVER-12-2017-1461
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1460
SUSE-SLE-RPI-12-SP2-2017-1461
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2017-1460
SUSE-SLE-SAP-12-SP1-2017-1461
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • postgresql10-devel >= 10.5-1.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA postgresql10-devel-10.5-1.3.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • postgresql10-devel >= 10.10-1.15.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA postgresql10-devel-10.10-1.15.1
SUSE Linux Enterprise Server for SAP Applications 12
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql93 >= 9.3.18-25.5.1
  • postgresql93-contrib >= 9.3.18-25.5.1
  • postgresql93-docs >= 9.3.18-25.5.1
  • postgresql93-server >= 9.3.18-25.5.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SAP-12-2017-1368
SUSE-SLE-SAP-12-2017-1460
SUSE-SLE-SAP-12-2017-1461
SUSE Linux Enterprise Software Development Kit 12 SP2
  • postgresql94-devel >= 9.4.13-21.5.1
  • postgresql96-devel >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1460
SUSE-SLE-SDK-12-SP2-2017-1461
SUSE Linux Enterprise Software Development Kit 12 SP3
  • postgresql96-devel >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1461
SUSE OpenStack Cloud 6
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-OpenStack-Cloud-6-2017-1460
SUSE-OpenStack-Cloud-6-2017-1461
openSUSE Leap 15.0
  • postgresql96 >= 9.6.8-lp150.1.2
  • postgresql96-server >= 9.6.8-lp150.1.2
Patchnames:
openSUSE Leap 15.0 GA postgresql96-9.6.8-lp150.1.2
openSUSE Leap 15.2
  • postgresql96 >= 9.6.17-lp152.1.4
  • postgresql96-server >= 9.6.17-lp152.1.4
Patchnames:
openSUSE Leap 15.2 GA postgresql96-9.6.17-lp152.1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 postgresql10 In progress
HPE Helion OpenStack 8 postgresql13 In progress
HPE Helion OpenStack 8 postgresql96 In progress
SUSE Linux Enterprise Desktop 12 SP2 postgresql Ignore
SUSE Linux Enterprise Desktop 12 SP2 postgresql94 Released
SUSE Linux Enterprise Desktop 12 SP2 postgresql96 Released
SUSE Linux Enterprise Desktop 12 SP3 postgresql96 Released
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql10 In progress
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql12 In progress
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql13 In progress
SUSE Linux Enterprise High Performance Computing 15 LTSS postgresql10 Already fixed
SUSE Linux Enterprise Point of Service 11 SP3 postgresql94 In progress
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql Ignore
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql91 Ignore
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql94 Released
SUSE Linux Enterprise Server 11 SP4 LTSS postgresql Ignore
SUSE Linux Enterprise Server 11 SP4 LTSS postgresql94 In progress
SUSE Linux Enterprise Server 12 LTSS postgresql94 Released
SUSE Linux Enterprise Server 12 LTSS postgresql96 Released
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql94 Released
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql96 Released
SUSE Linux Enterprise Server 12 SP2 postgresql Ignore
SUSE Linux Enterprise Server 12 SP2 postgresql94 Released
SUSE Linux Enterprise Server 12 SP2 postgresql96 Released
SUSE Linux Enterprise Server 12 SP2 BCL postgresql10 In progress
SUSE Linux Enterprise Server 12 SP2 BCL postgresql13 In progress
SUSE Linux Enterprise Server 12 SP2 BCL postgresql94 In progress
SUSE Linux Enterprise Server 12 SP2 BCL postgresql96 In progress
SUSE Linux Enterprise Server 12 SP3 postgresql96 Released
SUSE Linux Enterprise Server 12 SP3 BCL postgresql10 In progress
SUSE Linux Enterprise Server 12 SP3 BCL postgresql13 In progress
SUSE Linux Enterprise Server 12 SP3 BCL postgresql96 In progress
SUSE Linux Enterprise Server 12 SP3 ESPOS postgresql10 In progress
SUSE Linux Enterprise Server 12 SP3 ESPOS postgresql13 In progress
SUSE Linux Enterprise Server 12 SP3 ESPOS postgresql96 In progress
SUSE Linux Enterprise Server 12 SP3 LTSS postgresql10 In progress
SUSE Linux Enterprise Server 12 SP3 LTSS postgresql13 In progress
SUSE Linux Enterprise Server 12 SP3 LTSS postgresql96 In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS postgresql10 In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS postgresql13 In progress
SUSE Linux Enterprise Server 12 SP4 LTSS postgresql10 In progress
SUSE Linux Enterprise Server 12 SP4 LTSS postgresql13 In progress
SUSE Linux Enterprise Server 12 SP5 postgresql10 In progress
SUSE Linux Enterprise Server 12 SP5 postgresql12 In progress
SUSE Linux Enterprise Server 12 SP5 postgresql13 In progress
SUSE Linux Enterprise Server 15 ESPOS postgresql10 Already fixed
SUSE Linux Enterprise Server 15 LTSS postgresql10 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 postgresql Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postgresql10 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postgresql13 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postgresql96 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 postgresql10 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 postgresql13 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql10 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql12 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql13 In progress
SUSE Linux Enterprise Server for SAP Applications 15 postgresql10 Already fixed
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 postgresql94 Released
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 postgresql96 Released
SUSE Linux Enterprise Software Development Kit 12 SP2 postgresql Ignore
SUSE Linux Enterprise Workstation Extension 12 SP2 postgresql Ignore
SUSE OpenStack Cloud 8 postgresql10 In progress
SUSE OpenStack Cloud 8 postgresql13 In progress
SUSE OpenStack Cloud 8 postgresql96 In progress
SUSE OpenStack Cloud 9 postgresql10 In progress
SUSE OpenStack Cloud 9 postgresql13 In progress
SUSE OpenStack Cloud Crowbar 8 postgresql10 In progress
SUSE OpenStack Cloud Crowbar 8 postgresql13 In progress
SUSE OpenStack Cloud Crowbar 8 postgresql96 In progress
SUSE OpenStack Cloud Crowbar 9 postgresql10 In progress
SUSE OpenStack Cloud Crowbar 9 postgresql13 In progress