Upstream information

CVE-2017-7401 at MITRE

Description

Incorrect interaction of the parse_packet() and parse_part_sign_sha256() functions in network.c in collectd 5.7.1 and earlier allows remote attackers to cause a denial of service (infinite loop) of a collectd instance (configured with "SecurityLevel None" and with empty "AuthFile" options) via a crafted UDP packet.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 4.3
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1032307 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • collectd >= 5.10.0-1.108
  • collectd-plugin-connectivity >= 5.10.0-1.108
  • collectd-plugin-dbi >= 5.10.0-1.108
  • collectd-plugin-ipmi >= 5.10.0-1.108
  • collectd-plugin-java >= 5.10.0-1.108
  • collectd-plugin-lua >= 5.10.0-1.108
  • collectd-plugin-mcelog >= 5.10.0-1.108
  • collectd-plugin-memcachec >= 5.10.0-1.108
  • collectd-plugin-mysql >= 5.10.0-1.108
  • collectd-plugin-notify-desktop >= 5.10.0-1.108
  • collectd-plugin-nut >= 5.10.0-1.108
  • collectd-plugin-openldap >= 5.10.0-1.108
  • collectd-plugin-ovs >= 5.10.0-1.108
  • collectd-plugin-pcie >= 5.10.0-1.108
  • collectd-plugin-pinba >= 5.10.0-1.108
  • collectd-plugin-postgresql >= 5.10.0-1.108
  • collectd-plugin-procevent >= 5.10.0-1.108
  • collectd-plugin-python3 >= 5.10.0-1.108
  • collectd-plugin-smart >= 5.10.0-1.108
  • collectd-plugin-snmp >= 5.10.0-1.108
  • collectd-plugin-synproxy >= 5.10.0-1.108
  • collectd-plugin-sysevent >= 5.10.0-1.108
  • collectd-plugin-uptime >= 5.10.0-1.108
  • collectd-plugin-virt >= 5.10.0-1.108
  • collectd-plugin-write_stackdriver >= 5.10.0-1.108
  • collectd-plugin-write_syslog >= 5.10.0-1.108
  • collectd-plugins-all >= 5.10.0-1.108
  • collectd-spamassassin >= 5.10.0-1.108
  • collectd-web >= 5.10.0-1.108
  • collectd-web-js >= 5.10.0-1.108
  • libcollectdclient-devel >= 5.10.0-1.108
  • libcollectdclient1 >= 5.10.0-1.108
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA collectd-5.10.0-1.108
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • collectd >= 5.10.0-1.108
  • collectd-plugin-connectivity >= 5.10.0-1.108
  • collectd-plugin-dbi >= 5.10.0-1.108
  • collectd-plugin-ipmi >= 5.10.0-1.108
  • collectd-plugin-java >= 5.10.0-1.108
  • collectd-plugin-lua >= 5.10.0-1.108
  • collectd-plugin-mcelog >= 5.10.0-1.108
  • collectd-plugin-memcachec >= 5.10.0-1.108
  • collectd-plugin-mysql >= 5.10.0-1.108
  • collectd-plugin-notify-desktop >= 5.10.0-1.108
  • collectd-plugin-nut >= 5.10.0-1.108
  • collectd-plugin-openldap >= 5.10.0-1.108
  • collectd-plugin-ovs >= 5.10.0-1.108
  • collectd-plugin-pcie >= 5.10.0-1.108
  • collectd-plugin-pinba >= 5.10.0-1.108
  • collectd-plugin-postgresql >= 5.10.0-1.108
  • collectd-plugin-procevent >= 5.10.0-1.108
  • collectd-plugin-python3 >= 5.10.0-1.108
  • collectd-plugin-smart >= 5.10.0-1.108
  • collectd-plugin-snmp >= 5.10.0-1.108
  • collectd-plugin-synproxy >= 5.10.0-1.108
  • collectd-plugin-sysevent >= 5.10.0-1.108
  • collectd-plugin-uptime >= 5.10.0-1.108
  • collectd-plugin-virt >= 5.10.0-1.108
  • collectd-plugin-write_stackdriver >= 5.10.0-1.108
  • collectd-plugin-write_syslog >= 5.10.0-1.108
  • collectd-plugins-all >= 5.10.0-1.108
  • collectd-spamassassin >= 5.10.0-1.108
  • collectd-web >= 5.10.0-1.108
  • collectd-web-js >= 5.10.0-1.108
  • libcollectdclient-devel >= 5.10.0-1.108
  • libcollectdclient1 >= 5.10.0-1.108
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA collectd-5.10.0-1.108
SUSE Lifecycle Management Server 1.3
  • collectd >= 4.9.4-0.31.1
  • libcollectdclient-devel >= 4.9.4-0.31.1
  • libcollectdclient0 >= 4.9.4-0.31.1
Patchnames:
sleslms13-collectd-13121
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • collectd >= 5.12.0-150400.1.11
  • collectd-plugin-buddyinfo >= 5.12.0-150400.1.11
  • collectd-plugin-connectivity >= 5.12.0-150400.1.11
  • collectd-plugin-dbi >= 5.12.0-150400.1.11
  • collectd-plugin-ipmi >= 5.12.0-150400.1.11
  • collectd-plugin-java >= 5.12.0-150400.1.11
  • collectd-plugin-logparser >= 5.12.0-150400.1.11
  • collectd-plugin-lua >= 5.12.0-150400.1.11
  • collectd-plugin-mcelog >= 5.12.0-150400.1.11
  • collectd-plugin-memcachec >= 5.12.0-150400.1.11
  • collectd-plugin-mysql >= 5.12.0-150400.1.11
  • collectd-plugin-notify-desktop >= 5.12.0-150400.1.11
  • collectd-plugin-nut >= 5.12.0-150400.1.11
  • collectd-plugin-openldap >= 5.12.0-150400.1.11
  • collectd-plugin-ovs >= 5.12.0-150400.1.11
  • collectd-plugin-pcie >= 5.12.0-150400.1.11
  • collectd-plugin-pinba >= 5.12.0-150400.1.11
  • collectd-plugin-postgresql >= 5.12.0-150400.1.11
  • collectd-plugin-procevent >= 5.12.0-150400.1.11
  • collectd-plugin-python3 >= 5.12.0-150400.1.11
  • collectd-plugin-smart >= 5.12.0-150400.1.11
  • collectd-plugin-snmp >= 5.12.0-150400.1.11
  • collectd-plugin-synproxy >= 5.12.0-150400.1.11
  • collectd-plugin-sysevent >= 5.12.0-150400.1.11
  • collectd-plugin-ubi >= 5.12.0-150400.1.11
  • collectd-plugin-uptime >= 5.12.0-150400.1.11
  • collectd-plugin-virt >= 5.12.0-150400.1.11
  • collectd-plugin-write_influxdb_udp >= 5.12.0-150400.1.11
  • collectd-plugin-write_stackdriver >= 5.12.0-150400.1.11
  • collectd-plugin-write_syslog >= 5.12.0-150400.1.11
  • collectd-plugins-all >= 5.12.0-150400.1.11
  • collectd-spamassassin >= 5.12.0-150400.1.11
  • collectd-web >= 5.12.0-150400.1.11
  • collectd-web-js >= 5.12.0-150400.1.11
  • libcollectdclient-devel >= 5.12.0-150400.1.11
  • libcollectdclient1 >= 5.12.0-150400.1.11
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA collectd-5.12.0-150400.1.11
SUSE WebYast 1.3
  • collectd >= 4.9.4-0.31.1
  • libcollectdclient-devel >= 4.9.4-0.31.1
  • libcollectdclient0 >= 4.9.4-0.31.1
Patchnames:
slewyst13-collectd-13121
openSUSE Tumbleweed
  • collectd >= 5.12.0-7.2
  • collectd-plugin-amqp >= 5.12.0-7.2
  • collectd-plugin-buddyinfo >= 5.12.0-7.2
  • collectd-plugin-connectivity >= 5.12.0-7.2
  • collectd-plugin-dbi >= 5.12.0-7.2
  • collectd-plugin-gps >= 5.12.0-7.2
  • collectd-plugin-ipmi >= 5.12.0-7.2
  • collectd-plugin-java >= 5.12.0-7.2
  • collectd-plugin-logparser >= 5.12.0-7.2
  • collectd-plugin-lua >= 5.12.0-7.2
  • collectd-plugin-mcelog >= 5.12.0-7.2
  • collectd-plugin-memcachec >= 5.12.0-7.2
  • collectd-plugin-modbus >= 5.12.0-7.2
  • collectd-plugin-mqtt >= 5.12.0-7.2
  • collectd-plugin-mysql >= 5.12.0-7.2
  • collectd-plugin-notify-desktop >= 5.12.0-7.2
  • collectd-plugin-nut >= 5.12.0-7.2
  • collectd-plugin-openldap >= 5.12.0-7.2
  • collectd-plugin-ovs >= 5.12.0-7.2
  • collectd-plugin-pcie >= 5.12.0-7.2
  • collectd-plugin-pinba >= 5.12.0-7.2
  • collectd-plugin-postgresql >= 5.12.0-7.2
  • collectd-plugin-procevent >= 5.12.0-7.2
  • collectd-plugin-python3 >= 5.12.0-7.2
  • collectd-plugin-sigrok >= 5.12.0-7.2
  • collectd-plugin-smart >= 5.12.0-7.2
  • collectd-plugin-snmp >= 5.12.0-7.2
  • collectd-plugin-synproxy >= 5.12.0-7.2
  • collectd-plugin-sysevent >= 5.12.0-7.2
  • collectd-plugin-ubi >= 5.12.0-7.2
  • collectd-plugin-uptime >= 5.12.0-7.2
  • collectd-plugin-virt >= 5.12.0-7.2
  • collectd-plugin-write_influxdb_udp >= 5.12.0-7.2
  • collectd-plugin-write_stackdriver >= 5.12.0-7.2
  • collectd-plugin-write_syslog >= 5.12.0-7.2
  • collectd-plugins-all >= 5.12.0-7.2
  • collectd-spamassassin >= 5.12.0-7.2
  • collectd-web >= 5.12.0-7.2
  • collectd-web-js >= 5.12.0-7.2
  • libcollectdclient-devel >= 5.12.0-7.2
  • libcollectdclient1 >= 5.12.0-7.2
Patchnames:
openSUSE Tumbleweed GA collectd-5.12.0-7.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 collectd Already fixed
SUSE Enterprise Storage 7.1 collectd Already fixed
SUSE Linux Enterprise Real Time 15 SP3 collectd Already fixed
SUSE Manager Proxy 4.2 collectd Already fixed
SUSE Manager Retail Branch Server 4.2 collectd Already fixed
SUSE Manager Server 4.2 collectd Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 collectd Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS collectd Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS collectd Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 collectd Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS collectd Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS collectd Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 collectd Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP3 collectd Already fixed
SUSE Linux Enterprise Server 15 SP2 collectd Already fixed
SUSE Linux Enterprise Server 15 SP2-LTSS collectd Already fixed
SUSE Linux Enterprise Server 15 SP3 collectd Already fixed
SUSE Linux Enterprise Server 15 SP3-LTSS collectd Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 collectd Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 collectd Already fixed
Products past their end of life and not receiving proactive updates anymore.
SUSE Lifecycle Management Server 1.3 collectd Released
SUSE Linux Enterprise Desktop 15 SP2 collectd Already fixed
SUSE Linux Enterprise Desktop 15 SP3 collectd Already fixed
SUSE Linux Enterprise Real Time 15 SP2 collectd Already fixed
SUSE Linux Enterprise Server 15 SP2-BCL collectd Already fixed
SUSE Linux Enterprise Server 15 SP3-BCL collectd Already fixed
SUSE Linux Enterprise Server for SAP All-in-One 11 SP4 collectd Released
SUSE Manager Proxy 4.1 collectd Already fixed
SUSE Manager Retail Branch Server 4.1 collectd Already fixed
SUSE Manager Server 4.1 collectd Already fixed
SUSE WebYast 1.3 collectd Released
WebYaST for SLE-11 collectd Released


SUSE Timeline for this CVE

CVE page created: Mon Apr 3 17:52:12 2017
CVE page last modified: Fri Jan 20 13:31:14 2023