Upstream information

CVE-2017-6891 at MITRE

Description

Two errors in the "asn1_find_node()" function (lib/parser_aux.c) within GnuTLS libtasn1 version 4.10 can be exploited to cause a stacked-based buffer overflow by tricking a user into processing a specially crafted assignments file via the e.g. asn1Coding utility.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 3.3
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:L/AC:M/Au:N/C:N/I:P/A:P
Access Vector Network Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 5.1
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High Low
Availability Impact High Low
SUSE Bugzilla entry: 1040621 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability Extension 11 SP4
  • gnutls >= 2.4.1-24.39.70.1
  • libgnutls-extra26 >= 2.4.1-24.39.70.1
Patchnames:
slehasp4-gnutls-13212
SUSE Linux Enterprise Server 11 SP4
  • gnutls >= 2.4.1-24.39.70.1
  • libgnutls-extra26 >= 2.4.1-24.39.70.1
  • libgnutls26 >= 2.4.1-24.39.70.1
  • libgnutls26-32bit >= 2.4.1-24.39.70.1
  • libgnutls26-x86 >= 2.4.1-24.39.70.1
Patchnames:
slessp4-gnutls-13212
SUSE Linux Enterprise Software Development Kit 11 SP4
  • gnutls >= 2.4.1-24.39.70.1
  • libgnutls-devel >= 2.4.1-24.39.70.1
  • libgnutls-extra-devel >= 2.4.1-24.39.70.1
  • libgnutls-extra26 >= 2.4.1-24.39.70.1
Patchnames:
sdksp4-gnutls-13212


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 gnutls Unsupported
SUSE Linux Enterprise Desktop 12 SP1 libtasn1 Unsupported
SUSE Linux Enterprise Desktop 12 SP2 gnutls Ignore
SUSE Linux Enterprise High Availability Extension 11 SP4 gnutls Released
SUSE Linux Enterprise SDK 11 SP4 gnutls Released
SUSE Linux Enterprise SDK 12 SP1 gnutls Unsupported
SUSE Linux Enterprise SDK 12 SP1 libtasn1 Unsupported
SUSE Linux Enterprise SDK 12 SP2 gnutls Ignore
SUSE Linux Enterprise Server 11 SP3 LTSS gnutls Affected
SUSE Linux Enterprise Server 11 SP4 gnutls Released
SUSE Linux Enterprise Server 12 GA gnutls Ignore
SUSE Linux Enterprise Server 12 SP1 gnutls Unsupported
SUSE Linux Enterprise Server 12 SP1 libtasn1 Unsupported
SUSE Linux Enterprise Server 12 SP2 gnutls Ignore