Upstream information

CVE-2017-6891 at MITRE

Description

Two errors in the "asn1_find_node()" function (lib/parser_aux.c) within GnuTLS libtasn1 version 4.10 can be exploited to cause a stacked-based buffer overflow by tricking a user into processing a specially crafted assignments file via the e.g. asn1Coding utility.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 3.3
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:L/AC:M/Au:N/C:N/I:P/A:P
Access Vector Network Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 5.1
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1040621 [IN_PROGRESS], 1149679 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/nginx-ingress-controller:beta1
Container suse/sles12sp3:24.4
Container suse/sles12sp4:26.4
Container suse/sles12sp5:5.2.257
Image SLES12-SP4-Azure-BYOS
Image SLES12-SP4-EC2-HVM-BYOS
Image SLES12-SP4-GCE-BYOS
Image SLES12-SP4-OCI-BYOS
Image SLES12-SP4-SAP-Azure
Image SLES12-SP4-SAP-Azure-BYOS
Image SLES12-SP4-SAP-Azure-LI-BYOS-Production
Image SLES12-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES12-SP4-SAP-EC2-HVM
Image SLES12-SP4-SAP-EC2-HVM-BYOS
Image SLES12-SP4-SAP-GCE
Image SLES12-SP4-SAP-GCE-BYOS
Image SLES12-SP4-SAP-OCI-BYOS
Image SLES12-SP5-Azure-BYOS
Image SLES12-SP5-Azure-Basic-On-Demand
Image SLES12-SP5-Azure-HPC-BYOS
Image SLES12-SP5-Azure-HPC-On-Demand
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-Azure-Standard-On-Demand
Image SLES12-SP5-EC2-BYOS
Image SLES12-SP5-EC2-ECS-On-Demand
Image SLES12-SP5-EC2-On-Demand
Image SLES12-SP5-EC2-SAP-BYOS
Image SLES12-SP5-EC2-SAP-On-Demand
Image SLES12-SP5-GCE-BYOS
Image SLES12-SP5-GCE-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
Image SLES12-SP5-OCI-BYOS-BYOS
Image SLES12-SP5-OCI-BYOS-SAP-BYOS
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
SUSE CaaS Platform 3.0
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
Patchnames:
SUSE-CAASP-3.0-2019-1379
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libgnutls-devel >= 2.4.1-24.39.70.1
  • libgnutls-extra-devel >= 2.4.1-24.39.70.1
  • libgnutls-extra26 >= 2.4.1-24.39.70.1
Patchnames:
sdksp4-gnutls-13212
SUSE Linux Enterprise Desktop 12 SP3
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
  • libtasn1-6-32bit >= 4.9-3.10.1
  • libtasn1-devel >= 4.9-3.10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-1379
SUSE-SLE-SDK-12-SP3-2019-1379
SUSE Linux Enterprise Desktop 12 SP4
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
  • libtasn1-6-32bit >= 4.9-3.10.1
  • libtasn1-devel >= 4.9-3.10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1379
SUSE-SLE-SDK-12-SP4-2019-1379
SUSE Linux Enterprise High Availability Extension 11 SP4
  • libgnutls-extra26 >= 2.4.1-24.39.70.1
Patchnames:
slehasp4-gnutls-13212
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
  • libtasn1-6-32bit >= 4.9-3.10.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libtasn1-4.9-3.10.1
SUSE Linux Enterprise Server 11 SP4
  • gnutls >= 2.4.1-24.39.70.1
  • libgnutls-devel >= 2.4.1-24.39.70.1
  • libgnutls-extra-devel >= 2.4.1-24.39.70.1
  • libgnutls-extra26 >= 2.4.1-24.39.70.1
  • libgnutls26 >= 2.4.1-24.39.70.1
  • libgnutls26-32bit >= 2.4.1-24.39.70.1
  • libgnutls26-x86 >= 2.4.1-24.39.70.1
Patchnames:
sdksp4-gnutls-13212
slehasp4-gnutls-13212
slessp4-gnutls-13212
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
  • libtasn1-6-32bit >= 4.9-3.10.1
  • libtasn1-devel >= 4.9-3.10.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-1379
SUSE-SLE-SERVER-12-SP3-2019-1379
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
  • libtasn1-6-32bit >= 4.9-3.10.1
  • libtasn1-devel >= 4.9-3.10.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1379
SUSE-SLE-SERVER-12-SP4-2019-1379
SUSE Linux Enterprise Server 12 SP5
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
  • libtasn1-6-32bit >= 4.9-3.10.1
  • libtasn1-devel >= 4.9-3.10.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libtasn1-4.9-3.10.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libtasn1-devel-4.9-3.10.1
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • gnutls >= 2.4.1-24.39.70.1
  • libgnutls-devel >= 2.4.1-24.39.70.1
  • libgnutls-extra-devel >= 2.4.1-24.39.70.1
  • libgnutls-extra26 >= 2.4.1-24.39.70.1
  • libgnutls26 >= 2.4.1-24.39.70.1
  • libgnutls26-32bit >= 2.4.1-24.39.70.1
  • libgnutls26-x86 >= 2.4.1-24.39.70.1
Patchnames:
sdksp4-gnutls-13212
slessp4-gnutls-13212
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libtasn1-devel >= 4.9-3.10.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libtasn1-devel-4.9-3.10.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libtasn1-devel >= 4.9-3.10.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-1379
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libtasn1-devel >= 4.9-3.10.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1379


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libtasn1 Released
SLES15-EC2-CHOST-HVM-BYOS libtasn1 Not affected
SLES15-SP1-CHOST-BYOS-Azure libtasn1 Not affected
SLES15-SP1-CHOST-BYOS-EC2 libtasn1 Not affected
SLES15-SP1-CHOST-BYOS-GCE libtasn1 Not affected
SLES15-SP2-CHOST-BYOS-Aliyun libtasn1 Not affected
SLES15-SP2-CHOST-BYOS-Azure libtasn1 Not affected
SLES15-SP2-CHOST-BYOS-EC2 libtasn1 Not affected
SLES15-SP2-CHOST-BYOS-GCE libtasn1 Not affected
SLES15-SP3-CHOST-BYOS-Aliyun libtasn1 Not affected
SLES15-SP3-CHOST-BYOS-Azure libtasn1 Not affected
SLES15-SP3-CHOST-BYOS-EC2 libtasn1 Not affected
SLES15-SP3-CHOST-BYOS-GCE libtasn1 Not affected
SLES15-SP4-CHOST-BYOS libtasn1 Not affected
SLES15-SP4-CHOST-BYOS-Aliyun libtasn1 Not affected
SLES15-SP4-CHOST-BYOS-Azure libtasn1 Not affected
SLES15-SP4-CHOST-BYOS-EC2 libtasn1 Not affected
SLES15-SP4-CHOST-BYOS-GCE libtasn1 Not affected
SUSE CaaS Platform 3.0 libtasn1 Released
SUSE CaaS Platform 4.5 gnutls Not affected
SUSE CaaS Platform 4.5 libtasn1 Not affected
SUSE Container as a Service Platform 2.0 libtasn1 Released
SUSE Enterprise Storage 7 gnutls Not affected
SUSE Enterprise Storage 7 libtasn1 Not affected
SUSE Linux Enterprise Desktop 11 SP4 gnutls Released
SUSE Linux Enterprise Desktop 12 SP1 gnutls Ignore
SUSE Linux Enterprise Desktop 12 SP1 libtasn1 Released
SUSE Linux Enterprise Desktop 12 SP2 gnutls Ignore
SUSE Linux Enterprise Desktop 12 SP3 libtasn1 Released
SUSE Linux Enterprise Desktop 12 SP4 libtasn1 Released
SUSE Linux Enterprise Desktop 15 SP3 gnutls Not affected
SUSE Linux Enterprise Desktop 15 SP3 libtasn1 Not affected
SUSE Linux Enterprise Desktop 15 SP4 gnutls Not affected
SUSE Linux Enterprise Desktop 15 SP4 libtasn1 Not affected
SUSE Linux Enterprise High Availability Extension 11 SP4 gnutls Released
SUSE Linux Enterprise High Performance Computing 12 SP4 libtasn1 Released
SUSE Linux Enterprise High Performance Computing 12 SP5 gnutls Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libtasn1 Released
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS gnutls Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS libtasn1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS gnutls Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS libtasn1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS gnutls Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS libtasn1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 gnutls Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 libtasn1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 gnutls Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 libtasn1 Not affected
SUSE Linux Enterprise Micro 5.0 gnutls Not affected
SUSE Linux Enterprise Micro 5.0 libtasn1 Not affected
SUSE Linux Enterprise Micro 5.1 gnutls Not affected
SUSE Linux Enterprise Micro 5.1 libtasn1 Not affected
SUSE Linux Enterprise Micro 5.2 gnutls Not affected
SUSE Linux Enterprise Micro 5.2 libtasn1 Not affected
SUSE Linux Enterprise Micro 5.3 gnutls Not affected
SUSE Linux Enterprise Micro 5.3 libtasn1 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 gnutls Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 libtasn1 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 gnutls Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 libtasn1 Not affected
SUSE Linux Enterprise Module for Certifications 15 SP3 gnutls Not affected
SUSE Linux Enterprise Point of Service 11 SP3 gnutls Released
SUSE Linux Enterprise Point of Service 11 SP3 libtasn1 Released
SUSE Linux Enterprise Real Time 15 SP2 gnutls Not affected
SUSE Linux Enterprise Real Time 15 SP2 libtasn1 Not affected
SUSE Linux Enterprise Server 11 SP1 gnutls Unsupported
SUSE Linux Enterprise Server 11 SP1 libtasn1 Unsupported
SUSE Linux Enterprise Server 11 SP3 gnutls Unsupported
SUSE Linux Enterprise Server 11 SP3 libtasn1 Unsupported
SUSE Linux Enterprise Server 11 SP3 LTSS gnutls Released
SUSE Linux Enterprise Server 11 SP4 gnutls Released
SUSE Linux Enterprise Server 11 SP4 LTSS gnutls Released
SUSE Linux Enterprise Server 11 SP4 LTSS libtasn1 Released
SUSE Linux Enterprise Server 12 LTSS gnutls Ignore
SUSE Linux Enterprise Server 12 SP1 gnutls Ignore
SUSE Linux Enterprise Server 12 SP1 libtasn1 Released
SUSE Linux Enterprise Server 12 SP2 gnutls Ignore
SUSE Linux Enterprise Server 12 SP2 BCL gnutls Released
SUSE Linux Enterprise Server 12 SP2 BCL libtasn1 Released
SUSE Linux Enterprise Server 12 SP3 libtasn1 Released
SUSE Linux Enterprise Server 12 SP3 BCL libtasn1 Released
SUSE Linux Enterprise Server 12 SP3 ESPOS libtasn1 Released
SUSE Linux Enterprise Server 12 SP3 LTSS libtasn1 Released
SUSE Linux Enterprise Server 12 SP4 libtasn1 Released
SUSE Linux Enterprise Server 12 SP4 ESPOS libtasn1 Released
SUSE Linux Enterprise Server 12 SP4 LTSS libtasn1 Released
SUSE Linux Enterprise Server 12 SP5 gnutls Released
SUSE Linux Enterprise Server 12 SP5 libtasn1 Released
SUSE Linux Enterprise Server 15 SP2 LTSS gnutls Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS libtasn1 Not affected
SUSE Linux Enterprise Server 15 SP3 gnutls Not affected
SUSE Linux Enterprise Server 15 SP3 libtasn1 Not affected
SUSE Linux Enterprise Server 15 SP4 gnutls Not affected
SUSE Linux Enterprise Server 15 SP4 libtasn1 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libtasn1 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 gnutls Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 libtasn1 Not affected
SUSE Linux Enterprise Server for SAP All-in-One 11 SP4 gnutls Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 gnutls Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 gnutls Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libtasn1 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gnutls Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libtasn1 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libtasn1 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gnutls Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libtasn1 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libtasn1 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libtasn1 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libtasn1 Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 gnutls Released
SUSE Linux Enterprise Software Development Kit 12 SP1 gnutls Ignore
SUSE Linux Enterprise Software Development Kit 12 SP1 libtasn1 Released
SUSE Linux Enterprise Software Development Kit 12 SP2 gnutls Ignore
SUSE Linux Enterprise Software Development Kit 12 SP3 libtasn1 Released
SUSE Linux Enterprise Software Development Kit 12 SP4 libtasn1 Released
SUSE Linux Enterprise Storage 7.1 gnutls Not affected
SUSE Linux Enterprise Storage 7.1 libtasn1 Not affected
SUSE Manager Proxy 4.1 gnutls Not affected
SUSE Manager Proxy 4.1 libtasn1 Not affected
SUSE Manager Proxy 4.2 gnutls Not affected
SUSE Manager Proxy 4.2 libtasn1 Not affected
SUSE Manager Proxy 4.3 gnutls Not affected
SUSE Manager Proxy 4.3 libtasn1 Not affected
SUSE Manager Retail Branch Server 4.1 gnutls Not affected
SUSE Manager Retail Branch Server 4.1 libtasn1 Not affected
SUSE Manager Retail Branch Server 4.2 gnutls Not affected
SUSE Manager Retail Branch Server 4.2 libtasn1 Not affected
SUSE Manager Retail Branch Server 4.3 gnutls Not affected
SUSE Manager Retail Branch Server 4.3 libtasn1 Not affected
SUSE Manager Server 4.1 gnutls Not affected
SUSE Manager Server 4.1 libtasn1 Not affected
SUSE Manager Server 4.2 gnutls Not affected
SUSE Manager Server 4.2 libtasn1 Not affected
SUSE Manager Server 4.3 gnutls Not affected
SUSE Manager Server 4.3 libtasn1 Not affected
SUSE OpenStack Cloud 8 libtasn1 Released
SUSE OpenStack Cloud 9 libtasn1 Released
SUSE OpenStack Cloud Crowbar 8 libtasn1 Released
SUSE OpenStack Cloud Crowbar 9 libtasn1 Released
suse/sles/15.2/virt-handler:0.38.1
suse/sles/15.2/virt-launcher:0.38.1
suse/sles/15.3/virt-handler:0.45.0
suse/sles/15.3/virt-launcher:0.45.0
suse/sles/15.4/virt-handler:0.49.0
suse/sles/15.4/virt-launcher:0.49.0
gnutlsNot affected
bci/openjdk
bci/openjdk-devel:11
bci/openjdk:17
bci/python:3
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
ses/7.1/cephcsi/cephcsi
ses/7.1/rook/ceph
ses/7/ceph/ceph
ses/7/ceph/grafana
ses/7/ceph/prometheus-alertmanager
ses/7/ceph/prometheus-node-exporter
ses/7/ceph/prometheus-server
ses/7/cephcsi/cephcsi
ses/7/cephcsi/csi-attacher:v2.1.0
ses/7/cephcsi/csi-attacher:v3.3.0
ses/7/cephcsi/csi-livenessprobe:v1.1.0
ses/7/cephcsi/csi-node-driver-registrar:v1.2.0
ses/7/cephcsi/csi-node-driver-registrar:v2.3.0
ses/7/cephcsi/csi-provisioner:v1.6.0
ses/7/cephcsi/csi-provisioner:v3.0.0
ses/7/cephcsi/csi-resizer:v0.4.0
ses/7/cephcsi/csi-resizer:v1.3.0
ses/7/cephcsi/csi-snapshotter:v2.1.0
ses/7/cephcsi/csi-snapshotter:v2.1.1
ses/7/cephcsi/csi-snapshotter:v4.2.0
ses/7/prometheus-webhook-snmp
ses/7/rook/ceph
suse/manager/4.3/proxy-salt-broker
suse/manager/4.3/proxy-tftpd
suse/sle-micro-rancher/5.3
suse/sle-micro/5.0/toolbox
suse/sle15:15.0
suse/sle15:15.1
suse/sle15:15.2
suse/sle15:15.3
suse/sle15:15.4
suse/sles/15.2/virt-handler:0.38.1
suse/sles/15.2/virt-launcher:0.38.1
suse/sles/15.3/cdi-importer:1.37.1
suse/sles/15.3/cdi-uploadserver:1.37.1
suse/sles/15.3/libguestfs-tools:0.45.0
suse/sles/15.3/virt-handler:0.45.0
suse/sles/15.3/virt-launcher:0.45.0
suse/sles/15.4/cdi-importer:1.43.0
suse/sles/15.4/cdi-uploadserver:1.43.0
suse/sles/15.4/libguestfs-tools:0.49.0
suse/sles/15.4/virt-handler:0.49.0
suse/sles/15.4/virt-launcher:0.49.0
trento/trento-runner
libtasn1Not affected
suse/sles12sp3
suse/sles12sp4
suse/sles12sp5
libtasn1Released


SUSE Timeline for this CVE

CVE page created: Mon May 22 23:15:11 2017
CVE page last modified: Fri Oct 7 16:46:46 2022