Upstream information

CVE-2017-5495 at MITRE

Description

All versions of Quagga, 0.93 through 1.1.0, are vulnerable to an unbounded memory allocation in the telnet 'vty' CLI, leading to a Denial-of-Service of Quagga daemons, or even the entire host. When Quagga daemons are configured with their telnet CLI enabled, anyone who can connect to the TCP ports can trigger this vulnerability, prior to authentication. Most distributions restrict the Quagga telnet interface to local access only by default. The Quagga telnet interface 'vty' input buffer grows automatically, without bound, so long as a newline is not entered. This allows an attacker to cause the Quagga daemon to allocate unbounded memory by sending very long strings without a newline. Eventually the daemon is terminated by the system, or the system itself runs out of memory. This is fixed in Quagga 1.1.1 and Free Range Routing (FRR) Protocol Suite 2017-01-10.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.79 4.30
Vector AV:N/AC:L/Au:N/C:N/I:N/A:C AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Complete Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1021669 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • quagga >= 0.99.24.1-17.1
  • quagga-debuginfo >= 0.99.24.1-17.1
  • quagga-debugsource >= 0.99.24.1-17.1
  • quagga-devel >= 0.99.24.1-17.1
Patchnames:
openSUSE-2017-547
openSUSE Leap 42.2
  • libfpm_pb0 >= 1.1.1-16.3.1
  • libfpm_pb0-debuginfo >= 1.1.1-16.3.1
  • libospf0 >= 1.1.1-16.3.1
  • libospf0-debuginfo >= 1.1.1-16.3.1
  • libospfapiclient0 >= 1.1.1-16.3.1
  • libospfapiclient0-debuginfo >= 1.1.1-16.3.1
  • libquagga_pb0 >= 1.1.1-16.3.1
  • libquagga_pb0-debuginfo >= 1.1.1-16.3.1
  • libzebra1 >= 1.1.1-16.3.1
  • libzebra1-debuginfo >= 1.1.1-16.3.1
  • quagga >= 1.1.1-16.3.1
  • quagga-debuginfo >= 1.1.1-16.3.1
  • quagga-debugsource >= 1.1.1-16.3.1
  • quagga-devel >= 1.1.1-16.3.1
Patchnames:
openSUSE-2017-551


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise SDK 11 SP4
  • SUSE Linux Enterprise SDK 12 SP2
  • SUSE Linux Enterprise Server 11 SP4
  • SUSE Linux Enterprise Server 12 SP2
  • SUSE Linux Enterprise Server for SAP 11 SP3
  • SUSE Linux Enterprise Server for SAP 11 SP4
  • SUSE Linux Enterprise Server for SAP 12 GA
  • SUSE Linux Enterprise Server for SAP 12 SP1
  • SUSE Linux Enterprise Server for SAP 12 SP2
quagga