Upstream information

CVE-2017-5205 at MITRE

Description

The ISAKMP parser in tcpdump before 4.9.0 has a buffer overflow in print-isakmp.c:ikev2_e_print().

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.48 7.48
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1020940 [CONFIRMED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libpcap >= 1.8.1-9.1
  • libpcap1 >= 1.8.1-9.1
  • libpcap1-32bit >= 1.8.1-9.1
  • tcpdump >= 4.9.0-13.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-644
SUSE Linux Enterprise Desktop 12 SP2
  • libpcap >= 1.8.1-9.1
  • libpcap1 >= 1.8.1-9.1
  • libpcap1-32bit >= 1.8.1-9.1
  • tcpdump >= 4.9.0-13.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-644
SUSE Linux Enterprise Server 12 SP1
  • libpcap >= 1.8.1-9.1
  • libpcap1 >= 1.8.1-9.1
  • tcpdump >= 4.9.0-13.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-644
SUSE Linux Enterprise Server 12 SP2
  • libpcap >= 1.8.1-9.1
  • libpcap1 >= 1.8.1-9.1
  • tcpdump >= 4.9.0-13.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-644
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpcap >= 1.8.1-9.1
  • libpcap1 >= 1.8.1-9.1
  • tcpdump >= 4.9.0-13.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-644
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libpcap >= 1.8.1-9.1
  • libpcap-devel >= 1.8.1-9.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-644
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libpcap >= 1.8.1-9.1
  • libpcap-devel >= 1.8.1-9.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-644
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libpcap >= 1.8.1-9.1
  • libpcap1-32bit >= 1.8.1-9.1
Patchnames:
SUSE-SLE-WE-12-SP1-2017-644
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libpcap >= 1.8.1-9.1
  • libpcap1-32bit >= 1.8.1-9.1
Patchnames:
SUSE-SLE-WE-12-SP2-2017-644
openSUSE Leap 42.1
  • libpcap >= 1.8.1-8.1
  • libpcap-debugsource >= 1.8.1-8.1
  • libpcap-devel >= 1.8.1-8.1
  • libpcap-devel-32bit >= 1.8.1-8.1
  • libpcap-devel-static >= 1.8.1-8.1
  • libpcap1 >= 1.8.1-8.1
  • libpcap1-32bit >= 1.8.1-8.1
  • libpcap1-debuginfo >= 1.8.1-8.1
  • libpcap1-debuginfo-32bit >= 1.8.1-8.1
  • tcpdump >= 4.9.0-7.1
  • tcpdump-debuginfo >= 4.9.0-7.1
  • tcpdump-debugsource >= 4.9.0-7.1
Patchnames:
openSUSE-2017-557
openSUSE Leap 42.2
  • libpcap >= 1.8.1-7.3.1
  • libpcap-debugsource >= 1.8.1-7.3.1
  • libpcap-devel >= 1.8.1-7.3.1
  • libpcap-devel-32bit >= 1.8.1-7.3.1
  • libpcap-devel-static >= 1.8.1-7.3.1
  • libpcap1 >= 1.8.1-7.3.1
  • libpcap1-32bit >= 1.8.1-7.3.1
  • libpcap1-debuginfo >= 1.8.1-7.3.1
  • libpcap1-debuginfo-32bit >= 1.8.1-7.3.1
  • tcpdump >= 4.9.0-6.3.1
  • tcpdump-debuginfo >= 4.9.0-6.3.1
  • tcpdump-debugsource >= 4.9.0-6.3.1
Patchnames:
openSUSE-2017-557


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server for SAP 11 SP3
  • SUSE Linux Enterprise Server for SAP 12 GA
tcpdump