Upstream information

CVE-2017-3738 at MITRE

Description

There is an overflow bug in the AVX2 Montgomery multiplication procedure used in exponentiation with 1024-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against RSA and DSA as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH1024 are considered just feasible, because most of the work necessary to deduce information about a private key may be performed offline. The amount of resources required for such an attack would be significant. However, for an attack on TLS to be meaningful, the server would have to share the DH1024 private key among multiple clients, which is no longer an option since CVE-2016-0701. This only affects processors that support the AVX2 but not ADX extensions like Intel Haswell (4th generation). Note: The impact from this issue is similar to CVE-2017-3736, CVE-2017-3732 and CVE-2015-3193. OpenSSL version 1.0.2-1.0.2m and 1.1.0-1.1.0g are affected. Fixed in OpenSSL 1.0.2n. Due to the low severity of this issue we are not issuing a new release of OpenSSL 1.1.0 at this time. The fix will be included in OpenSSL 1.1.0h when it becomes available. The fix is also available in commit e502cc86d in the OpenSSL git repository.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 5.4
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N AV:N/AC:H/Au:N/C:C/I:N/A:N
Access Vector Network Network
Access Complexity Medium High
Authentication None None
Confidentiality Impact Partial Complete
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 5.9
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network Network
Access Complexity High High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
SUSE Bugzilla entries: 1071906 [RESOLVED / FIXED], 1097757

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libopenssl1_0_0 >= 1.0.2j-60.20.2
  • openssl >= 1.0.2j-60.20.2
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-2097
SUSE CaaS Platform ALL
  • libopenssl1_0_0 >= 1.0.2j-60.20.2
  • openssl >= 1.0.2j-60.20.2
  • sles12-caasp-dex-image >= 2.0.0-3.3.11
  • sles12-dnsmasq-nanny-image >= 2.0.1-2.3.15
  • sles12-haproxy-image >= 2.0.1-2.3.16
  • sles12-kubedns-image >= 2.0.1-2.3.11
  • sles12-mariadb-image >= 2.0.1-2.3.15
  • sles12-openldap-image >= 2.0.0-2.3.11
  • sles12-pause-image >= 2.0.1-2.3.9
  • sles12-pv-recycler-node-image >= 2.0.1-2.3.10
  • sles12-salt-api-image >= 2.0.1-2.3.10
  • sles12-salt-master-image >= 2.0.1-2.3.10
  • sles12-salt-minion-image >= 2.0.1-2.3.14
  • sles12-sidecar-image >= 2.0.1-2.3.11
  • sles12-tiller-image >= 2.0.0-2.3.11
  • sles12-velum-image >= 2.0.1-2.3.13
Patchnames:
SUSE-CAASP-ALL-2017-2097
SUSE-CAASP-ALL-2018-40
SUSE Enterprise Storage 4
  • nodejs4 >= 4.8.7-15.8.1
  • nodejs6 >= 6.12.2-11.8.1
Patchnames:
SUSE-Storage-4-2018-2
SUSE-Storage-4-2018-203
SUSE Linux Enterprise Desktop 12 SP2
  • libopenssl-devel >= 1.0.2j-60.20.2
  • libopenssl1_0_0 >= 1.0.2j-60.20.2
  • libopenssl1_0_0-32bit >= 1.0.2j-60.20.2
  • openssl >= 1.0.2j-60.20.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-2097
SUSE Linux Enterprise Desktop 12 SP3
  • libopenssl-devel >= 1.0.2j-60.20.2
  • libopenssl1_0_0 >= 1.0.2j-60.20.2
  • libopenssl1_0_0-32bit >= 1.0.2j-60.20.2
  • openssl >= 1.0.2j-60.20.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-2097
SUSE Linux Enterprise Module for Basesystem 15
  • libopenssl-1_1-devel >= 1.1.0h-2.3
  • libopenssl1_1 >= 1.1.0h-2.3
  • libopenssl1_1-32bit >= 1.1.0h-2.3
  • libopenssl1_1-hmac >= 1.1.0h-2.3
  • libopenssl1_1-hmac-32bit >= 1.1.0h-2.3
  • openssl-1_1 >= 1.1.0h-2.3
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libopenssl-1_1-devel
SUSE Linux Enterprise Module for Legacy Software 15
  • libopenssl-1_0_0-devel >= 1.0.2n-1.32
  • libopenssl1_0_0 >= 1.0.2n-1.32
  • openssl-1_0_0 >= 1.0.2n-1.32
Patchnames:
SUSE Linux Enterprise Module for Legacy Software 15 GA libopenssl-1_0_0-devel
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs4 >= 4.8.7-15.8.1
  • nodejs4-devel >= 4.8.7-15.8.1
  • nodejs4-docs >= 4.8.7-15.8.1
  • nodejs6 >= 6.12.2-11.8.1
  • nodejs6-devel >= 6.12.2-11.8.1
  • nodejs6-docs >= 6.12.2-11.8.1
  • npm4 >= 4.8.7-15.8.1
  • npm6 >= 6.12.2-11.8.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2018-2
SUSE-SLE-Module-Web-Scripting-12-2018-203
SUSE Linux Enterprise Module for Web Scripting 15
  • nodejs8 >= 8.11.1-1.19
  • nodejs8-devel >= 8.11.1-1.19
  • nodejs8-docs >= 8.11.1-1.19
  • npm8 >= 8.11.1-1.19
Patchnames:
SUSE Linux Enterprise Module for Web Scripting 15 GA nodejs8
SUSE Linux Enterprise Server 12 SP2
  • libopenssl-devel >= 1.0.2j-60.20.2
  • libopenssl1_0_0 >= 1.0.2j-60.20.2
  • libopenssl1_0_0-32bit >= 1.0.2j-60.20.2
  • libopenssl1_0_0-hmac >= 1.0.2j-60.20.2
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-60.20.2
  • openssl >= 1.0.2j-60.20.2
  • openssl-doc >= 1.0.2j-60.20.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-2097
SUSE Linux Enterprise Server 12 SP3
  • libopenssl-devel >= 1.0.2j-60.20.2
  • libopenssl1_0_0 >= 1.0.2j-60.20.2
  • libopenssl1_0_0-32bit >= 1.0.2j-60.20.2
  • libopenssl1_0_0-hmac >= 1.0.2j-60.20.2
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-60.20.2
  • openssl >= 1.0.2j-60.20.2
  • openssl-doc >= 1.0.2j-60.20.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-2097
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libopenssl-devel >= 1.0.2j-60.20.2
  • libopenssl1_0_0 >= 1.0.2j-60.20.2
  • libopenssl1_0_0-hmac >= 1.0.2j-60.20.2
  • openssl >= 1.0.2j-60.20.2
  • openssl-doc >= 1.0.2j-60.20.2
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-2097
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libopenssl-devel >= 1.0.2j-60.20.2
  • openssl >= 1.0.2j-60.20.2
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-2097
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libopenssl-devel >= 1.0.2j-60.20.2
  • openssl >= 1.0.2j-60.20.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-2097
SUSE OpenStack Cloud 7
  • nodejs6 >= 6.12.2-11.8.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-203
openSUSE Leap 15.0
  • libopenssl1_0_0 >= 1.0.2n-lp150.1.25
  • libopenssl1_1 >= 1.1.0h-lp150.2.1
  • libopenssl1_1-32bit >= 1.1.0h-lp150.2.1
  • openssl-1_1 >= 1.1.0h-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA libopenssl1_0_0
openSUSE Leap 15.0 GA libopenssl1_1
openSUSE Leap 42.2
  • libopenssl-devel >= 1.0.2j-6.9.1
  • libopenssl-devel-32bit >= 1.0.2j-6.9.1
  • libopenssl1_0_0 >= 1.0.2j-6.9.1
  • libopenssl1_0_0-32bit >= 1.0.2j-6.9.1
  • libopenssl1_0_0-debuginfo >= 1.0.2j-6.9.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.2j-6.9.1
  • libopenssl1_0_0-hmac >= 1.0.2j-6.9.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-6.9.1
  • nodejs4 >= 4.8.7-5.9.1
  • nodejs4-debuginfo >= 4.8.7-5.9.1
  • nodejs4-debugsource >= 4.8.7-5.9.1
  • nodejs4-devel >= 4.8.7-5.9.1
  • nodejs4-docs >= 4.8.7-5.9.1
  • npm4 >= 4.8.7-5.9.1
  • openssl >= 1.0.2j-6.9.1
  • openssl-cavs >= 1.0.2j-6.9.1
  • openssl-cavs-debuginfo >= 1.0.2j-6.9.1
  • openssl-debuginfo >= 1.0.2j-6.9.1
  • openssl-debugsource >= 1.0.2j-6.9.1
  • openssl-doc >= 1.0.2j-6.9.1
Patchnames:
openSUSE-2017-1381
openSUSE-2018-5
openSUSE Leap 42.3
  • libopenssl-devel >= 1.0.2j-16.1
  • libopenssl-devel-32bit >= 1.0.2j-16.1
  • libopenssl1_0_0 >= 1.0.2j-16.1
  • libopenssl1_0_0-32bit >= 1.0.2j-16.1
  • libopenssl1_0_0-debuginfo >= 1.0.2j-16.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.2j-16.1
  • libopenssl1_0_0-hmac >= 1.0.2j-16.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-16.1
  • nodejs4 >= 4.8.7-11.1
  • nodejs4-debuginfo >= 4.8.7-11.1
  • nodejs4-debugsource >= 4.8.7-11.1
  • nodejs4-devel >= 4.8.7-11.1
  • nodejs4-docs >= 4.8.7-11.1
  • nodejs6 >= 6.12.2-6.1
  • nodejs6-debuginfo >= 6.12.2-6.1
  • nodejs6-debugsource >= 6.12.2-6.1
  • nodejs6-devel >= 6.12.2-6.1
  • nodejs6-docs >= 6.12.2-6.1
  • npm4 >= 4.8.7-11.1
  • npm6 >= 6.12.2-6.1
  • openssl >= 1.0.2j-16.1
  • openssl-cavs >= 1.0.2j-16.1
  • openssl-cavs-debuginfo >= 1.0.2j-16.1
  • openssl-debuginfo >= 1.0.2j-16.1
  • openssl-debugsource >= 1.0.2j-16.1
  • openssl-doc >= 1.0.2j-16.1
Patchnames:
openSUSE-2017-1381
openSUSE-2018-116
openSUSE-2018-5


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 openssl Released
CaaS Platform 2.0 openssl Released
OpenStack Cloud Magnum Orchestration 7.0 openssl Released
SUSE Linux Enterprise Desktop 12 SP2 compat-openssl098 Unsupported
SUSE Linux Enterprise Desktop 12 SP2 openssl Released
SUSE Linux Enterprise Desktop 12 SP3 compat-openssl098 Not affected
SUSE Linux Enterprise Desktop 12 SP3 openssl Released
SUSE Linux Enterprise Module for Basesystem 15 GA openssl Already fixed
SUSE Linux Enterprise Module for Legacy Software 12 compat-openssl098 Not affected
SUSE Linux Enterprise SDK 11 SP4 openssl Not affected
SUSE Linux Enterprise SDK 12 SP2 openssl Released
SUSE Linux Enterprise SDK 12 SP3 openssl Released
SUSE Linux Enterprise Security Module 11.3 GA openssl1 Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP4 openssl Not affected
SUSE Linux Enterprise Server 12 GA LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP2 openssl Released
SUSE Linux Enterprise Server 12 SP2 LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP3 openssl Released
SUSE Linux Enterprise Server for SAP 11 SP3 compat-openssl097g Not affected
SUSE Linux Enterprise Server for SAP 11 SP4 compat-openssl097g Not affected
SUSE Linux Enterprise Server for SAP 12 SP1 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP 12 SP2 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP 12 SP3 compat-openssl098 Not affected
SUSE Studio Onsite 1.3 openssl Not affected