Upstream information

CVE-2017-3730 at MITRE

Description

In OpenSSL 1.1.0 before 1.1.0d, if a malicious server supplies bad parameters for a DHE or ECDHE key exchange then this can result in the client attempting to dereference a NULL pointer leading to a client crash. This could be exploited in a Denial of Service attack.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 4.3
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High

Note from the SUSE Security Team

This issue only affects OpenSSL 1.1 series. Currently no SUSE or openSUSE version includes openssl 1.1.

SUSE Bugzilla entries: 1021641 [RESOLVED / FIXED], 1022084 [RESOLVED / WORKSFORME]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 compat-openssl098 Unsupported
SUSE Linux Enterprise Desktop 12 SP1 openssl Unsupported
SUSE Linux Enterprise Desktop 12 SP2 compat-openssl098 Not affected
SUSE Linux Enterprise Desktop 12 SP2 openssl Not affected
SUSE Linux Enterprise Module for Legacy Software 12 compat-openssl098 Not affected
SUSE Linux Enterprise SDK 11 SP4 openssl Not affected
SUSE Linux Enterprise SDK 12 SP1 openssl Unsupported
SUSE Linux Enterprise SDK 12 SP2 openssl Not affected
SUSE Linux Enterprise Security Module 11.3 GA openssl1 Not affected
SUSE Linux Enterprise Server 11 SP4 openssl Not affected
SUSE Linux Enterprise Server 12 SP1 openssl Unsupported
SUSE Linux Enterprise Server 12 SP2 openssl Not affected
SUSE Linux Enterprise Server for SAP 11 SP3 compat-openssl097g Not affected
SUSE Linux Enterprise Server for SAP 12 SP2 compat-openssl098 Not affected
SUSE Studio Onsite 1.3 openssl Not affected