Upstream information

CVE-2017-3558 at MITRE

Description

Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to 5.0.38 and Prior to 5.1.20. Easily "exploitable" vulnerability allows unauthenticated attacker with logon to the infrastructure where Oracle VM VirtualBox executes to compromise Oracle VM VirtualBox. While the vulnerability is in Oracle VM VirtualBox, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of Oracle VM VirtualBox as well as unauthorized update, insert or delete access to some of Oracle VM VirtualBox accessible data and unauthorized read access to a subset of Oracle VM VirtualBox accessible data. CVSS 3.0 Base Score 8.5 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:H).

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.64
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.5
Vector AV:L/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction None
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact High
SUSE Bugzilla entry: 1034854 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • python-virtualbox >= 5.0.40-40.1
  • python-virtualbox-debuginfo >= 5.0.40-40.1
  • virtualbox >= 5.0.40-40.1
  • virtualbox-debuginfo >= 5.0.40-40.1
  • virtualbox-debugsource >= 5.0.40-40.1
  • virtualbox-devel >= 5.0.40-40.1
  • virtualbox-guest-desktop-icons >= 5.0.40-40.1
  • virtualbox-guest-kmp-default >= 5.0.40_k4.1.39_53-40.1
  • virtualbox-guest-kmp-default-debuginfo >= 5.0.40_k4.1.39_53-40.1
  • virtualbox-guest-tools >= 5.0.40-40.1
  • virtualbox-guest-tools-debuginfo >= 5.0.40-40.1
  • virtualbox-guest-x11 >= 5.0.40-40.1
  • virtualbox-guest-x11-debuginfo >= 5.0.40-40.1
  • virtualbox-host-kmp-default >= 5.0.40_k4.1.39_53-40.1
  • virtualbox-host-kmp-default-debuginfo >= 5.0.40_k4.1.39_53-40.1
  • virtualbox-host-source >= 5.0.40-40.1
  • virtualbox-qt >= 5.0.40-40.1
  • virtualbox-qt-debuginfo >= 5.0.40-40.1
  • virtualbox-websrv >= 5.0.40-40.1
  • virtualbox-websrv-debuginfo >= 5.0.40-40.1
Patchnames:
openSUSE-2017-534
openSUSE Leap 42.2
  • python-virtualbox >= 5.1.22-19.10.1
  • python-virtualbox-debuginfo >= 5.1.22-19.10.1
  • virtualbox >= 5.1.22-19.10.1
  • virtualbox-debuginfo >= 5.1.22-19.10.1
  • virtualbox-debugsource >= 5.1.22-19.10.1
  • virtualbox-devel >= 5.1.22-19.10.1
  • virtualbox-guest-desktop-icons >= 5.1.22-19.10.1
  • virtualbox-guest-kmp-default >= 5.1.22_k4.4.57_18.3-19.10.1
  • virtualbox-guest-kmp-default-debuginfo >= 5.1.22_k4.4.57_18.3-19.10.1
  • virtualbox-guest-tools >= 5.1.22-19.10.1
  • virtualbox-guest-tools-debuginfo >= 5.1.22-19.10.1
  • virtualbox-guest-x11 >= 5.1.22-19.10.1
  • virtualbox-guest-x11-debuginfo >= 5.1.22-19.10.1
  • virtualbox-host-kmp-default >= 5.1.22_k4.4.57_18.3-19.10.1
  • virtualbox-host-kmp-default-debuginfo >= 5.1.22_k4.4.57_18.3-19.10.1
  • virtualbox-host-source >= 5.1.22-19.10.1
  • virtualbox-qt >= 5.1.22-19.10.1
  • virtualbox-qt-debuginfo >= 5.1.22-19.10.1
  • virtualbox-websrv >= 5.1.22-19.10.1
  • virtualbox-websrv-debuginfo >= 5.1.22-19.10.1
Patchnames:
openSUSE-2017-533