Upstream information

CVE-2017-2816 at MITRE

Description

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 6.5
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Low
Authentication None Single
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 6.3
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
SUSE Bugzilla entry: 1058673 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 libofx Affected
SUSE Linux Enterprise Desktop 12 SP3 libofx Affected
SUSE Linux Enterprise SDK 11 SP4 libofx Affected
SUSE Linux Enterprise SDK 12 SP2 libofx Affected
SUSE Linux Enterprise SDK 12 SP3 libofx Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 libofx Affected
SUSE Linux Enterprise Workstation Extension 12 SP3 libofx Affected