Upstream information

CVE-2017-2816 at MITRE

Description

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 6.5
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Low
Authentication None Single
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 6.3
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1058673 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libofx >= 0.9.0-3.7.1
  • libofx-devel >= 0.9.0-3.7.1
  • libofx4 >= 0.9.0-3.7.1
Patchnames:
sdksp4-libofx-13701
SUSE Linux Enterprise Desktop 12 SP3
  • libofx >= 0.9.9-3.7.1
  • libofx-devel >= 0.9.9-3.7.1
  • libofx6 >= 0.9.9-3.7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1408
SUSE-SLE-SDK-12-SP3-2018-1408
SUSE-SLE-WE-12-SP3-2018-1408
SUSE Linux Enterprise Desktop 12 SP4
  • libofx >= 0.9.9-3.7.1
  • libofx-devel >= 0.9.9-3.7.1
  • libofx6 >= 0.9.9-3.7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libofx-0.9.9-3.7.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libofx-0.9.9-3.7.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libofx-0.9.9-3.7.1
SUSE Linux Enterprise Desktop 12 SP5
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libofx >= 0.9.9-3.7.1
  • libofx6 >= 0.9.9-3.7.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP5 GA libofx-0.9.9-3.7.1
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libofx >= 0.9.9-3.7.1
  • libofx-devel >= 0.9.9-3.7.1
  • libofx6 >= 0.9.9-3.7.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1408
SUSE-SLE-WE-12-SP3-2018-1408
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libofx >= 0.9.9-3.7.1
  • libofx-devel >= 0.9.9-3.7.1
  • libofx6 >= 0.9.9-3.7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libofx-0.9.9-3.7.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libofx-0.9.9-3.7.1
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libofx >= 0.9.9-3.7.1
  • libofx-devel >= 0.9.9-3.7.1
  • libofx6 >= 0.9.9-3.7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libofx-0.9.9-3.7.1
SUSE Linux Enterprise Workstation Extension 12 SP5 GA libofx-0.9.9-3.7.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libofx >= 0.9.9-3.7.1
  • libofx-devel >= 0.9.9-3.7.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1408
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libofx >= 0.9.9-3.7.1
  • libofx-devel >= 0.9.9-3.7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libofx-0.9.9-3.7.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libofx >= 0.9.9-3.7.1
  • libofx-devel >= 0.9.9-3.7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libofx-0.9.9-3.7.1
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libofx >= 0.9.9-3.7.1
  • libofx6 >= 0.9.9-3.7.1
Patchnames:
SUSE-SLE-WE-12-SP3-2018-1408
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libofx >= 0.9.9-3.7.1
  • libofx6 >= 0.9.9-3.7.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libofx-0.9.9-3.7.1
openSUSE Tumbleweed
  • libofx >= 0.10.1-1.9
  • libofx-devel >= 0.10.1-1.9
  • libofx7 >= 0.10.1-1.9
Patchnames:
openSUSE Tumbleweed GA libofx-0.10.1-1.9


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP4 libofx Released
SUSE Linux Enterprise Desktop 12 SP2 libofx Unsupported
SUSE Linux Enterprise Desktop 12 SP3 libofx Released
SUSE Linux Enterprise Desktop 12 SP5 libofx Released
SUSE Linux Enterprise Server 11 SP4 libofx Released
SUSE Linux Enterprise Server 12 SP2 libofx Unsupported
SUSE Linux Enterprise Server 12 SP3 libofx Released
SUSE Linux Enterprise Server 12 SP5 libofx Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 libofx Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libofx Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libofx Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libofx Released
SUSE Linux Enterprise Software Development Kit 11 SP4 libofx Released
SUSE Linux Enterprise Software Development Kit 12 SP2 libofx Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libofx Released
SUSE Linux Enterprise Software Development Kit 12 SP5 libofx Released
SUSE Linux Enterprise Workstation Extension 12 SP2 libofx Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP3 libofx Released
SUSE Linux Enterprise Workstation Extension 12 SP5 libofx Released