Upstream information

CVE-2017-2616 at MITRE

Description

A race condition was found in util-linux before 2.32.1 in the way su handled the management of child processes. A local authenticated attacker could use this flaw to kill other processes with root privileges under specific conditions.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.7
Vector AV:L/AC:M/Au:N/C:N/I:N/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 4.7
Vector CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Local
Access Complexity High
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entries: 1023041 [RESOLVED / FIXED], 1123789 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libblkid1 >= 2.25-40.1
  • libblkid1-32bit >= 2.25-40.1
  • libmount1 >= 2.25-40.1
  • libmount1-32bit >= 2.25-40.1
  • libsmartcols1 >= 2.25-40.1
  • libuuid-devel >= 2.25-40.1
  • libuuid1 >= 2.25-40.1
  • libuuid1-32bit >= 2.25-40.1
  • python-libmount >= 2.25-40.2
  • util-linux >= 2.25-40.1
  • util-linux-lang >= 2.25-40.1
  • util-linux-systemd >= 2.25-40.1
  • uuidd >= 2.25-40.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-291
SUSE Linux Enterprise Desktop 12 SP2
  • libblkid1 >= 2.28-44.3.1
  • libblkid1-32bit >= 2.28-44.3.1
  • libfdisk1 >= 2.28-44.3.1
  • libmount1 >= 2.28-44.3.1
  • libmount1-32bit >= 2.28-44.3.1
  • libsmartcols1 >= 2.28-44.3.1
  • libuuid-devel >= 2.28-44.3.1
  • libuuid1 >= 2.28-44.3.1
  • libuuid1-32bit >= 2.28-44.3.1
  • python-libmount >= 2.28-44.3.3
  • util-linux >= 2.28-44.3.1
  • util-linux-lang >= 2.28-44.3.1
  • util-linux-systemd >= 2.28-44.3.3
  • uuidd >= 2.28-44.3.3
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-292
SUSE Linux Enterprise Desktop 12 SP3
  • libblkid1 >= 2.29.2-2.3
  • libblkid1-32bit >= 2.29.2-2.3
  • libfdisk1 >= 2.29.2-2.3
  • libmount1 >= 2.29.2-2.3
  • libmount1-32bit >= 2.29.2-2.3
  • libsmartcols1 >= 2.29.2-2.3
  • libuuid-devel >= 2.29.2-2.3
  • libuuid1 >= 2.29.2-2.3
  • libuuid1-32bit >= 2.29.2-2.3
  • python-libmount >= 2.29.2-2.2
  • util-linux >= 2.29.2-2.3
  • util-linux-lang >= 2.29.2-2.3
  • util-linux-systemd >= 2.29.2-2.2
  • uuidd >= 2.29.2-2.2
SUSE Linux Enterprise Desktop 12 SP4
  • libblkid1 >= 2.29.2-7.14
  • libblkid1-32bit >= 2.29.2-7.14
  • libfdisk1 >= 2.29.2-7.14
  • libmount1 >= 2.29.2-7.14
  • libmount1-32bit >= 2.29.2-7.14
  • libsmartcols1 >= 2.29.2-7.14
  • libuuid-devel >= 2.29.2-7.14
  • libuuid1 >= 2.29.2-7.14
  • libuuid1-32bit >= 2.29.2-7.14
  • python-libmount >= 2.29.2-7.7
  • util-linux >= 2.29.2-7.14
  • util-linux-lang >= 2.29.2-7.14
  • util-linux-systemd >= 2.29.2-7.7
  • uuidd >= 2.29.2-7.7
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libblkid1 >= 2.33.2-2.13
  • libblkid1-32bit >= 2.33.2-2.13
  • libfdisk1 >= 2.33.2-2.13
  • libmount1 >= 2.33.2-2.13
  • libmount1-32bit >= 2.33.2-2.13
  • libsmartcols1 >= 2.33.2-2.13
  • libuuid1 >= 2.33.2-2.13
  • libuuid1-32bit >= 2.33.2-2.13
  • python-libmount >= 2.33.2-2.9
  • util-linux >= 2.33.2-2.13
  • util-linux-lang >= 2.33.2-2.13
  • util-linux-systemd >= 2.33.2-2.10
  • uuidd >= 2.33.2-2.10
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libblkid-devel >= 2.33.1-2.28
  • libblkid-devel-static >= 2.33.1-2.28
  • libblkid1 >= 2.33.1-2.28
  • libblkid1-32bit >= 2.33.1-2.28
  • libfdisk-devel >= 2.33.1-2.28
  • libfdisk1 >= 2.33.1-2.28
  • libmount-devel >= 2.33.1-2.28
  • libmount1 >= 2.33.1-2.28
  • libmount1-32bit >= 2.33.1-2.28
  • libsmartcols-devel >= 2.33.1-2.28
  • libsmartcols1 >= 2.33.1-2.28
  • libuuid-devel >= 2.33.1-2.28
  • libuuid-devel-static >= 2.33.1-2.28
  • libuuid1 >= 2.33.1-2.28
  • libuuid1-32bit >= 2.33.1-2.28
  • util-linux >= 2.33.1-2.28
  • util-linux-lang >= 2.33.1-2.28
  • util-linux-systemd >= 2.33.1-2.14
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libblkid-devel >= 2.33.1-4.5.1
  • libblkid-devel-static >= 2.33.1-4.5.1
  • libblkid1 >= 2.33.1-4.5.1
  • libblkid1-32bit >= 2.33.1-4.5.1
  • libfdisk-devel >= 2.33.1-4.5.1
  • libfdisk1 >= 2.33.1-4.5.1
  • libmount-devel >= 2.33.1-4.5.1
  • libmount1 >= 2.33.1-4.5.1
  • libmount1-32bit >= 2.33.1-4.5.1
  • libsmartcols-devel >= 2.33.1-4.5.1
  • libsmartcols1 >= 2.33.1-4.5.1
  • libuuid-devel >= 2.33.1-4.5.1
  • libuuid-devel-static >= 2.33.1-4.5.1
  • libuuid1 >= 2.33.1-4.5.1
  • libuuid1-32bit >= 2.33.1-4.5.1
  • util-linux >= 2.33.1-4.5.1
  • util-linux-lang >= 2.33.1-4.5.1
  • util-linux-systemd >= 2.33.1-4.5.1
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libblkid-devel >= 2.36.2-2.29
  • libblkid-devel-static >= 2.36.2-2.29
  • libblkid1 >= 2.36.2-2.29
  • libblkid1-32bit >= 2.36.2-2.29
  • libfdisk-devel >= 2.36.2-2.29
  • libfdisk1 >= 2.36.2-2.29
  • libmount-devel >= 2.36.2-2.29
  • libmount1 >= 2.36.2-2.29
  • libmount1-32bit >= 2.36.2-2.29
  • libsmartcols-devel >= 2.36.2-2.29
  • libsmartcols1 >= 2.36.2-2.29
  • libuuid-devel >= 2.36.2-2.29
  • libuuid-devel-static >= 2.36.2-2.29
  • libuuid1 >= 2.36.2-2.29
  • libuuid1-32bit >= 2.36.2-2.29
  • util-linux >= 2.36.2-2.29
  • util-linux-lang >= 2.36.2-2.29
  • util-linux-systemd >= 2.36.2-2.1
SUSE Linux Enterprise Module for Basesystem 15
  • libblkid-devel >= 2.31.1-7.1
  • libblkid-devel-static >= 2.31.1-7.1
  • libblkid1 >= 2.31.1-7.1
  • libblkid1-32bit >= 2.31.1-7.1
  • libfdisk-devel >= 2.31.1-7.1
  • libfdisk1 >= 2.31.1-7.1
  • libmount-devel >= 2.31.1-7.1
  • libmount1 >= 2.31.1-7.1
  • libmount1-32bit >= 2.31.1-7.1
  • libsmartcols-devel >= 2.31.1-7.1
  • libsmartcols1 >= 2.31.1-7.1
  • libuuid-devel >= 2.31.1-7.1
  • libuuid-devel-static >= 2.31.1-7.1
  • libuuid1 >= 2.31.1-7.1
  • libuuid1-32bit >= 2.31.1-7.1
  • util-linux >= 2.31.1-7.1
  • util-linux-lang >= 2.31.1-7.1
  • util-linux-systemd >= 2.31.1-7.1
SUSE Linux Enterprise Module for Containers 12
  • sles12-docker-image >= 1.1.4-20171002
  • sles12sp1-docker-image >= 1.0.7-20171002
  • sles12sp2-docker-image >= 1.0.2-20180821
Patchnames:
SUSE-SLE-Module-Containers-12-2017-1672
SUSE-SLE-Module-Containers-12-2017-1673
SUSE-SLE-Module-Containers-12-2018-1762
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • uuidd >= 2.33.1-2.14
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • uuidd >= 2.33.1-4.5.1
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • uuidd >= 2.36.2-2.1
SUSE Linux Enterprise Module for Server Applications 15
  • uuidd >= 2.31.1-7.1
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • coreutils >= 8.12-6.25.33.3.1
  • coreutils-lang >= 8.12-6.25.33.3.1
  • coreutils-x86 >= 8.12-6.25.33.3.1
Patchnames:
slessp4-coreutils-13546
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libblkid1 >= 2.25-40.1
  • libblkid1-32bit >= 2.25-40.1
  • libmount1 >= 2.25-40.1
  • libmount1-32bit >= 2.25-40.1
  • libsmartcols1 >= 2.25-40.1
  • libuuid1 >= 2.25-40.1
  • libuuid1-32bit >= 2.25-40.1
  • python-libmount >= 2.25-40.2
  • util-linux >= 2.25-40.1
  • util-linux-lang >= 2.25-40.1
  • util-linux-systemd >= 2.25-40.1
  • uuidd >= 2.25-40.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-291
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libblkid1 >= 2.28-44.3.1
  • libblkid1-32bit >= 2.28-44.3.1
  • libfdisk1 >= 2.28-44.3.1
  • libmount1 >= 2.28-44.3.1
  • libmount1-32bit >= 2.28-44.3.1
  • libsmartcols1 >= 2.28-44.3.1
  • libuuid1 >= 2.28-44.3.1
  • libuuid1-32bit >= 2.28-44.3.1
  • python-libmount >= 2.28-44.3.3
  • util-linux >= 2.28-44.3.1
  • util-linux-lang >= 2.28-44.3.1
  • util-linux-systemd >= 2.28-44.3.3
  • uuidd >= 2.28-44.3.3
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-292
SUSE Linux Enterprise Server 12 SP3
  • libblkid1 >= 2.29.2-2.3
  • libblkid1-32bit >= 2.29.2-2.3
  • libfdisk1 >= 2.29.2-2.3
  • libmount1 >= 2.29.2-2.3
  • libmount1-32bit >= 2.29.2-2.3
  • libsmartcols1 >= 2.29.2-2.3
  • libuuid1 >= 2.29.2-2.3
  • libuuid1-32bit >= 2.29.2-2.3
  • python-libmount >= 2.29.2-2.2
  • util-linux >= 2.29.2-2.3
  • util-linux-lang >= 2.29.2-2.3
  • util-linux-systemd >= 2.29.2-2.2
  • uuidd >= 2.29.2-2.2
SUSE Linux Enterprise Server 12 SP4
  • libblkid1 >= 2.29.2-7.14
  • libblkid1-32bit >= 2.29.2-7.14
  • libfdisk1 >= 2.29.2-7.14
  • libmount1 >= 2.29.2-7.14
  • libmount1-32bit >= 2.29.2-7.14
  • libsmartcols1 >= 2.29.2-7.14
  • libuuid1 >= 2.29.2-7.14
  • libuuid1-32bit >= 2.29.2-7.14
  • python-libmount >= 2.29.2-7.7
  • util-linux >= 2.29.2-7.14
  • util-linux-lang >= 2.29.2-7.14
  • util-linux-systemd >= 2.29.2-7.7
  • uuidd >= 2.29.2-7.7
SUSE Linux Enterprise Server 12-LTSS
  • libblkid1 >= 2.25-24.10.1
  • libblkid1-32bit >= 2.25-24.10.1
  • libmount1 >= 2.25-24.10.1
  • libmount1-32bit >= 2.25-24.10.1
  • libsmartcols1 >= 2.25-24.10.1
  • libuuid1 >= 2.25-24.10.1
  • libuuid1-32bit >= 2.25-24.10.1
  • python-libmount >= 2.25-24.10.3
  • util-linux >= 2.25-24.10.1
  • util-linux-lang >= 2.25-24.10.1
  • util-linux-systemd >= 2.25-24.10.1
  • uuidd >= 2.25-24.10.1
Patchnames:
SUSE-SLE-SERVER-12-2017-290
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libblkid1 >= 2.28-44.3.1
  • libfdisk1 >= 2.28-44.3.1
  • libmount1 >= 2.28-44.3.1
  • libsmartcols1 >= 2.28-44.3.1
  • libuuid1 >= 2.28-44.3.1
  • python-libmount >= 2.28-44.3.3
  • util-linux >= 2.28-44.3.1
  • util-linux-lang >= 2.28-44.3.1
  • util-linux-systemd >= 2.28-44.3.3
  • uuidd >= 2.28-44.3.3
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-292
SUSE Linux Enterprise Server for SAP Applications 12
  • libblkid1 >= 2.25-24.10.1
  • libblkid1-32bit >= 2.25-24.10.1
  • libmount1 >= 2.25-24.10.1
  • libmount1-32bit >= 2.25-24.10.1
  • libsmartcols1 >= 2.25-24.10.1
  • libuuid1 >= 2.25-24.10.1
  • libuuid1-32bit >= 2.25-24.10.1
  • python-libmount >= 2.25-24.10.3
  • util-linux >= 2.25-24.10.1
  • util-linux-lang >= 2.25-24.10.1
  • util-linux-systemd >= 2.25-24.10.1
  • uuidd >= 2.25-24.10.1
Patchnames:
SUSE-SLE-SAP-12-2017-290
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libblkid-devel >= 2.25-40.1
  • libmount-devel >= 2.25-40.1
  • libsmartcols-devel >= 2.25-40.1
  • libuuid-devel >= 2.25-40.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-291
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libblkid-devel >= 2.28-44.3.1
  • libmount-devel >= 2.28-44.3.1
  • libsmartcols-devel >= 2.28-44.3.1
  • libuuid-devel >= 2.28-44.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-292
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libblkid-devel >= 2.29.2-2.3
  • libmount-devel >= 2.29.2-2.3
  • libsmartcols-devel >= 2.29.2-2.3
  • libuuid-devel >= 2.29.2-2.3
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libblkid-devel >= 2.29.2-7.14
  • libmount-devel >= 2.29.2-7.14
  • libsmartcols-devel >= 2.29.2-7.14
  • libuuid-devel >= 2.29.2-7.14
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libblkid-devel >= 2.33.2-2.13
  • libmount-devel >= 2.33.2-2.13
  • libsmartcols-devel >= 2.33.2-2.13
  • libuuid-devel >= 2.33.2-2.13
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libuuid-devel >= 2.25-40.1
Patchnames:
SUSE-SLE-WE-12-SP1-2017-291
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libuuid-devel >= 2.28-44.3.1
Patchnames:
SUSE-SLE-WE-12-SP2-2017-292
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libuuid-devel >= 2.29.2-2.3
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libuuid-devel >= 2.29.2-7.14
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libuuid-devel >= 2.33.2-2.13
openSUSE Leap 15.0
  • libblkid1 >= 2.31.1-lp150.6.1
  • libblkid1-32bit >= 2.31.1-lp150.6.1
  • libfdisk1 >= 2.31.1-lp150.6.1
  • libmount1 >= 2.31.1-lp150.6.1
  • libsmartcols1 >= 2.31.1-lp150.6.1
  • libuuid1 >= 2.31.1-lp150.6.1
  • libuuid1-32bit >= 2.31.1-lp150.6.1
  • util-linux >= 2.31.1-lp150.6.1
  • util-linux-lang >= 2.31.1-lp150.6.1
  • util-linux-systemd >= 2.31.1-lp150.6.1
Patchnames:
openSUSE Leap 15.0 GA libblkid1-2.31.1-lp150.6.1
openSUSE Tumbleweed
  • libblkid-devel >= 2.36.2-3.2
  • libblkid-devel-32bit >= 2.36.2-3.2
  • libblkid-devel-static >= 2.36.2-3.2
  • libblkid1 >= 2.36.2-3.2
  • libblkid1-32bit >= 2.36.2-3.2
  • libfdisk-devel >= 2.36.2-3.2
  • libfdisk-devel-32bit >= 2.36.2-3.2
  • libfdisk-devel-static >= 2.36.2-3.2
  • libfdisk1 >= 2.36.2-3.2
  • libfdisk1-32bit >= 2.36.2-3.2
  • libmount-devel >= 2.36.2-3.2
  • libmount-devel-32bit >= 2.36.2-3.2
  • libmount-devel-static >= 2.36.2-3.2
  • libmount1 >= 2.36.2-3.2
  • libmount1-32bit >= 2.36.2-3.2
  • libsmartcols-devel >= 2.36.2-3.2
  • libsmartcols-devel-32bit >= 2.36.2-3.2
  • libsmartcols-devel-static >= 2.36.2-3.2
  • libsmartcols1 >= 2.36.2-3.2
  • libsmartcols1-32bit >= 2.36.2-3.2
  • libuuid-devel >= 2.36.2-3.2
  • libuuid-devel-32bit >= 2.36.2-3.2
  • libuuid-devel-static >= 2.36.2-3.2
  • libuuid1 >= 2.36.2-3.2
  • libuuid1-32bit >= 2.36.2-3.2
  • util-linux >= 2.36.2-3.2
  • util-linux-lang >= 2.36.2-3.2
Patchnames:
openSUSE Tumbleweed GA libblkid-devel-2.36.2-3.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 util-linux Already fixed
SLES-LTSS-SAP util-linux In progress
SUSE Linux Enterprise Desktop 12 SP1 coreutils Ignore
SUSE Linux Enterprise Desktop 12 SP1 util-linux Released
SUSE Linux Enterprise Desktop 12 SP2 coreutils Not affected
SUSE Linux Enterprise Desktop 12 SP2 util-linux Released
SUSE Linux Enterprise Module for Containers 12 sles12-docker-image Released
SUSE Linux Enterprise Module for Containers 12 sles12sp1-docker-image Released
SUSE Linux Enterprise Module for Containers 12 sles12sp2-docker-image Released
SUSE Linux Enterprise Point of Service 11 SP3 coreutils Released
SUSE Linux Enterprise Point of Service Image Server 12 SP2 util-linux Released
SUSE Linux Enterprise Server 11 SP4 coreutils Released
SUSE Linux Enterprise Server 11 SP4 util-linux Ignore
SUSE Linux Enterprise Server 11 SP4 LTSS coreutils Released
SUSE Linux Enterprise Server 12 LTSS util-linux Released
SUSE Linux Enterprise Server 12 SP1 coreutils Ignore
SUSE Linux Enterprise Server 12 SP1 util-linux Released
SUSE Linux Enterprise Server 12 SP2 coreutils Not affected
SUSE Linux Enterprise Server 12 SP2 util-linux Released
SUSE Linux Enterprise Server 12 SP2 ESPOS util-linux Released
SUSE Linux Enterprise Server 12 SP2 LTSS util-linux Released
SUSE Linux Enterprise Server 12 SP3 ESPOS util-linux Already fixed
SUSE Linux Enterprise Server 12 SP3 LTSS util-linux Already fixed
SUSE Linux Enterprise Server BCL 12 SP2 util-linux Released
SUSE Linux Enterprise Server BCL 12 SP3 util-linux Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 util-linux Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 util-linux Already fixed
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 util-linux Released
SUSE Linux Enterprise Software Development Kit 11 SP4 util-linux Ignore
SUSE Linux Enterprise Software Development Kit 12 SP1 util-linux Released
SUSE Linux Enterprise Software Development Kit 12 SP2 util-linux Released
SUSE Linux Enterprise Workstation Extension 12 SP1 util-linux Released
SUSE Linux Enterprise Workstation Extension 12 SP2 util-linux Released
SUSE OpenStack Cloud 7 util-linux Released
SUSE OpenStack Cloud 8 util-linux Already fixed
SUSE OpenStack Cloud Crowbar 8 util-linux Already fixed
SUSE Studio Onsite 1.3 util-linux Unsupported