Upstream information

CVE-2017-2579 at MITRE

Description

An out-of-bounds read vulnerability was found in netpbm before 10.61. The expandCodeOntoStack() function has an insufficient code value check, so that a maliciously crafted file could cause the application to crash or possibly allows code execution.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1024287 [RESOLVED / FIXED], 1024288 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libnetpbm11 >= 10.66.3-8.7.2
  • libnetpbm11-32bit >= 10.66.3-8.7.2
  • netpbm >= 10.66.3-8.7.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-1645
SUSE Linux Enterprise Desktop 12 SP4
  • libnetpbm11 >= 10.66.3-8.7.2
  • libnetpbm11-32bit >= 10.66.3-8.7.2
  • netpbm >= 10.66.3-8.7.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1645
SUSE Linux Enterprise Module for Basesystem 15
  • libnetpbm11 >= 10.80.1-3.8.2
  • netpbm >= 10.80.1-3.8.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1525
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libnetpbm11 >= 10.80.1-3.8.2
  • netpbm >= 10.80.1-3.8.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-1525
SUSE Linux Enterprise Module for Desktop Applications 15
  • libnetpbm-devel >= 10.80.1-3.8.2
  • netpbm >= 10.80.1-3.8.2
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-1525
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • libnetpbm-devel >= 10.80.1-3.8.2
  • netpbm >= 10.80.1-3.8.2
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP1-2019-1525
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libnetpbm11-32bit >= 10.80.1-3.8.2
  • netpbm >= 10.80.1-3.8.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1525
SUSE Linux Enterprise Point of Sale 11 SP3
  • libnetpbm10 >= 10.26.44-101.15.5.2
  • netpbm >= 10.26.44-101.15.5.2
Patchnames:
sleposp3-netpbm-14101
SUSE Linux Enterprise Server 11 SP4-LTSS
  • libnetpbm10 >= 10.26.44-101.15.5.2
  • libnetpbm10-32bit >= 10.26.44-101.15.5.2
  • netpbm >= 10.26.44-101.15.5.2
Patchnames:
slessp4-netpbm-14101
SUSE Linux Enterprise Server 12 SP3
  • libnetpbm11 >= 10.66.3-8.7.2
  • libnetpbm11-32bit >= 10.66.3-8.7.2
  • netpbm >= 10.66.3-8.7.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1645
SUSE Linux Enterprise Server 12 SP4
  • libnetpbm11 >= 10.66.3-8.7.2
  • libnetpbm11-32bit >= 10.66.3-8.7.2
  • netpbm >= 10.66.3-8.7.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1645
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • libnetpbm10 >= 10.26.44-101.15.5.2
  • libnetpbm10-32bit >= 10.26.44-101.15.5.2
  • netpbm >= 10.26.44-101.15.5.2
Patchnames:
slessp4-netpbm-14101
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libnetpbm11 >= 10.66.3-8.7.2
  • libnetpbm11-32bit >= 10.66.3-8.7.2
  • netpbm >= 10.66.3-8.7.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1645
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libnetpbm11 >= 10.66.3-8.7.2
  • libnetpbm11-32bit >= 10.66.3-8.7.2
  • netpbm >= 10.66.3-8.7.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1645
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libnetpbm-devel >= 10.66.3-8.7.2
  • netpbm >= 10.66.3-8.7.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-1645
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libnetpbm-devel >= 10.66.3-8.7.2
  • netpbm >= 10.66.3-8.7.2
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1645
openSUSE Leap 15.0
  • libnetpbm-devel >= 10.80.1-lp150.2.6.1
  • libnetpbm11 >= 10.80.1-lp150.2.6.1
  • libnetpbm11-32bit >= 10.80.1-lp150.2.6.1
  • libnetpbm11-32bit-debuginfo >= 10.80.1-lp150.2.6.1
  • libnetpbm11-debuginfo >= 10.80.1-lp150.2.6.1
  • netpbm >= 10.80.1-lp150.2.6.1
  • netpbm-debuginfo >= 10.80.1-lp150.2.6.1
  • netpbm-debugsource >= 10.80.1-lp150.2.6.1
  • netpbm-vulnerable >= 10.80.1-lp150.2.6.1
  • netpbm-vulnerable-debuginfo >= 10.80.1-lp150.2.6.1
Patchnames:
openSUSE-2019-1605
openSUSE Leap 15.1
  • libnetpbm-devel >= 10.80.1-lp151.4.3.1
  • libnetpbm11 >= 10.80.1-lp151.4.3.1
  • libnetpbm11-32bit >= 10.80.1-lp151.4.3.1
  • libnetpbm11-32bit-debuginfo >= 10.80.1-lp151.4.3.1
  • libnetpbm11-debuginfo >= 10.80.1-lp151.4.3.1
  • netpbm >= 10.80.1-lp151.4.3.1
  • netpbm-debuginfo >= 10.80.1-lp151.4.3.1
  • netpbm-debugsource >= 10.80.1-lp151.4.3.1
  • netpbm-vulnerable >= 10.80.1-lp151.4.3.1
  • netpbm-vulnerable-debuginfo >= 10.80.1-lp151.4.3.1
Patchnames:
openSUSE-2019-1605


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 netpbm Affected
SUSE Linux Enterprise Desktop 12 SP2 netpbm Affected
SUSE Linux Enterprise Desktop 12 SP3 netpbm Released
SUSE Linux Enterprise Desktop 12 SP4 netpbm Released
SUSE Linux Enterprise High Performance Computing 12 netpbm Released
SUSE Linux Enterprise Module for Basesystem 15 GA netpbm Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 netpbm Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA netpbm Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 netpbm Released
SUSE Linux Enterprise SDK 11 SP4 netpbm Affected
SUSE Linux Enterprise SDK 12 SP1 netpbm Affected
SUSE Linux Enterprise SDK 12 SP2 netpbm Affected
SUSE Linux Enterprise SDK 12 SP3 netpbm Released
SUSE Linux Enterprise SDK 12 SP4 netpbm Released
SUSE Linux Enterprise Server 11 SP4 netpbm Affected
SUSE Linux Enterprise Server 11 SP4 LTSS netpbm Released
SUSE Linux Enterprise Server 12 SP1 netpbm Affected
SUSE Linux Enterprise Server 12 SP2 netpbm Affected
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI netpbm Released
SUSE Linux Enterprise Server 12 SP3 netpbm Released
SUSE Linux Enterprise Server 12 SP4 netpbm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 netpbm Released