Upstream information

CVE-2017-2295 at MITRE

Description

Versions of Puppet prior to 4.10.1 will deserialize data off the wire (from the agent to the server, in this case) with a attacker-specified format. This could be used to force YAML deserialization in an unsafe manner, which would lead to remote code execution. This change constrains the format of data on the wire to PSON or safely decoded YAML.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6 7.6
Vector AV:N/AC:M/Au:S/C:P/I:P/A:P AV:N/AC:H/Au:N/C:C/I:C/A:C
Access Vector Network Network
Access Complexity Medium High
Authentication Single None
Confidentiality Impact Partial Complete
Integrity Impact Partial Complete
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.2 8.1
Vector AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity High High
Privileges Required Low None
User Interaction None None
Scope Changed Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact None High
SUSE Bugzilla entry: 1040151 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • puppet >= 3.8.5-15.3.3
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1310
SUSE Linux Enterprise Desktop 12 SP3
  • puppet >= 3.8.5-15.3.3
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1310
SUSE Linux Enterprise Module for Advanced Systems Management 12
  • puppet >= 3.8.5-15.3.3
  • puppet-server >= 3.8.5-15.3.3
Patchnames:
SUSE-SLE-Module-Adv-Systems-Management-12-2017-1310
SUSE Linux Enterprise Server 11 SP4
  • puppet >= 2.7.26-0.5.3.1
  • puppet-server >= 2.7.26-0.5.3.1
Patchnames:
slessp4-puppet-13498
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • puppet >= 2.7.26-0.5.3.1
  • puppet-server >= 2.7.26-0.5.3.1
Patchnames:
slessp4-puppet-13498
openSUSE Leap 42.2
  • ruby2.1-rubygem-puppet >= 3.8.7-17.3.1
  • ruby2.1-rubygem-puppet-doc >= 3.8.7-17.3.1
  • ruby2.1-rubygem-puppet-testsuite >= 3.8.7-17.3.1
  • rubygem-puppet >= 3.8.7-17.3.1
  • rubygem-puppet-emacs >= 3.8.7-17.3.1
  • rubygem-puppet-master >= 3.8.7-17.3.1
  • rubygem-puppet-master-unicorn >= 3.8.7-17.3.1
  • rubygem-puppet-vim >= 3.8.7-17.3.1
Patchnames:
openSUSE-2017-835
openSUSE Leap 42.3
  • ruby2.1-rubygem-puppet >= 3.8.7-20.1
  • ruby2.1-rubygem-puppet-doc >= 3.8.7-20.1
  • ruby2.1-rubygem-puppet-testsuite >= 3.8.7-20.1
  • ruby2.2-rubygem-puppet >= 3.8.7-20.1
  • ruby2.2-rubygem-puppet-doc >= 3.8.7-20.1
  • ruby2.2-rubygem-puppet-testsuite >= 3.8.7-20.1
  • ruby2.3-rubygem-puppet >= 3.8.7-20.1
  • ruby2.3-rubygem-puppet-doc >= 3.8.7-20.1
  • ruby2.3-rubygem-puppet-testsuite >= 3.8.7-20.1
  • ruby2.4-rubygem-puppet >= 3.8.7-20.1
  • ruby2.4-rubygem-puppet-doc >= 3.8.7-20.1
  • ruby2.4-rubygem-puppet-testsuite >= 3.8.7-20.1
  • rubygem-puppet >= 3.8.7-20.1
  • rubygem-puppet-emacs >= 3.8.7-20.1
  • rubygem-puppet-master >= 3.8.7-20.1
  • rubygem-puppet-master-unicorn >= 3.8.7-20.1
  • rubygem-puppet-vim >= 3.8.7-20.1
Patchnames:
openSUSE-2017-835


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 puppet Unsupported
SUSE Linux Enterprise Desktop 12 SP2 puppet Released
SUSE Linux Enterprise Desktop 12 SP3 puppet Released
SUSE Linux Enterprise Module for Advanced Systems Management 12 puppet Released
SUSE Linux Enterprise Server 11 SP3 LTSS puppet Affected
SUSE Linux Enterprise Server 11 SP4 puppet Released