Upstream information

CVE-2017-18359 at MITRE

Description

PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of service via crafted ST_AsX3D function input, as demonstrated by an abnormal server termination for "SELECT ST_AsX3D('LINESTRING EMPTY');" because empty geometries are mishandled.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1201215 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP4
  • librttopo-devel >= 1.1.0-bp154.2.3.1
  • librttopo1 >= 1.1.0-bp154.2.3.1
Patchnames:
openSUSE-2022-10042
openSUSE Leap 15.4
  • librttopo-devel >= 1.1.0-bp154.2.3.1
  • librttopo1 >= 1.1.0-bp154.2.3.1
Patchnames:
openSUSE-2022-10042
openSUSE Tumbleweed
  • librttopo-devel >= 1.1.0-2.1
  • librttopo1 >= 1.1.0-2.1
Patchnames:
openSUSE Tumbleweed GA librttopo-devel-1.1.0-2.1