Upstream information

CVE-2017-18201 at MITRE

Description

An issue was discovered in GNU libcdio before 2.0.0. There is a double free in get_cdtext_generic() in lib/driver/_cdio_generic.c.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 5.3
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entry: 1082877 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libcdio >= 0.90-6.3.1
  • libcdio14 >= 0.90-6.3.1
  • libcdio14-32bit >= 0.90-6.3.1
  • libiso9660-8 >= 0.90-6.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-459
SUSE Linux Enterprise Desktop 12 SP3
  • libcdio >= 0.90-6.3.1
  • libcdio14 >= 0.90-6.3.1
  • libcdio14-32bit >= 0.90-6.3.1
  • libiso9660-8 >= 0.90-6.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-459
SUSE Linux Enterprise Module for Desktop Applications 15
  • libcdio >= 0.94-6.3.1
  • libcdio++0 >= 0.94-6.3.1
  • libcdio-devel >= 0.94-6.3.1
  • libcdio16 >= 0.94-6.3.1
  • libiso9660-10 >= 0.94-6.3.1
  • libudf0 >= 0.94-6.3.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libcdio++0
SUSE-SLE-Module-Desktop-Applications-15-2018-1512
SUSE Linux Enterprise Server 12 SP2
  • libcdio >= 0.90-6.3.1
  • libcdio14 >= 0.90-6.3.1
  • libcdio14-32bit >= 0.90-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-459
SUSE Linux Enterprise Server 12 SP3
  • libcdio >= 0.90-6.3.1
  • libcdio14 >= 0.90-6.3.1
  • libcdio14-32bit >= 0.90-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-459
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libcdio >= 0.90-6.3.1
  • libcdio14 >= 0.90-6.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-459
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libcdio >= 0.90-6.3.1
  • libcdio14 >= 0.90-6.3.1
  • libcdio14-32bit >= 0.90-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-459
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libcdio >= 0.90-6.3.1
  • libcdio14 >= 0.90-6.3.1
  • libcdio14-32bit >= 0.90-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-459
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libcdio >= 0.90-6.3.1
  • libcdio++0 >= 0.90-6.3.1
  • libcdio-devel >= 0.90-6.3.1
  • libiso9660-8 >= 0.90-6.3.1
  • libudf0 >= 0.90-6.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-459
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libcdio >= 0.90-6.3.1
  • libcdio++0 >= 0.90-6.3.1
  • libcdio-devel >= 0.90-6.3.1
  • libiso9660-8 >= 0.90-6.3.1
  • libudf0 >= 0.90-6.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-459
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libcdio >= 0.90-6.3.1
  • libiso9660-8 >= 0.90-6.3.1
Patchnames:
SUSE-SLE-WE-12-SP2-2018-459
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libcdio >= 0.90-6.3.1
  • libiso9660-8 >= 0.90-6.3.1
Patchnames:
SUSE-SLE-WE-12-SP3-2018-459
openSUSE Leap 15.0
  • cdio-utils >= 0.94-lp150.5.3.1
  • cdio-utils-debuginfo >= 0.94-lp150.5.3.1
  • cdio-utils-debugsource >= 0.94-lp150.5.3.1
  • libcdio >= 0.94-lp150.5.3.1
  • libcdio++0 >= 0.94-lp150.5.3.1
  • libcdio++0-32bit >= 0.94-lp150.5.3.1
  • libcdio++0-32bit-debuginfo >= 0.94-lp150.5.3.1
  • libcdio++0-debuginfo >= 0.94-lp150.5.3.1
  • libcdio-debugsource >= 0.94-lp150.5.3.1
  • libcdio-devel >= 0.94-lp150.5.3.1
  • libcdio16 >= 0.94-lp150.4.3
  • libcdio16-32bit >= 0.94-lp150.5.3.1
  • libcdio16-32bit-debuginfo >= 0.94-lp150.5.3.1
  • libcdio16-debuginfo >= 0.94-lp150.5.3.1
  • libiso9660-10 >= 0.94-lp150.4.3
  • libiso9660-10-32bit >= 0.94-lp150.5.3.1
  • libiso9660-10-32bit-debuginfo >= 0.94-lp150.5.3.1
  • libiso9660-10-debuginfo >= 0.94-lp150.5.3.1
  • libudf0 >= 0.94-lp150.5.3.1
  • libudf0-32bit >= 0.94-lp150.5.3.1
  • libudf0-32bit-debuginfo >= 0.94-lp150.5.3.1
  • libudf0-debuginfo >= 0.94-lp150.5.3.1
Patchnames:
openSUSE Leap 15.0 GA libcdio16
openSUSE-2018-857


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 libcdio Released
SUSE Linux Enterprise Desktop 12 SP3 libcdio Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA libcdio Released
SUSE Linux Enterprise SDK 11 SP4 libcdio Not affected
SUSE Linux Enterprise SDK 12 SP2 libcdio Released
SUSE Linux Enterprise SDK 12 SP3 libcdio Released
SUSE Linux Enterprise Server 11 SP3 LTSS libcdio Not affected
SUSE Linux Enterprise Server 11 SP4 libcdio Not affected
SUSE Linux Enterprise Server 12 GA LTSS libcdio Affected
SUSE Linux Enterprise Server 12 SP1 LTSS libcdio Affected
SUSE Linux Enterprise Server 12 SP2 libcdio Released
SUSE Linux Enterprise Server 12 SP3 libcdio Released
SUSE Linux Enterprise Workstation Extension 12 SP2 libcdio Released
SUSE Linux Enterprise Workstation Extension 12 SP3 libcdio Released