Upstream information

CVE-2017-15896 at MITRE

Description

Node.js was affected by OpenSSL vulnerability CVE-2017-3737 in regards to the use of SSL_read() due to TLS handshake failure. The result was that an active network attacker could send application data to Node.js using the TLS or HTTP2 modules in a way that bypassed TLS authentication and encryption.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.4 6.4
Vector AV:N/AC:L/Au:N/C:P/I:P/A:N AV:N/AC:L/Au:N/C:P/I:P/A:N
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact None None
CVSS v3 Scores
  SUSE
Base Score 6.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
SUSE Bugzilla entries: 1071905 [RESOLVED / FIXED], 1072322 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • nodejs4 >= 4.8.7-15.8.1
  • nodejs6 >= 6.12.2-11.8.1
Patchnames:
SUSE-Storage-4-2018-2
SUSE-Storage-4-2018-203
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs4 >= 4.8.7-15.8.1
  • nodejs4-devel >= 4.8.7-15.8.1
  • nodejs4-docs >= 4.8.7-15.8.1
  • nodejs6 >= 6.12.2-11.8.1
  • nodejs6-devel >= 6.12.2-11.8.1
  • nodejs6-docs >= 6.12.2-11.8.1
  • npm4 >= 4.8.7-15.8.1
  • npm6 >= 6.12.2-11.8.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2018-2
SUSE-SLE-Module-Web-Scripting-12-2018-203
SUSE Linux Enterprise Module for Web Scripting 15
  • nodejs8 >= 8.11.1-1.19
  • nodejs8-devel >= 8.11.1-1.19
  • nodejs8-docs >= 8.11.1-1.19
  • npm8 >= 8.11.1-1.19
Patchnames:
SUSE Linux Enterprise Module for Web Scripting 15 GA nodejs8
SUSE OpenStack Cloud 7
  • nodejs6 >= 6.12.2-11.8.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-203
openSUSE Leap 42.2
  • nodejs4 >= 4.8.7-5.9.1
  • nodejs4-debuginfo >= 4.8.7-5.9.1
  • nodejs4-debugsource >= 4.8.7-5.9.1
  • nodejs4-devel >= 4.8.7-5.9.1
  • nodejs4-docs >= 4.8.7-5.9.1
  • npm4 >= 4.8.7-5.9.1
Patchnames:
openSUSE-2018-5
openSUSE Leap 42.3
  • nodejs4 >= 4.8.7-11.1
  • nodejs4-debuginfo >= 4.8.7-11.1
  • nodejs4-debugsource >= 4.8.7-11.1
  • nodejs4-devel >= 4.8.7-11.1
  • nodejs4-docs >= 4.8.7-11.1
  • nodejs6 >= 6.12.2-6.1
  • nodejs6-debuginfo >= 6.12.2-6.1
  • nodejs6-debugsource >= 6.12.2-6.1
  • nodejs6-devel >= 6.12.2-6.1
  • nodejs6-docs >= 6.12.2-6.1
  • npm4 >= 4.8.7-11.1
  • npm6 >= 6.12.2-6.1
Patchnames:
openSUSE-2018-116
openSUSE-2018-5


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs4 Released
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs6 Released
SUSE Openstack Cloud 7 nodejs6 Released
SUSE Storage 4 nodejs4 Released
SUSE Storage 4 nodejs6 Released