Upstream information

CVE-2017-13098 at MITRE

Description

BouncyCastle TLS prior to version 1.0.3, when configured to use the JCE (Java Cryptography Extension) for cryptographic functions, provides a weak Bleichenbacher oracle when any TLS cipher suite using RSA key exchange is negotiated. An attacker can recover the private key from a vulnerable application. This vulnerability is referred to as "ROBOT."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.9
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
CVSSv3 Version 3
SUSE Bugzilla entry: 1072697 [RESOLVED / INVALID]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Development Tools 15 SP2
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • bouncycastle >= 1.64-1.63
  • bouncycastle-pg >= 1.64-1.63
openSUSE Leap 15.0
  • bouncycastle >= 1.60-lp150.2.3.1
  • bouncycastle-javadoc >= 1.60-lp150.2.3.1
Patchnames:
openSUSE-2019-546
openSUSE Leap 15.1
  • bouncycastle >= 1.60-lp151.3.3.1
  • bouncycastle-javadoc >= 1.60-lp151.3.3.1
Patchnames:
openSUSE-2020-607
openSUSE Tumbleweed
  • bouncycastle >= 1.68-3.2
  • bouncycastle-javadoc >= 1.68-3.2
  • bouncycastle-mail >= 1.68-3.2
  • bouncycastle-pg >= 1.68-3.2
  • bouncycastle-pkix >= 1.68-3.2
  • bouncycastle-tls >= 1.68-3.2
Patchnames:
openSUSE Tumbleweed GA bouncycastle-1.68-3.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Development Tools 15 SP2 bouncycastle Already fixed