Upstream information

CVE-2017-12865 at MITRE

Description

Stack-based buffer overflow in "dnsproxy.c" in connman 1.34 and earlier allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted response query string passed to the "name" variable.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1054720 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • connman >= 1.40-2.2
  • connman-client >= 1.40-2.2
  • connman-devel >= 1.40-2.2
  • connman-doc >= 1.40-2.2
  • connman-nmcompat >= 1.40-2.2
  • connman-plugin-hh2serial-gps >= 1.40-2.2
  • connman-plugin-iospm >= 1.40-2.2
  • connman-plugin-l2tp >= 1.40-2.2
  • connman-plugin-openconnect >= 1.40-2.2
  • connman-plugin-openvpn >= 1.40-2.2
  • connman-plugin-polkit >= 1.40-2.2
  • connman-plugin-pptp >= 1.40-2.2
  • connman-plugin-tist >= 1.40-2.2
  • connman-plugin-vpnc >= 1.40-2.2
  • connman-plugin-wireguard >= 1.40-2.2
  • connman-test >= 1.40-2.2
Patchnames:
openSUSE Tumbleweed GA connman-1.40-2.2