Upstream information

CVE-2017-11464 at MITRE

Description

A SIGFPE is raised in the function box_blur_line of rsvg-filter.c in GNOME librsvg 2.40.17 during an attempted parse of a crafted SVG file, because of incorrect protection against division by zero.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 4.3
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 3.7
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Local Network
Access Complexity Low High
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1049607 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP4-SAP-Azure-LI-BYOS-Production
Image SLES12-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • gdk-pixbuf-loader-rsvg >= 2.40.18-5.3.1
  • librsvg-2-2 >= 2.40.18-5.3.1
SUSE Linux Enterprise Desktop 12 SP2
  • gdk-pixbuf-loader-rsvg >= 2.40.18-5.3.1
  • librsvg-2-2 >= 2.40.18-5.3.1
  • librsvg-2-2-32bit >= 2.40.18-5.3.1
  • librsvg-devel >= 2.40.18-5.3.1
  • rsvg-view >= 2.40.18-5.3.1
  • typelib-1_0-Rsvg-2_0 >= 2.40.18-5.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1315
SUSE-SLE-SDK-12-SP2-2017-1315
SUSE Linux Enterprise Desktop 12 SP3
  • gdk-pixbuf-loader-rsvg >= 2.40.18-5.3.1
  • librsvg-2-2 >= 2.40.18-5.3.1
  • librsvg-2-2-32bit >= 2.40.18-5.3.1
  • librsvg-devel >= 2.40.18-5.3.1
  • rsvg-view >= 2.40.18-5.3.1
  • typelib-1_0-Rsvg-2_0 >= 2.40.18-5.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1315
SUSE-SLE-SDK-12-SP3-2017-1315
SUSE Linux Enterprise Desktop 12 SP4
  • gdk-pixbuf-loader-rsvg >= 2.40.20-5.6.1
  • librsvg-2-2 >= 2.40.20-5.6.1
  • librsvg-2-2-32bit >= 2.40.20-5.6.1
  • librsvg-devel >= 2.40.20-5.6.1
  • rsvg-view >= 2.40.20-5.6.1
  • typelib-1_0-Rsvg-2_0 >= 2.40.20-5.6.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA gdk-pixbuf-loader-rsvg-2.40.20-5.6.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA librsvg-devel-2.40.20-5.6.1
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Linux Enterprise Storage 6
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • gdk-pixbuf-loader-rsvg >= 2.42.3-1.49
  • librsvg-2-2 >= 2.42.3-1.49
  • librsvg-devel >= 2.42.3-1.49
  • typelib-1_0-Rsvg-2_0 >= 2.42.3-1.49
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA gdk-pixbuf-loader-rsvg-2.42.3-1.49
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA librsvg-devel-2.42.3-1.49
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • gdk-pixbuf-loader-rsvg >= 2.46.4-1.31
  • librsvg-2-2 >= 2.46.4-1.31
  • librsvg-devel >= 2.46.4-1.31
  • typelib-1_0-Rsvg-2_0 >= 2.46.4-1.31
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA gdk-pixbuf-loader-rsvg-2.46.4-1.31
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA librsvg-devel-2.46.4-1.31
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • gdk-pixbuf-loader-rsvg >= 2.46.5-3.3.1
  • librsvg-2-2 >= 2.46.5-3.3.1
  • librsvg-devel >= 2.46.5-3.3.1
  • typelib-1_0-Rsvg-2_0 >= 2.46.5-3.3.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA gdk-pixbuf-loader-rsvg-2.46.5-3.3.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA librsvg-devel-2.46.5-3.3.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • gdk-pixbuf-loader-rsvg >= 2.52.6-150400.1.7
  • librsvg-2-2 >= 2.52.6-150400.1.7
  • librsvg-devel >= 2.52.6-150400.1.7
  • typelib-1_0-Rsvg-2_0 >= 2.52.6-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA gdk-pixbuf-loader-rsvg-2.52.6-150400.1.7
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA librsvg-devel-2.52.6-150400.1.7
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • gdk-pixbuf-loader-rsvg >= 2.42.3-1.49
  • librsvg-2-2 >= 2.42.3-1.49
  • librsvg-devel >= 2.42.3-1.49
  • typelib-1_0-Rsvg-2_0 >= 2.42.3-1.49
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA gdk-pixbuf-loader-rsvg-2.42.3-1.49
SUSE Linux Enterprise Module for Desktop Applications 15 GA librsvg-devel-2.42.3-1.49
SUSE Linux Enterprise High Performance Computing 12 SP5
  • gdk-pixbuf-loader-rsvg >= 2.40.20-5.6.1
  • librsvg-2-2 >= 2.40.20-5.6.1
  • librsvg-2-2-32bit >= 2.40.20-5.6.1
  • rsvg-view >= 2.40.20-5.6.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA gdk-pixbuf-loader-rsvg-2.40.20-5.6.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • gdk-pixbuf-loader-rsvg >= 2.42.3-1.49
  • librsvg-2-2 >= 2.42.3-1.49
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA gdk-pixbuf-loader-rsvg-2.42.3-1.49
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • gdk-pixbuf-loader-rsvg >= 2.46.4-1.31
  • librsvg-2-2 >= 2.46.4-1.31
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA gdk-pixbuf-loader-rsvg-2.46.4-1.31
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • gdk-pixbuf-loader-rsvg >= 2.46.5-3.3.1
  • librsvg-2-2 >= 2.46.5-3.3.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA gdk-pixbuf-loader-rsvg-2.46.5-3.3.1
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • gdk-pixbuf-loader-rsvg >= 2.52.6-150400.1.7
  • librsvg-2-2 >= 2.52.6-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA gdk-pixbuf-loader-rsvg-2.52.6-150400.1.7
SUSE Linux Enterprise Module for Basesystem 15
  • gdk-pixbuf-loader-rsvg >= 2.42.3-1.49
  • librsvg-2-2 >= 2.42.3-1.49
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA gdk-pixbuf-loader-rsvg-2.42.3-1.49
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • librsvg-devel >= 2.42.3-1.49
  • typelib-1_0-Rsvg-2_0 >= 2.42.3-1.49
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA librsvg-devel-2.42.3-1.49
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • librsvg-devel >= 2.46.4-1.31
  • typelib-1_0-Rsvg-2_0 >= 2.46.4-1.31
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA librsvg-devel-2.46.4-1.31
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • librsvg-devel >= 2.46.5-3.3.1
  • typelib-1_0-Rsvg-2_0 >= 2.46.5-3.3.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA librsvg-devel-2.46.5-3.3.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
  • librsvg-devel >= 2.52.6-150400.1.7
  • typelib-1_0-Rsvg-2_0 >= 2.52.6-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA librsvg-devel-2.52.6-150400.1.7
SUSE Linux Enterprise Module for Desktop Applications 15
  • librsvg-devel >= 2.42.3-1.49
  • typelib-1_0-Rsvg-2_0 >= 2.42.3-1.49
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA librsvg-devel-2.42.3-1.49
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • gdk-pixbuf-loader-rsvg >= 2.40.18-5.3.1
  • librsvg-2-2 >= 2.40.18-5.3.1
  • librsvg-2-2-32bit >= 2.40.18-5.3.1
  • librsvg-devel >= 2.40.18-5.3.1
  • rsvg-view >= 2.40.18-5.3.1
  • typelib-1_0-Rsvg-2_0 >= 2.40.18-5.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1315
SUSE-SLE-SERVER-12-SP2-2017-1315
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • gdk-pixbuf-loader-rsvg >= 2.40.18-5.3.1
  • librsvg-2-2 >= 2.40.18-5.3.1
  • librsvg-2-2-32bit >= 2.40.18-5.3.1
  • librsvg-devel >= 2.40.18-5.3.1
  • rsvg-view >= 2.40.18-5.3.1
  • typelib-1_0-Rsvg-2_0 >= 2.40.18-5.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1315
SUSE-SLE-SERVER-12-SP3-2017-1315
SUSE Linux Enterprise Server 12 SP4
  • gdk-pixbuf-loader-rsvg >= 2.40.20-5.6.1
  • librsvg-2-2 >= 2.40.20-5.6.1
  • librsvg-2-2-32bit >= 2.40.20-5.6.1
  • librsvg-devel >= 2.40.20-5.6.1
  • rsvg-view >= 2.40.20-5.6.1
  • typelib-1_0-Rsvg-2_0 >= 2.40.20-5.6.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA gdk-pixbuf-loader-rsvg-2.40.20-5.6.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA librsvg-devel-2.40.20-5.6.1
SUSE Linux Enterprise Server 12 SP5
  • gdk-pixbuf-loader-rsvg >= 2.40.20-5.6.1
  • librsvg-2-2 >= 2.40.20-5.6.1
  • librsvg-2-2-32bit >= 2.40.20-5.6.1
  • librsvg-devel >= 2.40.20-5.6.1
  • rsvg-view >= 2.40.20-5.6.1
  • typelib-1_0-Rsvg-2_0 >= 2.40.20-5.6.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA gdk-pixbuf-loader-rsvg-2.40.20-5.6.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA librsvg-devel-2.40.20-5.6.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gdk-pixbuf-loader-rsvg >= 2.40.18-5.3.1
  • librsvg-2-2 >= 2.40.18-5.3.1
  • rsvg-view >= 2.40.18-5.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1315
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • librsvg-devel >= 2.40.20-5.6.1
  • typelib-1_0-Rsvg-2_0 >= 2.40.20-5.6.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA librsvg-devel-2.40.20-5.6.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • librsvg-devel >= 2.40.20-5.6.1
  • typelib-1_0-Rsvg-2_0 >= 2.40.20-5.6.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA librsvg-devel-2.40.20-5.6.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • librsvg-devel >= 2.40.18-5.3.1
  • typelib-1_0-Rsvg-2_0 >= 2.40.18-5.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1315
SUSE Linux Enterprise Software Development Kit 12 SP3
  • librsvg-devel >= 2.40.18-5.3.1
  • typelib-1_0-Rsvg-2_0 >= 2.40.18-5.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1315
openSUSE Leap 15.0
  • gdk-pixbuf-loader-rsvg >= 2.42.3-lp150.1.20
  • librsvg-2-2 >= 2.42.3-lp150.1.20
  • rsvg-thumbnailer >= 2.42.3-lp150.1.20
  • typelib-1_0-Rsvg-2_0 >= 2.42.3-lp150.1.20
Patchnames:
openSUSE Leap 15.0 GA gdk-pixbuf-loader-rsvg-2.42.3-lp150.1.20
openSUSE Leap 15.2
  • gdk-pixbuf-loader-rsvg >= 2.46.4-lp152.1.25
  • librsvg-2-2 >= 2.46.4-lp152.1.25
  • librsvg-lang >= 2.46.4-lp152.1.25
  • rsvg-thumbnailer >= 2.46.4-lp152.1.25
  • typelib-1_0-Rsvg-2_0 >= 2.46.4-lp152.1.25
Patchnames:
openSUSE Leap 15.2 GA gdk-pixbuf-loader-rsvg-2.46.4-lp152.1.1
openSUSE Leap 15.3
  • gdk-pixbuf-loader-rsvg >= 2.46.5-3.3.1
  • librsvg-2-2 >= 2.46.5-3.3.1
  • librsvg-lang >= 2.46.5-3.3.1
  • rsvg-thumbnailer >= 2.46.5-3.3.1
  • typelib-1_0-Rsvg-2_0 >= 2.46.5-3.3.1
Patchnames:
openSUSE Leap 15.3 GA gdk-pixbuf-loader-rsvg-2.46.5-3.3.1
openSUSE Leap 15.4
  • gdk-pixbuf-loader-rsvg >= 2.52.6-150400.1.7
  • librsvg-2-2 >= 2.52.6-150400.1.7
  • rsvg-thumbnailer >= 2.52.6-150400.1.7
  • typelib-1_0-Rsvg-2_0 >= 2.52.6-150400.1.7
Patchnames:
openSUSE Leap 15.4 GA gdk-pixbuf-loader-rsvg-2.52.6-150400.1.7
openSUSE Tumbleweed
  • gdk-pixbuf-loader-rsvg >= 2.50.7-1.5
  • gdk-pixbuf-loader-rsvg-32bit >= 2.50.7-1.5
  • librsvg-2-2 >= 2.50.7-1.5
  • librsvg-2-2-32bit >= 2.50.7-1.5
  • librsvg-devel >= 2.50.7-1.5
  • librsvg-lang >= 2.50.7-1.5
  • rsvg-convert >= 2.50.7-1.5
  • rsvg-thumbnailer >= 2.50.7-1.5
  • typelib-1_0-Rsvg-2_0 >= 2.50.7-1.5
Patchnames:
openSUSE Tumbleweed GA gdk-pixbuf-loader-rsvg-2.50.7-1.5


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 librsvg Released
SUSE Enterprise Storage 5 librsvg Released
SUSE Linux Enterprise Desktop 11 SP4 librsvg Not affected
SUSE Linux Enterprise Desktop 12 SP2 librsvg Released
SUSE Linux Enterprise Desktop 12 SP3 librsvg Released
SUSE Linux Enterprise High Performance Computing 12 SP5 librsvg Released
SUSE Linux Enterprise Point of Service Image Server 12 SP2 librsvg Released
SUSE Linux Enterprise Server 11 SP3 LTSS librsvg Not affected
SUSE Linux Enterprise Server 11 SP4 librsvg Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS librsvg Not affected
SUSE Linux Enterprise Server 12 SP2 librsvg Released
SUSE Linux Enterprise Server 12 SP2 BCL librsvg Released
SUSE Linux Enterprise Server 12 SP2 ESPOS librsvg Released
SUSE Linux Enterprise Server 12 SP2 LTSS librsvg Released
SUSE Linux Enterprise Server 12 SP3 librsvg Released
SUSE Linux Enterprise Server 12 SP3 BCL librsvg Released
SUSE Linux Enterprise Server 12 SP3 ESPOS librsvg Released
SUSE Linux Enterprise Server 12 SP3 LTSS librsvg Released
SUSE Linux Enterprise Server 12 SP4 ESPOS librsvg Released
SUSE Linux Enterprise Server 12 SP4 LTSS librsvg Released
SUSE Linux Enterprise Server 12 SP5 librsvg Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 librsvg Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 librsvg Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 librsvg Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 librsvg Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 librsvg Released
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 librsvg Released
SUSE Linux Enterprise Software Development Kit 11 SP4 librsvg Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 librsvg Released
SUSE Linux Enterprise Software Development Kit 12 SP3 librsvg Released
SUSE Linux Enterprise Software Development Kit 12 SP5 librsvg Released
SUSE OpenStack Cloud 7 librsvg Released
SUSE OpenStack Cloud 8 librsvg Released
SUSE OpenStack Cloud 9 librsvg Released
SUSE OpenStack Cloud Crowbar 8 librsvg Released
SUSE OpenStack Cloud Crowbar 9 librsvg Released