Upstream information

CVE-2017-11462 at MITRE

Description

Double free vulnerability in MIT Kerberos 5 (aka krb5) allows attackers to have unspecified impact via vectors involving automatic deletion of security contexts on error.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 4.6
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Local
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  SUSE
Base Score 5.3
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entry: 1056995 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • krb5 >= 1.12.5-40.13.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-1644
SUSE CaaS Platform ALL
  • krb5 >= 1.12.5-40.13.1
  • sles12-mariadb-docker-image >= 1.1.0-2.5.19
  • sles12-pause-docker-image >= 1.1.0-2.5.21
  • sles12-pv-recycler-node-docker-image >= 1.1.0-2.5.19
  • sles12-salt-api-docker-image >= 1.1.0-2.5.19
  • sles12-salt-master-docker-image >= 1.1.0-4.5.18
  • sles12-salt-minion-docker-image >= 1.1.0-2.5.18
  • sles12-velum-docker-image >= 1.1.0-4.5.18
Patchnames:
SUSE-CAASP-ALL-2017-1644
SUSE-CAASP-ALL-2017-1782
SUSE Linux Enterprise Build System Kit 12 SP2
  • krb5-mini >= 1.12.5-40.13.1
  • krb5-mini-devel >= 1.12.5-40.13.1
Patchnames:
SUSE-SLE-BSK-12-SP2-2017-1644
SUSE Linux Enterprise Build System Kit 12 SP3
  • krb5-mini >= 1.12.5-40.13.1
  • krb5-mini-devel >= 1.12.5-40.13.1
Patchnames:
SUSE-SLE-BSK-12-SP3-2017-1644
SUSE Linux Enterprise Desktop 12 SP2
  • krb5 >= 1.12.5-40.13.1
  • krb5-32bit >= 1.12.5-40.13.1
  • krb5-client >= 1.12.5-40.13.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1644
SUSE Linux Enterprise Desktop 12 SP3
  • krb5 >= 1.12.5-40.13.1
  • krb5-32bit >= 1.12.5-40.13.1
  • krb5-client >= 1.12.5-40.13.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1644
SUSE Linux Enterprise Module for Basesystem 15
  • krb5 >= 1.15.2-4.25
  • krb5-32bit >= 1.15.2-4.25
  • krb5-client >= 1.15.2-4.25
  • krb5-devel >= 1.15.2-4.25
  • krb5-plugin-preauth-otp >= 1.15.2-4.25
  • krb5-plugin-preauth-pkinit >= 1.15.2-4.25
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA krb5
SUSE Linux Enterprise Module for Server Applications 15
  • krb5-plugin-kdb-ldap >= 1.15.2-4.25
  • krb5-server >= 1.15.2-4.25
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA krb5-plugin-kdb-ldap
SUSE Linux Enterprise Server 11 SP4
  • krb5 >= 1.6.3-133.49.113.7.1
  • krb5-32bit >= 1.6.3-133.49.113.7.1
  • krb5-apps-clients >= 1.6.3-133.49.113.7.1
  • krb5-apps-servers >= 1.6.3-133.49.113.7.1
  • krb5-client >= 1.6.3-133.49.113.7.1
  • krb5-server >= 1.6.3-133.49.113.7.1
  • krb5-x86 >= 1.6.3-133.49.113.7.1
Patchnames:
slessp4-krb5-13541
SUSE Linux Enterprise Server 12 SP2
  • krb5 >= 1.12.5-40.13.1
  • krb5-32bit >= 1.12.5-40.13.1
  • krb5-client >= 1.12.5-40.13.1
  • krb5-doc >= 1.12.5-40.13.1
  • krb5-plugin-kdb-ldap >= 1.12.5-40.13.1
  • krb5-plugin-preauth-otp >= 1.12.5-40.13.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.13.1
  • krb5-server >= 1.12.5-40.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1644
SUSE Linux Enterprise Server 12 SP3
  • krb5 >= 1.12.5-40.13.1
  • krb5-32bit >= 1.12.5-40.13.1
  • krb5-client >= 1.12.5-40.13.1
  • krb5-doc >= 1.12.5-40.13.1
  • krb5-plugin-kdb-ldap >= 1.12.5-40.13.1
  • krb5-plugin-preauth-otp >= 1.12.5-40.13.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.13.1
  • krb5-server >= 1.12.5-40.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1644
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • krb5 >= 1.12.5-40.13.1
  • krb5-client >= 1.12.5-40.13.1
  • krb5-doc >= 1.12.5-40.13.1
  • krb5-plugin-kdb-ldap >= 1.12.5-40.13.1
  • krb5-plugin-preauth-otp >= 1.12.5-40.13.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.13.1
  • krb5-server >= 1.12.5-40.13.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1644
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • krb5 >= 1.6.3-133.49.113.7.1
  • krb5-32bit >= 1.6.3-133.49.113.7.1
  • krb5-apps-clients >= 1.6.3-133.49.113.7.1
  • krb5-apps-servers >= 1.6.3-133.49.113.7.1
  • krb5-client >= 1.6.3-133.49.113.7.1
  • krb5-server >= 1.6.3-133.49.113.7.1
  • krb5-x86 >= 1.6.3-133.49.113.7.1
Patchnames:
slessp4-krb5-13541
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • krb5 >= 1.12.5-40.13.1
  • krb5-32bit >= 1.12.5-40.13.1
  • krb5-client >= 1.12.5-40.13.1
  • krb5-doc >= 1.12.5-40.13.1
  • krb5-plugin-kdb-ldap >= 1.12.5-40.13.1
  • krb5-plugin-preauth-otp >= 1.12.5-40.13.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.13.1
  • krb5-server >= 1.12.5-40.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1644
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • krb5 >= 1.12.5-40.13.1
  • krb5-32bit >= 1.12.5-40.13.1
  • krb5-client >= 1.12.5-40.13.1
  • krb5-doc >= 1.12.5-40.13.1
  • krb5-plugin-kdb-ldap >= 1.12.5-40.13.1
  • krb5-plugin-preauth-otp >= 1.12.5-40.13.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.13.1
  • krb5-server >= 1.12.5-40.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1644
SUSE Linux Enterprise Software Development Kit 11 SP4
  • krb5 >= 1.6.3-133.49.113.7.1
  • krb5-devel >= 1.6.3-133.49.113.7.1
  • krb5-devel-32bit >= 1.6.3-133.49.113.7.1
  • krb5-server >= 1.6.3-133.49.113.7.1
Patchnames:
sdksp4-krb5-13541
SUSE Linux Enterprise Software Development Kit 12 SP2
  • krb5 >= 1.12.5-40.13.1
  • krb5-devel >= 1.12.5-40.13.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1644
SUSE Linux Enterprise Software Development Kit 12 SP3
  • krb5 >= 1.12.5-40.13.1
  • krb5-devel >= 1.12.5-40.13.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1644
openSUSE Leap 15.0
  • krb5 >= 1.15.2-lp150.4.4
  • krb5-32bit >= 1.15.2-lp150.4.4
  • krb5-server >= 1.15.2-lp150.4.4
Patchnames:
openSUSE Leap 15.0 GA krb5
openSUSE Leap 42.2
  • krb5 >= 1.12.5-6.3.1
  • krb5-32bit >= 1.12.5-6.3.1
  • krb5-client >= 1.12.5-6.3.1
  • krb5-client-debuginfo >= 1.12.5-6.3.1
  • krb5-debuginfo >= 1.12.5-6.3.1
  • krb5-debuginfo-32bit >= 1.12.5-6.3.1
  • krb5-debugsource >= 1.12.5-6.3.1
  • krb5-devel >= 1.12.5-6.3.1
  • krb5-devel-32bit >= 1.12.5-6.3.1
  • krb5-doc >= 1.12.5-6.3.1
  • krb5-mini >= 1.12.5-6.3.1
  • krb5-mini-debuginfo >= 1.12.5-6.3.1
  • krb5-mini-debugsource >= 1.12.5-6.3.1
  • krb5-mini-devel >= 1.12.5-6.3.1
  • krb5-plugin-kdb-ldap >= 1.12.5-6.3.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.12.5-6.3.1
  • krb5-plugin-preauth-otp >= 1.12.5-6.3.1
  • krb5-plugin-preauth-otp-debuginfo >= 1.12.5-6.3.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-6.3.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.12.5-6.3.1
  • krb5-server >= 1.12.5-6.3.1
  • krb5-server-debuginfo >= 1.12.5-6.3.1
Patchnames:
openSUSE-2017-1145
openSUSE Leap 42.3
  • krb5 >= 1.12.5-9.1
  • krb5-32bit >= 1.12.5-9.1
  • krb5-client >= 1.12.5-9.1
  • krb5-client-debuginfo >= 1.12.5-9.1
  • krb5-debuginfo >= 1.12.5-9.1
  • krb5-debuginfo-32bit >= 1.12.5-9.1
  • krb5-debugsource >= 1.12.5-9.1
  • krb5-devel >= 1.12.5-9.1
  • krb5-devel-32bit >= 1.12.5-9.1
  • krb5-doc >= 1.12.5-9.1
  • krb5-mini >= 1.12.5-9.1
  • krb5-mini-debuginfo >= 1.12.5-9.1
  • krb5-mini-debugsource >= 1.12.5-9.1
  • krb5-mini-devel >= 1.12.5-9.1
  • krb5-plugin-kdb-ldap >= 1.12.5-9.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.12.5-9.1
  • krb5-plugin-preauth-otp >= 1.12.5-9.1
  • krb5-plugin-preauth-otp-debuginfo >= 1.12.5-9.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-9.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.12.5-9.1
  • krb5-server >= 1.12.5-9.1
  • krb5-server-debuginfo >= 1.12.5-9.1
Patchnames:
openSUSE-2017-1145


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 krb5 Released
CaaS Platform 2.0 krb5 Released
OpenStack Cloud Magnum Orchestration 7.0 krb5 Released
SUSE Linux Enterprise Desktop 12 SP2 krb5 Released
SUSE Linux Enterprise Desktop 12 SP3 krb5 Released
SUSE Linux Enterprise SDK 11 SP4 krb5 Released
SUSE Linux Enterprise SDK 12 SP2 krb5 Released
SUSE Linux Enterprise SDK 12 SP3 krb5 Released
SUSE Linux Enterprise Server 11 SP3 LTSS krb5 Affected
SUSE Linux Enterprise Server 11 SP4 krb5 Released
SUSE Linux Enterprise Server 12 GA LTSS krb5 Unsupported
SUSE Linux Enterprise Server 12 SP1 LTSS krb5 Unsupported
SUSE Linux Enterprise Server 12 SP2 krb5 Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI krb5 Released
SUSE Linux Enterprise Server 12 SP3 krb5 Released