Upstream information

CVE-2017-1000367 at MITRE

Description

Todd Miller's sudo version 1.8.20 and earlier is vulnerable to an input validation (embedded spaces) in the get_process_ttyname() function resulting in information disclosure and command execution.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.89 6.89
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Complete Complete
Integrity Impact Complete Complete
Availability Impact Complete Complete
CVSS v3 Scores
  SUSE
Base Score 7.8
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High

Note from the SUSE Security Team

This security issue only affects sudo 1.8.5 or later. The sudo versions on SUSE Linux Enterprise 11 and older products are not affected. This issue is also only a problem if the system operates in SELinux mode.

SUSE Bugzilla entries: 1007501 [RESOLVED / FIXED], 1039361 [RESOLVED / ], 1042146 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • sudo >= 1.8.10p3-10.5.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-889
SUSE Linux Enterprise Desktop 12 SP1
  • sudo >= 1.8.10p3-2.11.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-888
SUSE Linux Enterprise Desktop 12 SP2
  • sudo >= 1.8.10p3-10.5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-889
SUSE Linux Enterprise Server 12 SP1
  • sudo >= 1.8.10p3-2.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-888
SUSE Linux Enterprise Server 12 SP2
  • sudo >= 1.8.10p3-10.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-889
SUSE Linux Enterprise Server 12-LTSS
  • sudo >= 1.8.10p3-2.11.1
Patchnames:
SUSE-SLE-SERVER-12-2017-888
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • sudo >= 1.8.10p3-10.5.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-889
SUSE Linux Enterprise Software Development Kit 12 SP1
  • sudo >= 1.8.10p3-2.11.1
  • sudo-devel >= 1.8.10p3-2.11.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-888
SUSE Linux Enterprise Software Development Kit 12 SP2
  • sudo >= 1.8.10p3-10.5.1
  • sudo-devel >= 1.8.10p3-10.5.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-889
SUSE Linux Enterprise for SAP 12
  • sudo >= 1.8.10p3-2.11.1
Patchnames:
SUSE-SLE-SAP-12-2017-888
openSUSE Leap 42.2
  • sudo >= 1.8.10p3-9.3.1
  • sudo-debuginfo >= 1.8.10p3-9.3.1
  • sudo-debugsource >= 1.8.10p3-9.3.1
  • sudo-devel >= 1.8.10p3-9.3.1
  • sudo-test >= 1.8.10p3-9.3.1
Patchnames:
openSUSE-2017-636


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server 11 SP2 LTSS
  • SUSE Linux Enterprise Server 11 SP3 LTSS
  • SUSE Linux Enterprise Server 12 GA
  • SUSE Linux Enterprise Server for SAP 11 SP3
  • SUSE Linux Enterprise Server for SAP 12 GA
sudo