Upstream information

CVE-2016-9813 at MITRE

Description

The _parse_pat function in the mpegts parser in GStreamer before 1.10.2 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 7.1
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:C
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack Vector Local
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1013680 [RESOLVED / FIXED]

SUSE Security Advisories:

  • SUSE-SU-2016:3296-1, published Thu Dec 29 16:07:46 MST 2016
  • SUSE-SU-2016:3297-1, published Thu Dec 29 16:08:58 MST 2016
  • openSUSE-SU-2017:0072-1 openSUSE-SU-2017:0149-1 openSUSE-SU-2017:0152-1

List of released packages

Product(s) Fixed package version(s) References
SUSE Liberty Linux 7
  • gstreamer1-plugins-bad-free >= 1.4.5-6.el7_3
  • gstreamer1-plugins-bad-free-devel >= 1.4.5-6.el7_3
Patchnames:
RHSA-2017:0021
SUSE Linux Enterprise Desktop 12 SP1
  • gstreamer-plugins-bad >= 1.2.4-3.4.1
  • gstreamer-plugins-bad-devel >= 1.2.4-3.4.1
  • gstreamer-plugins-bad-lang >= 1.2.4-3.4.1
  • libgstbasecamerabinsrc-1_0-0 >= 1.2.4-3.4.1
  • libgstcodecparsers-1_0-0 >= 1.2.4-3.4.1
  • libgstegl-1_0-0 >= 1.2.4-3.4.1
  • libgstinsertbin-1_0-0 >= 1.2.4-3.4.1
  • libgstmpegts-1_0-0 >= 1.2.4-3.4.1
  • libgstphotography-1_0-0 >= 1.2.4-3.4.1
  • libgsturidownloader-1_0-0 >= 1.2.4-3.4.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1932
SUSE-SLE-SDK-12-SP1-2016-1932
SUSE Linux Enterprise Desktop 12 SP2
  • gstreamer-plugins-bad >= 1.8.3-14.1
  • gstreamer-plugins-bad-devel >= 1.8.3-14.1
  • gstreamer-plugins-bad-lang >= 1.8.3-14.1
  • libgstadaptivedemux-1_0-0 >= 1.8.3-14.1
  • libgstbadaudio-1_0-0 >= 1.8.3-14.1
  • libgstbadbase-1_0-0 >= 1.8.3-14.1
  • libgstbadvideo-1_0-0 >= 1.8.3-14.1
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-14.1
  • libgstcodecparsers-1_0-0 >= 1.8.3-14.1
  • libgstegl-1_0-0 >= 1.2.4-3.4.1
  • libgstgl-1_0-0 >= 1.8.3-14.1
  • libgstinsertbin-1_0-0 >= 1.8.3-14.1
  • libgstmpegts-1_0-0 >= 1.8.3-14.1
  • libgstphotography-1_0-0 >= 1.8.3-14.1
  • libgsturidownloader-1_0-0 >= 1.8.3-14.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2016-1932
SUSE-SLE-DESKTOP-12-SP2-2016-1933
SUSE-SLE-SDK-12-SP2-2016-1933
SUSE Linux Enterprise Desktop 12 SP3
  • gstreamer-plugins-bad >= 1.8.3-17.2
  • gstreamer-plugins-bad-devel >= 1.8.3-17.2
  • gstreamer-plugins-bad-lang >= 1.8.3-17.2
  • libgstadaptivedemux-1_0-0 >= 1.8.3-17.2
  • libgstbadaudio-1_0-0 >= 1.8.3-17.2
  • libgstbadbase-1_0-0 >= 1.8.3-17.2
  • libgstbadvideo-1_0-0 >= 1.8.3-17.2
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-17.2
  • libgstcodecparsers-1_0-0 >= 1.8.3-17.2
  • libgstgl-1_0-0 >= 1.8.3-17.2
  • libgstinsertbin-1_0-0 >= 1.8.3-17.2
  • libgstmpegts-1_0-0 >= 1.8.3-17.2
  • libgstphotography-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA gstreamer-plugins-bad-1.8.3-17.2
SUSE Linux Enterprise Software Development Kit 12 SP3 GA gstreamer-plugins-bad-devel-1.8.3-17.2
SUSE Linux Enterprise Desktop 12 SP4
  • gstreamer-plugins-bad >= 1.8.3-17.2
  • gstreamer-plugins-bad-devel >= 1.8.3-17.2
  • gstreamer-plugins-bad-lang >= 1.8.3-17.2
  • libgstadaptivedemux-1_0-0 >= 1.8.3-17.2
  • libgstbadaudio-1_0-0 >= 1.8.3-17.2
  • libgstbadbase-1_0-0 >= 1.8.3-17.2
  • libgstbadvideo-1_0-0 >= 1.8.3-17.2
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-17.2
  • libgstcodecparsers-1_0-0 >= 1.8.3-17.2
  • libgstgl-1_0-0 >= 1.8.3-17.2
  • libgstinsertbin-1_0-0 >= 1.8.3-17.2
  • libgstmpegts-1_0-0 >= 1.8.3-17.2
  • libgstphotography-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA gstreamer-plugins-bad-1.8.3-17.2
SUSE Linux Enterprise Software Development Kit 12 SP4 GA gstreamer-plugins-bad-devel-1.8.3-17.2
SUSE Linux Enterprise High Performance Computing 12 SP5
  • gstreamer-plugins-bad >= 1.8.3-17.2
  • gstreamer-plugins-bad-lang >= 1.8.3-17.2
  • libgstadaptivedemux-1_0-0 >= 1.8.3-17.2
  • libgstbadaudio-1_0-0 >= 1.8.3-17.2
  • libgstbadbase-1_0-0 >= 1.8.3-17.2
  • libgstbadvideo-1_0-0 >= 1.8.3-17.2
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-17.2
  • libgstcodecparsers-1_0-0 >= 1.8.3-17.2
  • libgstgl-1_0-0 >= 1.8.3-17.2
  • libgstmpegts-1_0-0 >= 1.8.3-17.2
  • libgstphotography-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA gstreamer-plugins-bad-1.8.3-17.2
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • gstreamer-plugins-bad >= 1.2.4-3.4.1
  • gstreamer-plugins-bad-devel >= 1.2.4-3.4.1
  • gstreamer-plugins-bad-lang >= 1.2.4-3.4.1
  • libgstbasecamerabinsrc-1_0-0 >= 1.2.4-3.4.1
  • libgstcodecparsers-1_0-0 >= 1.2.4-3.4.1
  • libgstegl-1_0-0 >= 1.2.4-3.4.1
  • libgstinsertbin-1_0-0 >= 1.2.4-3.4.1
  • libgstmpegts-1_0-0 >= 1.2.4-3.4.1
  • libgstphotography-1_0-0 >= 1.2.4-3.4.1
  • libgsturidownloader-1_0-0 >= 1.2.4-3.4.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1932
SUSE-SLE-SERVER-12-SP1-2016-1932
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • gstreamer-plugins-bad >= 1.8.3-14.1
  • gstreamer-plugins-bad-devel >= 1.8.3-14.1
  • gstreamer-plugins-bad-lang >= 1.8.3-14.1
  • libgstadaptivedemux-1_0-0 >= 1.8.3-14.1
  • libgstbadaudio-1_0-0 >= 1.8.3-14.1
  • libgstbadbase-1_0-0 >= 1.8.3-14.1
  • libgstbadvideo-1_0-0 >= 1.8.3-14.1
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-14.1
  • libgstcodecparsers-1_0-0 >= 1.8.3-14.1
  • libgstegl-1_0-0 >= 1.2.4-3.4.1
  • libgstgl-1_0-0 >= 1.8.3-14.1
  • libgstinsertbin-1_0-0 >= 1.8.3-14.1
  • libgstmpegts-1_0-0 >= 1.8.3-14.1
  • libgstphotography-1_0-0 >= 1.8.3-14.1
  • libgsturidownloader-1_0-0 >= 1.8.3-14.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2016-1933
SUSE-SLE-SERVER-12-SP2-2016-1932
SUSE-SLE-SERVER-12-SP2-2016-1933
SUSE Linux Enterprise Server 12 SP3
  • gstreamer-plugins-bad >= 1.8.3-17.2
  • gstreamer-plugins-bad-devel >= 1.8.3-17.2
  • gstreamer-plugins-bad-lang >= 1.8.3-17.2
  • libgstadaptivedemux-1_0-0 >= 1.8.3-17.2
  • libgstbadaudio-1_0-0 >= 1.8.3-17.2
  • libgstbadbase-1_0-0 >= 1.8.3-17.2
  • libgstbadvideo-1_0-0 >= 1.8.3-17.2
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-17.2
  • libgstcodecparsers-1_0-0 >= 1.8.3-17.2
  • libgstgl-1_0-0 >= 1.8.3-17.2
  • libgstinsertbin-1_0-0 >= 1.8.3-17.2
  • libgstmpegts-1_0-0 >= 1.8.3-17.2
  • libgstphotography-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA gstreamer-plugins-bad-1.8.3-17.2
SUSE Linux Enterprise Software Development Kit 12 SP3 GA gstreamer-plugins-bad-devel-1.8.3-17.2
SUSE Linux Enterprise Server 12 SP4
  • gstreamer-plugins-bad >= 1.8.3-17.2
  • gstreamer-plugins-bad-devel >= 1.8.3-17.2
  • gstreamer-plugins-bad-lang >= 1.8.3-17.2
  • libgstadaptivedemux-1_0-0 >= 1.8.3-17.2
  • libgstbadaudio-1_0-0 >= 1.8.3-17.2
  • libgstbadbase-1_0-0 >= 1.8.3-17.2
  • libgstbadvideo-1_0-0 >= 1.8.3-17.2
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-17.2
  • libgstcodecparsers-1_0-0 >= 1.8.3-17.2
  • libgstgl-1_0-0 >= 1.8.3-17.2
  • libgstinsertbin-1_0-0 >= 1.8.3-17.2
  • libgstmpegts-1_0-0 >= 1.8.3-17.2
  • libgstphotography-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA gstreamer-plugins-bad-1.8.3-17.2
SUSE Linux Enterprise Software Development Kit 12 SP4 GA gstreamer-plugins-bad-devel-1.8.3-17.2
SUSE Linux Enterprise Server 12 SP5
  • gstreamer-plugins-bad >= 1.8.3-17.2
  • gstreamer-plugins-bad-devel >= 1.8.3-14.1
  • gstreamer-plugins-bad-lang >= 1.8.3-17.2
  • libgstadaptivedemux-1_0-0 >= 1.8.3-17.2
  • libgstbadaudio-1_0-0 >= 1.8.3-17.2
  • libgstbadbase-1_0-0 >= 1.8.3-17.2
  • libgstbadvideo-1_0-0 >= 1.8.3-17.2
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-17.2
  • libgstcodecparsers-1_0-0 >= 1.8.3-17.2
  • libgstgl-1_0-0 >= 1.8.3-17.2
  • libgstinsertbin-1_0-0 >= 1.8.3-14.1
  • libgstmpegts-1_0-0 >= 1.8.3-17.2
  • libgstphotography-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-14.1
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA gstreamer-plugins-bad-1.8.3-17.2
SUSE Linux Enterprise Software Development Kit 12 SP5 GA gstreamer-plugins-bad-1.8.3-17.2
SUSE Linux Enterprise Software Development Kit 12 SP5 GA gstreamer-plugins-bad-devel-1.8.3-17.2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gstreamer-plugins-bad >= 1.8.3-14.1
  • gstreamer-plugins-bad-lang >= 1.8.3-14.1
  • libgstadaptivedemux-1_0-0 >= 1.8.3-14.1
  • libgstbadaudio-1_0-0 >= 1.8.3-14.1
  • libgstbadbase-1_0-0 >= 1.8.3-14.1
  • libgstbadvideo-1_0-0 >= 1.8.3-14.1
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-14.1
  • libgstcodecparsers-1_0-0 >= 1.8.3-14.1
  • libgstegl-1_0-0 >= 1.2.4-3.4.1
  • libgstgl-1_0-0 >= 1.8.3-14.1
  • libgstmpegts-1_0-0 >= 1.8.3-14.1
  • libgstphotography-1_0-0 >= 1.8.3-14.1
  • libgsturidownloader-1_0-0 >= 1.8.3-14.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2016-1932
SUSE-SLE-RPI-12-SP2-2016-1933
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • gstreamer-plugins-bad-devel >= 1.8.3-17.2
  • libgstinsertbin-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA gstreamer-plugins-bad-devel-1.8.3-17.2
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • gstreamer-plugins-bad-devel >= 1.8.3-17.2
  • libgstinsertbin-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA gstreamer-plugins-bad-devel-1.8.3-17.2
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • gstreamer-plugins-bad-devel >= 1.8.3-14.1
  • libgstinsertbin-1_0-0 >= 1.8.3-14.1
  • libgsturidownloader-1_0-0 >= 1.8.3-14.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA gstreamer-plugins-bad-1.8.3-17.2
SUSE Linux Enterprise Software Development Kit 12 SP5 GA gstreamer-plugins-bad-devel-1.8.3-17.2
SUSE Linux Enterprise Software Development Kit 12 SP1
  • gstreamer-plugins-bad-devel >= 1.2.4-3.4.1
  • libgstinsertbin-1_0-0 >= 1.2.4-3.4.1
  • libgsturidownloader-1_0-0 >= 1.2.4-3.4.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1932
SUSE Linux Enterprise Software Development Kit 12 SP2
  • gstreamer-plugins-bad-devel >= 1.8.3-14.1
  • libgstinsertbin-1_0-0 >= 1.8.3-14.1
  • libgsturidownloader-1_0-0 >= 1.8.3-14.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2016-1933


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP5 gstreamer-plugins-bad Released
SUSE Linux Enterprise Server 12 SP5 gstreamer-plugins-bad Released
SUSE Linux Enterprise Server 12-LTSS gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gstreamer-plugins-bad Released
SUSE Linux Enterprise Software Development Kit 12 SP5 gstreamer-plugins-bad Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 12 SP2-BCL gstreamer-plugins-bad Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Desktop 12 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Desktop 12 SP1 gstreamer-plugins-bad Released
SUSE Linux Enterprise Desktop 12 SP2 gstreamer-plugins-bad Released
SUSE Linux Enterprise Desktop 12 SP3 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Desktop 12 SP4 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Point of Service Image Server 12 SP2 gstreamer-plugins-bad Released
SUSE Linux Enterprise Server 12 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server 12 SP1 gstreamer-plugins-bad Released
SUSE Linux Enterprise Server 12 SP1-LTSS gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server 12 SP2 gstreamer-plugins-bad Released
SUSE Linux Enterprise Server 12 SP2-ESPOS gstreamer-plugins-bad Released
SUSE Linux Enterprise Server 12 SP2-LTSS gstreamer-plugins-bad Released
SUSE Linux Enterprise Server 12 SP3 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server 12 SP3-BCL gstreamer-plugins-bad Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS gstreamer-plugins-bad Unsupported
SUSE Linux Enterprise Server 12 SP3-LTSS gstreamer-plugins-bad Unsupported
SUSE Linux Enterprise Server 12 SP4 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server 12 SP4-LTSS gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 gstreamer-plugins-bad Released
SUSE Linux Enterprise Server for SAP Applications 12 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 gstreamer-plugins-bad Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gstreamer-plugins-bad Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gstreamer-plugins-bad Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 gstreamer-plugins-bad Released
SUSE Linux Enterprise Software Development Kit 12 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 gstreamer-plugins-bad Released
SUSE Linux Enterprise Software Development Kit 12 SP2 gstreamer-plugins-bad Released
SUSE Linux Enterprise Software Development Kit 12 SP3 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 gstreamer-plugins-bad Affected
SUSE OpenStack Cloud 7 gstreamer-plugins-bad Released
SUSE OpenStack Cloud 8 gstreamer-plugins-bad Affected
SUSE OpenStack Cloud 9 gstreamer-plugins-bad Affected
SUSE OpenStack Cloud Crowbar 8 gstreamer-plugins-bad Affected
SUSE OpenStack Cloud Crowbar 9 gstreamer-plugins-bad Affected


SUSE Timeline for this CVE

CVE page created: Mon Dec 5 05:58:22 2016
CVE page last modified: Thu Dec 7 13:12:40 2023