Upstream information

CVE-2016-9807 at MITRE

Description

The flx_decode_chunks function in gst/flx/gstflxdec.c in GStreamer before 1.10.2 allows remote attackers to cause a denial of service (invalid memory read and crash) via a crafted FLIC file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 7.1
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:C
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1013655 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • gstreamer-0_10-plugins-good >= 0.10.31-13.3.3
  • gstreamer-0_10-plugins-good-lang >= 0.10.31-13.3.3
  • gstreamer-plugins-good >= 1.2.4-2.3.1
  • gstreamer-plugins-good-lang >= 1.2.4-2.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1922
SUSE-SLE-DESKTOP-12-SP1-2017-118
SUSE Linux Enterprise Desktop 12 SP2
  • gstreamer-0_10-plugins-good >= 0.10.31-16.1
  • gstreamer-0_10-plugins-good-lang >= 0.10.31-16.1
  • gstreamer-plugins-good >= 1.8.3-9.1
  • gstreamer-plugins-good-lang >= 1.8.3-9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2016-1939
SUSE-SLE-DESKTOP-12-SP2-2017-104
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
  • gstreamer-0_10-plugins-good >= 0.10.31-16.1
  • gstreamer-0_10-plugins-good-lang >= 0.10.31-16.1
  • gstreamer-plugins-good >= 1.8.3-15.1
  • gstreamer-plugins-good-lang >= 1.8.3-15.1
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • gstreamer-plugins-good >= 1.8.3-15.1
  • gstreamer-plugins-good-lang >= 1.8.3-15.1
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • gstreamer-0_10-plugins-good >= 0.10.30-5.14.1
  • gstreamer-0_10-plugins-good-doc >= 0.10.30-5.14.1
  • gstreamer-0_10-plugins-good-lang >= 0.10.30-5.14.1
Patchnames:
slessp4-gstreamer-0_10-plugins-good-12948
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • gstreamer-plugins-good >= 1.2.4-2.3.1
  • gstreamer-plugins-good-lang >= 1.2.4-2.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1922
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • gstreamer-plugins-good >= 1.8.3-9.1
  • gstreamer-plugins-good-lang >= 1.8.3-9.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1939
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gstreamer-plugins-good >= 1.8.3-9.1
  • gstreamer-plugins-good-lang >= 1.8.3-9.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2016-1939
SUSE Linux Enterprise Workstation Extension 12 SP1
  • gstreamer-0_10-plugins-good >= 0.10.31-13.3.3
  • gstreamer-0_10-plugins-good-lang >= 0.10.31-13.3.3
Patchnames:
SUSE-SLE-WE-12-SP1-2017-118
SUSE Linux Enterprise Workstation Extension 12 SP2
  • gstreamer-0_10-plugins-good >= 0.10.31-16.1
  • gstreamer-0_10-plugins-good-lang >= 0.10.31-16.1
Patchnames:
SUSE-SLE-WE-12-SP2-2017-104
SUSE Linux Enterprise Workstation Extension 12 SP3
SUSE Linux Enterprise Workstation Extension 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP5
  • gstreamer-0_10-plugins-good >= 0.10.31-16.1
  • gstreamer-0_10-plugins-good-lang >= 0.10.31-16.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 gstreamer-plugins-good In progress
SUSE Linux Enterprise Desktop 12 SP1 gstreamer-plugins-good Released
SUSE Linux Enterprise Desktop 12 SP2 gstreamer-plugins-good Released
SUSE Linux Enterprise High Performance Computing 12 SP5 gstreamer-plugins-good In progress
SUSE Linux Enterprise Point of Service 11 SP3 gstreamer-0_10-plugins-good In progress
SUSE Linux Enterprise Server 11 SP4 LTSS gstreamer-0_10-plugins-good In progress
SUSE Linux Enterprise Server 12 LTSS gstreamer-plugins-good Released
SUSE Linux Enterprise Server 12 SP1 gstreamer-plugins-good Released
SUSE Linux Enterprise Server 12 SP2 gstreamer-plugins-good Released
SUSE Linux Enterprise Server 12 SP2 BCL gstreamer-plugins-good In progress
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON gstreamer-plugins-good In progress
SUSE Linux Enterprise Server 12 SP2 LTSS SAP gstreamer-plugins-good In progress
SUSE Linux Enterprise Server 12 SP3 BCL gstreamer-plugins-good In progress
SUSE Linux Enterprise Server 12 SP3 ESPOS gstreamer-plugins-good In progress
SUSE Linux Enterprise Server 12 SP3 LTSS gstreamer-plugins-good In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS gstreamer-plugins-good In progress
SUSE Linux Enterprise Server 12 SP4 LTSS gstreamer-plugins-good In progress
SUSE Linux Enterprise Server 12 SP5 gstreamer-plugins-good In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gstreamer-plugins-good In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gstreamer-plugins-good In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gstreamer-plugins-good In progress
SUSE Linux Enterprise Server for the Raspberry Pi gstreamer-plugins-good Released
SUSE Linux Enterprise Workstation Extension 12 gstreamer-0_10-plugins-good Released
SUSE OpenStack Cloud 8 gstreamer-plugins-good In progress
SUSE OpenStack Cloud 9 gstreamer-plugins-good In progress
SUSE OpenStack Cloud Crowbar 8 gstreamer-plugins-good In progress
SUSE OpenStack Cloud Crowbar 9 gstreamer-plugins-good In progress