Upstream information

CVE-2016-9801 at MITRE

Description

In BlueZ 5.42, a buffer overflow was observed in "set_ext_ctrl" function in "tools/parser/l2cap.c" source file when processing corrupted dump file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 1.2
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:L/AC:H/Au:N/C:N/I:N/A:P
Access Vector Network Local
Access Complexity Low High
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
SUSE Bugzilla entry: 1013732 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • bluez >= 5.13-5.7.1
  • bluez-cups >= 5.13-5.7.1
  • libbluetooth3 >= 5.13-5.7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2987
SUSE Linux Enterprise Desktop 12 SP4
  • bluez >= 5.13-5.7.1
  • bluez-cups >= 5.13-5.7.1
  • libbluetooth3 >= 5.13-5.7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2018-2987
SUSE Linux Enterprise Module for Basesystem 15
  • bluez >= 5.48-5.8.1
  • libbluetooth3 >= 5.48-5.8.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2988
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libbluetooth3 >= 5.48-5.13.10
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libbluetooth3
SUSE Linux Enterprise Module for Desktop Applications 15
  • bluez >= 5.48-5.8.1
  • bluez-devel >= 5.48-5.8.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-2988
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • bluez >= 5.48-5.13.10
  • bluez-devel >= 5.48-5.13.10
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA bluez
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • bluez >= 5.48-5.8.1
  • bluez-auto-enable-devices >= 5.48-5.8.1
  • bluez-test >= 5.48-5.8.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2018-2988
SUSE Linux Enterprise Server 12 SP1-LTSS
  • bluez >= 5.13-3.10.1
  • libbluetooth3 >= 5.13-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-510
SUSE Linux Enterprise Server 12 SP3
  • bluez >= 5.13-5.7.1
  • libbluetooth3 >= 5.13-5.7.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2987
SUSE Linux Enterprise Server 12 SP4
  • bluez >= 5.13-5.7.1
  • libbluetooth3 >= 5.13-5.7.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2018-2987
SUSE Linux Enterprise Server 12-LTSS
  • bluez >= 5.13-3.10.1
  • libbluetooth3 >= 5.13-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-2019-510
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • bluez >= 5.13-3.10.1
  • libbluetooth3 >= 5.13-3.10.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-510
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • bluez >= 5.13-3.10.1
  • libbluetooth3 >= 5.13-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-510
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • bluez >= 5.13-5.7.1
  • libbluetooth3 >= 5.13-5.7.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2987
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • bluez >= 5.13-5.7.1
  • libbluetooth3 >= 5.13-5.7.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2018-2987
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • bluez >= 5.13-3.10.1
  • libbluetooth3 >= 5.13-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-2019-510
SUSE Linux Enterprise Software Development Kit 12 SP3
  • bluez >= 5.13-5.7.1
  • bluez-devel >= 5.13-5.7.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2987
SUSE Linux Enterprise Software Development Kit 12 SP4
  • bluez >= 5.13-5.7.1
  • bluez-devel >= 5.13-5.7.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2018-2987
SUSE Linux Enterprise Workstation Extension 12 SP3
  • bluez >= 5.13-5.7.1
  • bluez-cups >= 5.13-5.7.1
Patchnames:
SUSE-SLE-WE-12-SP3-2018-2987
SUSE Linux Enterprise Workstation Extension 12 SP4
  • bluez >= 5.13-5.7.1
  • bluez-cups >= 5.13-5.7.1
Patchnames:
SUSE-SLE-WE-12-SP4-2018-2987
SUSE Linux Enterprise Workstation Extension 15
  • bluez >= 5.48-5.8.1
  • bluez-cups >= 5.48-5.8.1
Patchnames:
SUSE-SLE-Product-WE-15-2018-2988
SUSE Linux Enterprise Workstation Extension 15 SP1
  • bluez-cups >= 5.48-5.13.10
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP1 GA bluez-cups
SUSE OpenStack Cloud 6
  • bluez >= 5.13-3.10.1
  • libbluetooth3 >= 5.13-3.10.1
Patchnames:
SUSE-OpenStack-Cloud-6-2019-510
openSUSE Leap 15.0
  • bluez >= 5.48-lp150.4.6.1
  • bluez-auto-enable-devices >= 5.48-lp150.4.6.1
  • bluez-cups >= 5.48-lp150.4.6.1
  • bluez-cups-debuginfo >= 5.48-lp150.4.6.1
  • bluez-debuginfo >= 5.48-lp150.4.6.1
  • bluez-debugsource >= 5.48-lp150.4.6.1
  • bluez-devel >= 5.48-lp150.4.6.1
  • bluez-devel-32bit >= 5.48-lp150.4.6.1
  • bluez-test >= 5.48-lp150.4.6.1
  • bluez-test-debuginfo >= 5.48-lp150.4.6.1
  • libbluetooth3 >= 5.48-lp150.4.6.1
  • libbluetooth3-32bit >= 5.48-lp150.4.6.1
  • libbluetooth3-32bit-debuginfo >= 5.48-lp150.4.6.1
  • libbluetooth3-debuginfo >= 5.48-lp150.4.6.1
Patchnames:
openSUSE-2019-1030


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 bluez Affected
SUSE Linux Enterprise Desktop 12 SP2 bluez Affected
SUSE Linux Enterprise Desktop 12 SP3 bluez Released
SUSE Linux Enterprise Desktop 12 SP4 bluez Released
SUSE Linux Enterprise High Performance Computing 12 bluez Released
SUSE Linux Enterprise Module for Basesystem 15 GA bluez Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA bluez Released
SUSE Linux Enterprise SDK 11 SP4 bluez Not affected
SUSE Linux Enterprise SDK 12 SP1 bluez Affected
SUSE Linux Enterprise SDK 12 SP2 bluez Affected
SUSE Linux Enterprise SDK 12 SP3 bluez Released
SUSE Linux Enterprise SDK 12 SP4 bluez Released
SUSE Linux Enterprise Server 11 SP4 bluez Not affected
SUSE Linux Enterprise Server 12 GA LTSS bluez Released
SUSE Linux Enterprise Server 12 SP1 bluez Affected
SUSE Linux Enterprise Server 12 SP1 LTSS bluez Released
SUSE Linux Enterprise Server 12 SP2 bluez Affected
SUSE Linux Enterprise Server 12 SP3 bluez Released
SUSE Linux Enterprise Server 12 SP4 bluez Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 bluez Released
SUSE Linux Enterprise Workstation Extension 12 SP1 bluez Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 bluez Affected
SUSE Linux Enterprise Workstation Extension 12 SP3 bluez Released
SUSE Linux Enterprise Workstation Extension 12 SP4 bluez Released
SUSE Linux Enterprise Workstation Extension 15 GA bluez Released