Upstream information

CVE-2016-9377 at MITRE

Description

Xen 4.5.x through 4.7.x on AMD systems without the NRip feature, when emulating instructions that generate software interrupts, allows local HVM guest OS users to cause a denial of service (guest crash) by leveraging IDT entry miscalculation.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 2.1 4.7
Vector AV:L/AC:L/Au:N/C:N/I:N/A:P AV:L/AC:M/Au:N/C:N/I:N/A:C
Access Vector Local Local
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1009108 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • xen >= 4.5.5_02-22.3.1
  • xen-kmp-default >= 4.5.5_02_k3.12.67_60.64.18-22.3.1
  • xen-libs >= 4.5.5_02-22.3.1
  • xen-libs-32bit >= 4.5.5_02-22.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1795
SUSE Linux Enterprise Desktop 12 SP2
  • xen >= 4.7.1_02-25.1
  • xen-libs >= 4.7.1_02-25.1
  • xen-libs-32bit >= 4.7.1_02-25.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2016-1785
SUSE Linux Enterprise Desktop 12 SP3
  • xen >= 4.9.0_08-2.2
  • xen-libs >= 4.9.0_08-2.2
  • xen-libs-32bit >= 4.9.0_08-2.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA xen
SUSE Linux Enterprise Desktop 12 SP4
  • xen >= 4.11.0_08-1.11
  • xen-libs >= 4.11.0_08-1.11
  • xen-libs-32bit >= 4.11.0_08-1.11
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA xen
SUSE Linux Enterprise Module for Basesystem 15
  • xen-libs >= 4.10.1_04-1.4
  • xen-tools-domU >= 4.10.1_04-1.4
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA xen-libs
SUSE Linux Enterprise Module for Server Applications 15
  • xen >= 4.10.1_04-1.4
  • xen-devel >= 4.10.1_04-1.4
  • xen-tools >= 4.10.1_04-1.4
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA xen
SUSE Linux Enterprise Server 12 SP1
  • xen >= 4.5.5_02-22.3.1
  • xen-doc-html >= 4.5.5_02-22.3.1
  • xen-kmp-default >= 4.5.5_02_k3.12.67_60.64.18-22.3.1
  • xen-libs >= 4.5.5_02-22.3.1
  • xen-libs-32bit >= 4.5.5_02-22.3.1
  • xen-tools >= 4.5.5_02-22.3.1
  • xen-tools-domU >= 4.5.5_02-22.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1795
SUSE Linux Enterprise Server 12 SP2
  • xen >= 4.7.1_02-25.1
  • xen-doc-html >= 4.7.1_02-25.1
  • xen-libs >= 4.7.1_02-25.1
  • xen-libs-32bit >= 4.7.1_02-25.1
  • xen-tools >= 4.7.1_02-25.1
  • xen-tools-domU >= 4.7.1_02-25.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1785
SUSE Linux Enterprise Server 12 SP3
  • xen >= 4.9.0_08-2.2
  • xen-doc-html >= 4.9.0_08-2.2
  • xen-libs >= 4.9.0_08-2.2
  • xen-libs-32bit >= 4.9.0_08-2.2
  • xen-tools >= 4.9.0_08-2.2
  • xen-tools-domU >= 4.9.0_08-2.2
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA xen
SUSE Linux Enterprise Server 12 SP4
  • xen >= 4.11.0_08-1.11
  • xen-doc-html >= 4.11.0_08-1.11
  • xen-libs >= 4.11.0_08-1.11
  • xen-libs-32bit >= 4.11.0_08-1.11
  • xen-tools >= 4.11.0_08-1.11
  • xen-tools-domU >= 4.11.0_08-1.11
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA xen
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • xen >= 4.5.5_02-22.3.1
  • xen-doc-html >= 4.5.5_02-22.3.1
  • xen-kmp-default >= 4.5.5_02_k3.12.67_60.64.18-22.3.1
  • xen-libs >= 4.5.5_02-22.3.1
  • xen-libs-32bit >= 4.5.5_02-22.3.1
  • xen-tools >= 4.5.5_02-22.3.1
  • xen-tools-domU >= 4.5.5_02-22.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1795
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • xen >= 4.7.1_02-25.1
  • xen-doc-html >= 4.7.1_02-25.1
  • xen-libs >= 4.7.1_02-25.1
  • xen-libs-32bit >= 4.7.1_02-25.1
  • xen-tools >= 4.7.1_02-25.1
  • xen-tools-domU >= 4.7.1_02-25.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1785
SUSE Linux Enterprise Software Development Kit 12 SP1
  • xen >= 4.5.5_02-22.3.1
  • xen-devel >= 4.5.5_02-22.3.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1795
SUSE Linux Enterprise Software Development Kit 12 SP2
  • xen >= 4.7.1_02-25.1
  • xen-devel >= 4.7.1_02-25.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2016-1785
SUSE Linux Enterprise Software Development Kit 12 SP3
  • xen-devel >= 4.9.0_08-2.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA xen-devel
SUSE Linux Enterprise Software Development Kit 12 SP4
  • xen-devel >= 4.11.0_08-1.11
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA xen-devel
openSUSE Leap 15.0
  • xen-libs >= 4.10.0_20-lp150.1.2
Patchnames:
openSUSE Leap 15.0 GA xen-libs
openSUSE Leap 42.1
  • xen >= 4.5.5_06-18.1
  • xen-debugsource >= 4.5.5_06-18.1
  • xen-devel >= 4.5.5_06-18.1
  • xen-doc-html >= 4.5.5_06-18.1
  • xen-kmp-default >= 4.5.5_06_k4.1.36_41-18.1
  • xen-kmp-default-debuginfo >= 4.5.5_06_k4.1.36_41-18.1
  • xen-libs >= 4.5.5_06-18.1
  • xen-libs-32bit >= 4.5.5_06-18.1
  • xen-libs-debuginfo >= 4.5.5_06-18.1
  • xen-libs-debuginfo-32bit >= 4.5.5_06-18.1
  • xen-tools >= 4.5.5_06-18.1
  • xen-tools-debuginfo >= 4.5.5_06-18.1
  • xen-tools-domU >= 4.5.5_06-18.1
  • xen-tools-domU-debuginfo >= 4.5.5_06-18.1
Patchnames:
openSUSE-2017-4
openSUSE Leap 42.2
  • xen >= 4.7.1_02-3.1
  • xen-debugsource >= 4.7.1_02-3.1
  • xen-devel >= 4.7.1_02-3.1
  • xen-doc-html >= 4.7.1_02-3.1
  • xen-libs >= 4.7.1_02-3.1
  • xen-libs-32bit >= 4.7.1_02-3.1
  • xen-libs-debuginfo >= 4.7.1_02-3.1
  • xen-libs-debuginfo-32bit >= 4.7.1_02-3.1
  • xen-tools >= 4.7.1_02-3.1
  • xen-tools-debuginfo >= 4.7.1_02-3.1
  • xen-tools-domU >= 4.7.1_02-3.1
  • xen-tools-domU-debuginfo >= 4.7.1_02-3.1
Patchnames:
openSUSE-2016-1477
openSUSE Leap 42.3
  • xen >= 4.9.0_08-2.1
  • xen-doc-html >= 4.9.0_08-2.1
  • xen-libs >= 4.9.0_08-2.1
  • xen-tools >= 4.9.0_08-2.1
  • xen-tools-domU >= 4.9.0_08-2.1
Patchnames:
openSUSE Leap 42.3 GA xen


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 xen Released
SUSE Linux Enterprise Desktop 12 SP2 xen Released
SUSE Linux Enterprise SDK 11 SP4 xen Not affected
SUSE Linux Enterprise SDK 12 SP1 xen Released
SUSE Linux Enterprise SDK 12 SP2 xen Released
SUSE Linux Enterprise Server 11 SP2 LTSS xen Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS xen Not affected
SUSE Linux Enterprise Server 11 SP4 xen Not affected
SUSE Linux Enterprise Server 12 GA LTSS xen Not affected
SUSE Linux Enterprise Server 12 SP1 xen Released
SUSE Linux Enterprise Server 12 SP2 xen Released