Upstream information

CVE-2016-8858 at MITRE

Description

** DISPUTED ** The kex_input_kexinit function in kex.c in OpenSSH 6.x and 7.x through 7.3 allows remote attackers to cause a denial of service (memory consumption) by sending many duplicate KEXINIT requests. NOTE: a third party reports that "OpenSSH upstream does not consider this as a security issue."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:N/AC:L/Au:N/C:N/I:N/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Changed
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3 3.1
SUSE Bugzilla entry: 1005480 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • openssh >= 6.6p1-54.7.1
  • openssh-askpass-gnome >= 6.6p1-54.7.1
  • openssh-helpers >= 6.6p1-54.7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-325
SUSE Linux Enterprise Desktop 12 SP2
  • openssh >= 7.2p2-66.1
  • openssh-askpass-gnome >= 7.2p2-66.3
  • openssh-helpers >= 7.2p2-66.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-138
SUSE Linux Enterprise Desktop 12 SP3
  • openssh >= 7.2p2-69.1
  • openssh-helpers >= 7.2p2-69.1
SUSE Linux Enterprise Desktop 12 SP4
  • openssh >= 7.2p2-74.25.1
  • openssh-helpers >= 7.2p2-74.25.1
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • openssh >= 7.2p2-74.45.1
  • openssh-fips >= 7.2p2-74.45.1
  • openssh-helpers >= 7.2p2-74.45.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • openssh >= 7.9p1-4.7
  • openssh-helpers >= 7.9p1-4.7
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • openssh >= 8.1p1-3.21
  • openssh-helpers >= 8.1p1-3.21
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • openssh >= 8.4p1-1.30
  • openssh-clients >= 8.4p1-1.30
  • openssh-common >= 8.4p1-1.30
  • openssh-helpers >= 8.4p1-1.30
  • openssh-server >= 8.4p1-1.30
SUSE Linux Enterprise Module for Basesystem 15
  • openssh >= 7.6p1-7.8
  • openssh-helpers >= 7.6p1-7.8
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • openssh-fips >= 7.9p1-4.7
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • openssh-fips >= 8.1p1-3.21
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • openssh-fips >= 8.4p1-1.30
SUSE Linux Enterprise Module for Server Applications 15
  • openssh-fips >= 7.6p1-7.8
SUSE Linux Enterprise Point of Sale 11 SP3
  • openssh >= 6.2p2-0.40.1
  • openssh-askpass >= 6.2p2-0.40.1
  • openssh-askpass-gnome >= 6.2p2-0.40.3
Patchnames:
sleposp3-openssh-13005
SUSE Linux Enterprise Server 11 SP3-LTSS
  • openssh >= 6.2p2-0.40.1
  • openssh-askpass >= 6.2p2-0.40.1
  • openssh-askpass-gnome >= 6.2p2-0.40.3
Patchnames:
slessp3-openssh-13005
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • openssh >= 6.6p1-35.1
  • openssh-askpass-gnome >= 6.6p1-35.4
  • openssh-fips >= 6.6p1-35.1
  • openssh-helpers >= 6.6p1-35.1
Patchnames:
slessp4-openssh-13002
SUSE Linux Enterprise Server 11-SECURITY
  • openssh-openssl1 >= 6.6p1-18.1
  • openssh-openssl1-helpers >= 6.6p1-18.1
Patchnames:
secsp3-openssh-openssl1-13169
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • openssh >= 6.6p1-54.7.1
  • openssh-askpass-gnome >= 6.6p1-54.7.1
  • openssh-fips >= 6.6p1-54.7.1
  • openssh-helpers >= 6.6p1-54.7.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-325
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • openssh >= 7.2p2-66.1
  • openssh-askpass-gnome >= 7.2p2-66.3
  • openssh-fips >= 7.2p2-66.1
  • openssh-helpers >= 7.2p2-66.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-138
SUSE Linux Enterprise Server 12 SP3
  • openssh >= 7.2p2-69.1
  • openssh-fips >= 7.2p2-69.1
  • openssh-helpers >= 7.2p2-69.1
SUSE Linux Enterprise Server 12 SP4
  • openssh >= 7.2p2-74.25.1
  • openssh-fips >= 7.2p2-74.25.1
  • openssh-helpers >= 7.2p2-74.25.1
SUSE Linux Enterprise Server 12-LTSS
  • openssh >= 6.6p1-54.7.1
  • openssh-askpass-gnome >= 6.6p1-54.7.1
  • openssh-fips >= 6.6p1-54.7.1
  • openssh-helpers >= 6.6p1-54.7.1
Patchnames:
SUSE-SLE-SERVER-12-2017-325
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • openssh >= 7.2p2-66.1
  • openssh-askpass-gnome >= 7.2p2-66.3
  • openssh-fips >= 7.2p2-66.1
  • openssh-helpers >= 7.2p2-66.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-138
SUSE Linux Enterprise Server for SAP Applications 12
  • openssh >= 6.6p1-54.7.1
  • openssh-askpass-gnome >= 6.6p1-54.7.1
  • openssh-fips >= 6.6p1-54.7.1
  • openssh-helpers >= 6.6p1-54.7.1
Patchnames:
SUSE-SLE-SAP-12-2017-325
SUSE Manager 2.1
  • openssh >= 6.2p2-0.40.1
  • openssh-askpass >= 6.2p2-0.40.1
  • openssh-askpass-gnome >= 6.2p2-0.40.3
Patchnames:
sleman21-openssh-13005
SUSE Manager Proxy 2.1
  • openssh >= 6.2p2-0.40.1
  • openssh-askpass >= 6.2p2-0.40.1
  • openssh-askpass-gnome >= 6.2p2-0.40.3
Patchnames:
slemap21-openssh-13005
SUSE OpenStack Cloud 5
  • openssh >= 6.2p2-0.40.1
  • openssh-askpass >= 6.2p2-0.40.1
  • openssh-askpass-gnome >= 6.2p2-0.40.3
Patchnames:
sleclo50sp3-openssh-13005
openSUSE Leap 15.0
  • openssh >= 7.6p1-lp150.7.4
  • openssh-helpers >= 7.6p1-lp150.7.4
Patchnames:
openSUSE Leap 15.0 GA openssh-7.6p1-lp150.7.4
openSUSE Tumbleweed
  • openssh >= 8.4p1-7.4
  • openssh-cavs >= 8.4p1-7.4
  • openssh-clients >= 8.4p1-7.4
  • openssh-common >= 8.4p1-7.4
  • openssh-fips >= 8.4p1-7.4
  • openssh-helpers >= 8.4p1-7.4
  • openssh-server >= 8.4p1-7.4
Patchnames:
openSUSE Tumbleweed GA openssh-8.4p1-7.4


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 openssh In progress
SLES-LTSS-SAP openssh In progress
SUSE Linux Enterprise Desktop 12 SP1 openssh Released
SUSE Linux Enterprise Desktop 12 SP2 openssh Released
SUSE Linux Enterprise Point of Service 11 SP3 openssh In progress
SUSE Linux Enterprise Server 11 SP3 LTSS openssh Released
SUSE Linux Enterprise Server 11 SP4 openssh Released
SUSE Linux Enterprise Server 11 SP4 LTSS openssh In progress
SUSE Linux Enterprise Server 12 LTSS openssh Released
SUSE Linux Enterprise Server 12 SP1 openssh Released
SUSE Linux Enterprise Server 12 SP2 openssh Released
SUSE Linux Enterprise Server 12 SP3 ESPOS openssh In progress
SUSE Linux Enterprise Server 12 SP3 LTSS openssh In progress
SUSE Linux Enterprise Server BCL 12 SP2 openssh In progress
SUSE Linux Enterprise Server BCL 12 SP3 openssh In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openssh Released
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 openssh Released
SUSE OpenStack Cloud 8 openssh In progress
SUSE OpenStack Cloud Crowbar 8 openssh In progress
Security Module for SUSE Linux Enterprise 11 openssh-openssl1 Released