Upstream information

CVE-2016-7954 at MITRE

Description

Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.6
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:H/Au:N/C:C/I:C/A:C
Access Vector Network Network
Access Complexity Low High
Authentication None None
Confidentiality Impact Partial Complete
Integrity Impact Partial Complete
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 4.9
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Access Vector Network Local
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3 3.1
SUSE Bugzilla entry: 1003063 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.5 rubygem-bundler Not affected
SUSE Cloud 5 rubygem-bundler Unsupported
SUSE Enterprise Storage 2.1 rubygem-bundler Affected
SUSE Enterprise Storage 3 rubygem-bundler Affected
SUSE Enterprise Storage 7 rubygem-bundler Not affected
SUSE Lifecycle Management Server 1.3 rubygem-bundler Affected
SUSE Linux Enterprise High Availability Extension 11 SP4 rubygem-bundler Affected
SUSE Linux Enterprise High Availability Extension 12 rubygem-bundler Affected
SUSE Linux Enterprise High Availability Extension 12 SP1 rubygem-bundler Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS rubygem-bundler Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS rubygem-bundler Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS rubygem-bundler Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 rubygem-bundler Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS rubygem-bundler Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 rubygem-bundler Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 rubygem-bundler Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 rubygem-bundler Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 rubygem-bundler Affected
SUSE Linux Enterprise Software Development Kit 12 rubygem-bundler Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 rubygem-bundler Affected
SUSE Manager Proxy 4.1 rubygem-bundler Not affected
SUSE Manager Retail Branch Server 4.1 rubygem-bundler Not affected
SUSE Manager Server 4.1 rubygem-bundler Not affected
SUSE OpenStack Cloud 6 rubygem-bundler Ignore
SUSE Studio Onsite 1.3 rubygem-bundler Affected