Upstream information

CVE-2016-5385 at MITRE

Description

PHP through 7.0.8 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, as demonstrated by (1) an application that makes a getenv('HTTP_PROXY') call or (2) a CGI configuration of PHP, aka an "httpoxy" issue.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5.1 5
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network Network
Access Complexity High Low
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial Partial
Availability Impact Partial None
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.1
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entries: 988484 [RESOLVED / FIXED], 988486 [RESOLVED / FIXED], 988487 [RESOLVED / FIXED], 988488 [RESOLVED / FIXED], 988489 [RESOLVED / FIXED], 988491 [RESOLVED / FIXED], 988492 [RESOLVED / DUPLICATE], 989125 [RESOLVED / WORKSFORME], 989174 [RESOLVED / WORKSFORME]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • php5-devel >= 5.5.14-68.1
  • php7-devel >= 7.0.7-25.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1082
SUSE-SLE-SDK-12-SP1-2016-1722
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP2
  • php5-devel >= 5.5.14-73.1
  • php7-devel >= 7.0.7-25.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA php5-devel-5.5.14-73.1
SUSE-SLE-SDK-12-SP2-2016-1722
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • php5-devel >= 5.5.14-108.1
  • php7-devel >= 7.0.7-49.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA php5-devel-5.5.14-108.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA php7-devel-7.0.7-49.1
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • php5-devel >= 5.5.14-109.41.1
  • php7-devel >= 7.0.7-50.52.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA php5-devel-5.5.14-109.41.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA php7-devel-7.0.7-50.52.1
SUSE Linux Enterprise High Performance Computing 12
SUSE Linux Enterprise Module for Web and Scripting 12
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • apache2-mod_php5 >= 5.5.14-68.1
  • apache2-mod_php7 >= 7.0.7-25.1
  • php5 >= 5.5.14-68.1
  • php5-bcmath >= 5.5.14-68.1
  • php5-bz2 >= 5.5.14-68.1
  • php5-calendar >= 5.5.14-68.1
  • php5-ctype >= 5.5.14-68.1
  • php5-curl >= 5.5.14-68.1
  • php5-dba >= 5.5.14-68.1
  • php5-dom >= 5.5.14-68.1
  • php5-enchant >= 5.5.14-68.1
  • php5-exif >= 5.5.14-68.1
  • php5-fastcgi >= 5.5.14-68.1
  • php5-fileinfo >= 5.5.14-68.1
  • php5-fpm >= 5.5.14-68.1
  • php5-ftp >= 5.5.14-68.1
  • php5-gd >= 5.5.14-68.1
  • php5-gettext >= 5.5.14-68.1
  • php5-gmp >= 5.5.14-68.1
  • php5-iconv >= 5.5.14-68.1
  • php5-imap >= 5.5.14-68.1
  • php5-intl >= 5.5.14-68.1
  • php5-json >= 5.5.14-68.1
  • php5-ldap >= 5.5.14-68.1
  • php5-mbstring >= 5.5.14-68.1
  • php5-mcrypt >= 5.5.14-68.1
  • php5-mysql >= 5.5.14-68.1
  • php5-odbc >= 5.5.14-68.1
  • php5-opcache >= 5.5.14-68.1
  • php5-openssl >= 5.5.14-68.1
  • php5-pcntl >= 5.5.14-68.1
  • php5-pdo >= 5.5.14-68.1
  • php5-pear >= 5.5.14-68.1
  • php5-pgsql >= 5.5.14-68.1
  • php5-phar >= 5.5.14-68.1
  • php5-posix >= 5.5.14-68.1
  • php5-pspell >= 5.5.14-68.1
  • php5-shmop >= 5.5.14-68.1
  • php5-snmp >= 5.5.14-68.1
  • php5-soap >= 5.5.14-68.1
  • php5-sockets >= 5.5.14-68.1
  • php5-sqlite >= 5.5.14-68.1
  • php5-suhosin >= 5.5.14-68.1
  • php5-sysvmsg >= 5.5.14-68.1
  • php5-sysvsem >= 5.5.14-68.1
  • php5-sysvshm >= 5.5.14-68.1
  • php5-tokenizer >= 5.5.14-68.1
  • php5-wddx >= 5.5.14-68.1
  • php5-xmlreader >= 5.5.14-68.1
  • php5-xmlrpc >= 5.5.14-68.1
  • php5-xmlwriter >= 5.5.14-68.1
  • php5-xsl >= 5.5.14-68.1
  • php5-zip >= 5.5.14-68.1
  • php5-zlib >= 5.5.14-68.1
  • php7 >= 7.0.7-25.1
  • php7-bcmath >= 7.0.7-25.1
  • php7-bz2 >= 7.0.7-25.1
  • php7-calendar >= 7.0.7-25.1
  • php7-ctype >= 7.0.7-25.1
  • php7-curl >= 7.0.7-25.1
  • php7-dba >= 7.0.7-25.1
  • php7-dom >= 7.0.7-25.1
  • php7-enchant >= 7.0.7-25.1
  • php7-exif >= 7.0.7-25.1
  • php7-fastcgi >= 7.0.7-25.1
  • php7-fileinfo >= 7.0.7-25.1
  • php7-fpm >= 7.0.7-25.1
  • php7-ftp >= 7.0.7-25.1
  • php7-gd >= 7.0.7-25.1
  • php7-gettext >= 7.0.7-25.1
  • php7-gmp >= 7.0.7-25.1
  • php7-iconv >= 7.0.7-25.1
  • php7-imap >= 7.0.7-25.1
  • php7-intl >= 7.0.7-25.1
  • php7-json >= 7.0.7-25.1
  • php7-ldap >= 7.0.7-25.1
  • php7-mbstring >= 7.0.7-25.1
  • php7-mcrypt >= 7.0.7-25.1
  • php7-mysql >= 7.0.7-25.1
  • php7-odbc >= 7.0.7-25.1
  • php7-opcache >= 7.0.7-25.1
  • php7-openssl >= 7.0.7-25.1
  • php7-pcntl >= 7.0.7-25.1
  • php7-pdo >= 7.0.7-25.1
  • php7-pear >= 7.0.7-25.1
  • php7-pear-Archive_Tar >= 7.0.7-25.1
  • php7-pgsql >= 7.0.7-25.1
  • php7-phar >= 7.0.7-25.1
  • php7-posix >= 7.0.7-25.1
  • php7-pspell >= 7.0.7-25.1
  • php7-shmop >= 7.0.7-25.1
  • php7-snmp >= 7.0.7-25.1
  • php7-soap >= 7.0.7-25.1
  • php7-sockets >= 7.0.7-25.1
  • php7-sqlite >= 7.0.7-25.1
  • php7-sysvmsg >= 7.0.7-25.1
  • php7-sysvsem >= 7.0.7-25.1
  • php7-sysvshm >= 7.0.7-25.1
  • php7-tokenizer >= 7.0.7-25.1
  • php7-wddx >= 7.0.7-25.1
  • php7-xmlreader >= 7.0.7-25.1
  • php7-xmlrpc >= 7.0.7-25.1
  • php7-xmlwriter >= 7.0.7-25.1
  • php7-xsl >= 7.0.7-25.1
  • php7-zip >= 7.0.7-25.1
  • php7-zlib >= 7.0.7-25.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2016-1082
SUSE-SLE-Module-Web-Scripting-12-2016-1722
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • apache2-mod_php5 >= 5.5.14-68.1
  • apache2-mod_php7 >= 7.0.7-25.1
  • php5 >= 5.5.14-68.1
  • php5-bcmath >= 5.5.14-68.1
  • php5-bz2 >= 5.5.14-68.1
  • php5-calendar >= 5.5.14-68.1
  • php5-ctype >= 5.5.14-68.1
  • php5-curl >= 5.5.14-68.1
  • php5-dba >= 5.5.14-68.1
  • php5-devel >= 5.5.14-108.1
  • php5-dom >= 5.5.14-68.1
  • php5-enchant >= 5.5.14-68.1
  • php5-exif >= 5.5.14-68.1
  • php5-fastcgi >= 5.5.14-68.1
  • php5-fileinfo >= 5.5.14-68.1
  • php5-fpm >= 5.5.14-68.1
  • php5-ftp >= 5.5.14-68.1
  • php5-gd >= 5.5.14-68.1
  • php5-gettext >= 5.5.14-68.1
  • php5-gmp >= 5.5.14-68.1
  • php5-iconv >= 5.5.14-68.1
  • php5-imap >= 5.5.14-68.1
  • php5-intl >= 5.5.14-68.1
  • php5-json >= 5.5.14-68.1
  • php5-ldap >= 5.5.14-68.1
  • php5-mbstring >= 5.5.14-68.1
  • php5-mcrypt >= 5.5.14-68.1
  • php5-mysql >= 5.5.14-68.1
  • php5-odbc >= 5.5.14-68.1
  • php5-opcache >= 5.5.14-68.1
  • php5-openssl >= 5.5.14-68.1
  • php5-pcntl >= 5.5.14-68.1
  • php5-pdo >= 5.5.14-68.1
  • php5-pear >= 5.5.14-68.1
  • php5-pgsql >= 5.5.14-68.1
  • php5-phar >= 5.5.14-68.1
  • php5-posix >= 5.5.14-68.1
  • php5-pspell >= 5.5.14-68.1
  • php5-shmop >= 5.5.14-68.1
  • php5-snmp >= 5.5.14-68.1
  • php5-soap >= 5.5.14-68.1
  • php5-sockets >= 5.5.14-68.1
  • php5-sqlite >= 5.5.14-68.1
  • php5-suhosin >= 5.5.14-68.1
  • php5-sysvmsg >= 5.5.14-68.1
  • php5-sysvsem >= 5.5.14-68.1
  • php5-sysvshm >= 5.5.14-68.1
  • php5-tokenizer >= 5.5.14-68.1
  • php5-wddx >= 5.5.14-68.1
  • php5-xmlreader >= 5.5.14-68.1
  • php5-xmlrpc >= 5.5.14-68.1
  • php5-xmlwriter >= 5.5.14-68.1
  • php5-xsl >= 5.5.14-68.1
  • php5-zip >= 5.5.14-68.1
  • php5-zlib >= 5.5.14-68.1
  • php7 >= 7.0.7-25.1
  • php7-bcmath >= 7.0.7-25.1
  • php7-bz2 >= 7.0.7-25.1
  • php7-calendar >= 7.0.7-25.1
  • php7-ctype >= 7.0.7-25.1
  • php7-curl >= 7.0.7-25.1
  • php7-dba >= 7.0.7-25.1
  • php7-devel >= 7.0.7-49.1
  • php7-dom >= 7.0.7-25.1
  • php7-enchant >= 7.0.7-25.1
  • php7-exif >= 7.0.7-25.1
  • php7-fastcgi >= 7.0.7-25.1
  • php7-fileinfo >= 7.0.7-25.1
  • php7-fpm >= 7.0.7-25.1
  • php7-ftp >= 7.0.7-25.1
  • php7-gd >= 7.0.7-25.1
  • php7-gettext >= 7.0.7-25.1
  • php7-gmp >= 7.0.7-25.1
  • php7-iconv >= 7.0.7-25.1
  • php7-imap >= 7.0.7-25.1
  • php7-intl >= 7.0.7-25.1
  • php7-json >= 7.0.7-25.1
  • php7-ldap >= 7.0.7-25.1
  • php7-mbstring >= 7.0.7-25.1
  • php7-mcrypt >= 7.0.7-25.1
  • php7-mysql >= 7.0.7-25.1
  • php7-odbc >= 7.0.7-25.1
  • php7-opcache >= 7.0.7-25.1
  • php7-openssl >= 7.0.7-25.1
  • php7-pcntl >= 7.0.7-25.1
  • php7-pdo >= 7.0.7-25.1
  • php7-pear >= 7.0.7-25.1
  • php7-pear-Archive_Tar >= 7.0.7-25.1
  • php7-pgsql >= 7.0.7-25.1
  • php7-phar >= 7.0.7-25.1
  • php7-posix >= 7.0.7-25.1
  • php7-pspell >= 7.0.7-25.1
  • php7-shmop >= 7.0.7-25.1
  • php7-snmp >= 7.0.7-25.1
  • php7-soap >= 7.0.7-25.1
  • php7-sockets >= 7.0.7-25.1
  • php7-sqlite >= 7.0.7-25.1
  • php7-sysvmsg >= 7.0.7-25.1
  • php7-sysvsem >= 7.0.7-25.1
  • php7-sysvshm >= 7.0.7-25.1
  • php7-tokenizer >= 7.0.7-25.1
  • php7-wddx >= 7.0.7-25.1
  • php7-xmlreader >= 7.0.7-25.1
  • php7-xmlrpc >= 7.0.7-25.1
  • php7-xmlwriter >= 7.0.7-25.1
  • php7-xsl >= 7.0.7-25.1
  • php7-zip >= 7.0.7-25.1
  • php7-zlib >= 7.0.7-25.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA php5-devel-5.5.14-108.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA php7-devel-7.0.7-49.1
SUSE-SLE-Module-Web-Scripting-12-2016-1082
SUSE-SLE-Module-Web-Scripting-12-2016-1722
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • apache2-mod_php5 >= 5.5.14-68.1
  • apache2-mod_php7 >= 7.0.7-25.1
  • php5 >= 5.5.14-68.1
  • php5-bcmath >= 5.5.14-68.1
  • php5-bz2 >= 5.5.14-68.1
  • php5-calendar >= 5.5.14-68.1
  • php5-ctype >= 5.5.14-68.1
  • php5-curl >= 5.5.14-68.1
  • php5-dba >= 5.5.14-68.1
  • php5-devel >= 5.5.14-109.41.1
  • php5-dom >= 5.5.14-68.1
  • php5-enchant >= 5.5.14-68.1
  • php5-exif >= 5.5.14-68.1
  • php5-fastcgi >= 5.5.14-68.1
  • php5-fileinfo >= 5.5.14-68.1
  • php5-fpm >= 5.5.14-68.1
  • php5-ftp >= 5.5.14-68.1
  • php5-gd >= 5.5.14-68.1
  • php5-gettext >= 5.5.14-68.1
  • php5-gmp >= 5.5.14-68.1
  • php5-iconv >= 5.5.14-68.1
  • php5-imap >= 5.5.14-68.1
  • php5-intl >= 5.5.14-68.1
  • php5-json >= 5.5.14-68.1
  • php5-ldap >= 5.5.14-68.1
  • php5-mbstring >= 5.5.14-68.1
  • php5-mcrypt >= 5.5.14-68.1
  • php5-mysql >= 5.5.14-68.1
  • php5-odbc >= 5.5.14-68.1
  • php5-opcache >= 5.5.14-68.1
  • php5-openssl >= 5.5.14-68.1
  • php5-pcntl >= 5.5.14-68.1
  • php5-pdo >= 5.5.14-68.1
  • php5-pear >= 5.5.14-68.1
  • php5-pgsql >= 5.5.14-68.1
  • php5-phar >= 5.5.14-68.1
  • php5-posix >= 5.5.14-68.1
  • php5-pspell >= 5.5.14-68.1
  • php5-shmop >= 5.5.14-68.1
  • php5-snmp >= 5.5.14-68.1
  • php5-soap >= 5.5.14-68.1
  • php5-sockets >= 5.5.14-68.1
  • php5-sqlite >= 5.5.14-68.1
  • php5-suhosin >= 5.5.14-68.1
  • php5-sysvmsg >= 5.5.14-68.1
  • php5-sysvsem >= 5.5.14-68.1
  • php5-sysvshm >= 5.5.14-68.1
  • php5-tokenizer >= 5.5.14-68.1
  • php5-wddx >= 5.5.14-68.1
  • php5-xmlreader >= 5.5.14-68.1
  • php5-xmlrpc >= 5.5.14-68.1
  • php5-xmlwriter >= 5.5.14-68.1
  • php5-xsl >= 5.5.14-68.1
  • php5-zip >= 5.5.14-68.1
  • php5-zlib >= 5.5.14-68.1
  • php7 >= 7.0.7-25.1
  • php7-bcmath >= 7.0.7-25.1
  • php7-bz2 >= 7.0.7-25.1
  • php7-calendar >= 7.0.7-25.1
  • php7-ctype >= 7.0.7-25.1
  • php7-curl >= 7.0.7-25.1
  • php7-dba >= 7.0.7-25.1
  • php7-devel >= 7.0.7-50.52.1
  • php7-dom >= 7.0.7-25.1
  • php7-enchant >= 7.0.7-25.1
  • php7-exif >= 7.0.7-25.1
  • php7-fastcgi >= 7.0.7-25.1
  • php7-fileinfo >= 7.0.7-25.1
  • php7-fpm >= 7.0.7-25.1
  • php7-ftp >= 7.0.7-25.1
  • php7-gd >= 7.0.7-25.1
  • php7-gettext >= 7.0.7-25.1
  • php7-gmp >= 7.0.7-25.1
  • php7-iconv >= 7.0.7-25.1
  • php7-imap >= 7.0.7-25.1
  • php7-intl >= 7.0.7-25.1
  • php7-json >= 7.0.7-25.1
  • php7-ldap >= 7.0.7-25.1
  • php7-mbstring >= 7.0.7-25.1
  • php7-mcrypt >= 7.0.7-25.1
  • php7-mysql >= 7.0.7-25.1
  • php7-odbc >= 7.0.7-25.1
  • php7-opcache >= 7.0.7-25.1
  • php7-openssl >= 7.0.7-25.1
  • php7-pcntl >= 7.0.7-25.1
  • php7-pdo >= 7.0.7-25.1
  • php7-pear >= 7.0.7-25.1
  • php7-pear-Archive_Tar >= 7.0.7-25.1
  • php7-pgsql >= 7.0.7-25.1
  • php7-phar >= 7.0.7-25.1
  • php7-posix >= 7.0.7-25.1
  • php7-pspell >= 7.0.7-25.1
  • php7-shmop >= 7.0.7-25.1
  • php7-snmp >= 7.0.7-25.1
  • php7-soap >= 7.0.7-25.1
  • php7-sockets >= 7.0.7-25.1
  • php7-sqlite >= 7.0.7-25.1
  • php7-sysvmsg >= 7.0.7-25.1
  • php7-sysvsem >= 7.0.7-25.1
  • php7-sysvshm >= 7.0.7-25.1
  • php7-tokenizer >= 7.0.7-25.1
  • php7-wddx >= 7.0.7-25.1
  • php7-xmlreader >= 7.0.7-25.1
  • php7-xmlrpc >= 7.0.7-25.1
  • php7-xmlwriter >= 7.0.7-25.1
  • php7-xsl >= 7.0.7-25.1
  • php7-zip >= 7.0.7-25.1
  • php7-zlib >= 7.0.7-25.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA php5-devel-5.5.14-109.41.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA php7-devel-7.0.7-50.52.1
SUSE-SLE-Module-Web-Scripting-12-2016-1082
SUSE-SLE-Module-Web-Scripting-12-2016-1722
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • apache2-mod_php5 >= 5.5.14-68.1
  • apache2-mod_php7 >= 7.0.7-25.1
  • php5 >= 5.5.14-68.1
  • php5-bcmath >= 5.5.14-68.1
  • php5-bz2 >= 5.5.14-68.1
  • php5-calendar >= 5.5.14-68.1
  • php5-ctype >= 5.5.14-68.1
  • php5-curl >= 5.5.14-68.1
  • php5-dba >= 5.5.14-68.1
  • php5-dom >= 5.5.14-68.1
  • php5-enchant >= 5.5.14-68.1
  • php5-exif >= 5.5.14-68.1
  • php5-fastcgi >= 5.5.14-68.1
  • php5-fileinfo >= 5.5.14-68.1
  • php5-fpm >= 5.5.14-68.1
  • php5-ftp >= 5.5.14-68.1
  • php5-gd >= 5.5.14-68.1
  • php5-gettext >= 5.5.14-68.1
  • php5-gmp >= 5.5.14-68.1
  • php5-iconv >= 5.5.14-68.1
  • php5-imap >= 5.5.14-68.1
  • php5-intl >= 5.5.14-68.1
  • php5-json >= 5.5.14-68.1
  • php5-ldap >= 5.5.14-68.1
  • php5-mbstring >= 5.5.14-68.1
  • php5-mcrypt >= 5.5.14-68.1
  • php5-mysql >= 5.5.14-68.1
  • php5-odbc >= 5.5.14-68.1
  • php5-opcache >= 5.5.14-68.1
  • php5-openssl >= 5.5.14-68.1
  • php5-pcntl >= 5.5.14-68.1
  • php5-pdo >= 5.5.14-68.1
  • php5-pear >= 5.5.14-68.1
  • php5-pgsql >= 5.5.14-68.1
  • php5-phar >= 5.5.14-68.1
  • php5-posix >= 5.5.14-68.1
  • php5-pspell >= 5.5.14-68.1
  • php5-shmop >= 5.5.14-68.1
  • php5-snmp >= 5.5.14-68.1
  • php5-soap >= 5.5.14-68.1
  • php5-sockets >= 5.5.14-68.1
  • php5-sqlite >= 5.5.14-68.1
  • php5-suhosin >= 5.5.14-68.1
  • php5-sysvmsg >= 5.5.14-68.1
  • php5-sysvsem >= 5.5.14-68.1
  • php5-sysvshm >= 5.5.14-68.1
  • php5-tokenizer >= 5.5.14-68.1
  • php5-wddx >= 5.5.14-68.1
  • php5-xmlreader >= 5.5.14-68.1
  • php5-xmlrpc >= 5.5.14-68.1
  • php5-xmlwriter >= 5.5.14-68.1
  • php5-xsl >= 5.5.14-68.1
  • php5-zip >= 5.5.14-68.1
  • php5-zlib >= 5.5.14-68.1
  • php7 >= 7.0.7-25.1
  • php7-bcmath >= 7.0.7-25.1
  • php7-bz2 >= 7.0.7-25.1
  • php7-calendar >= 7.0.7-25.1
  • php7-ctype >= 7.0.7-25.1
  • php7-curl >= 7.0.7-25.1
  • php7-dba >= 7.0.7-25.1
  • php7-devel >= 7.0.7-50.85.1
  • php7-dom >= 7.0.7-25.1
  • php7-enchant >= 7.0.7-25.1
  • php7-exif >= 7.0.7-25.1
  • php7-fastcgi >= 7.0.7-25.1
  • php7-fileinfo >= 7.0.7-25.1
  • php7-fpm >= 7.0.7-25.1
  • php7-ftp >= 7.0.7-25.1
  • php7-gd >= 7.0.7-25.1
  • php7-gettext >= 7.0.7-25.1
  • php7-gmp >= 7.0.7-25.1
  • php7-iconv >= 7.0.7-25.1
  • php7-imap >= 7.0.7-25.1
  • php7-intl >= 7.0.7-25.1
  • php7-json >= 7.0.7-25.1
  • php7-ldap >= 7.0.7-25.1
  • php7-mbstring >= 7.0.7-25.1
  • php7-mcrypt >= 7.0.7-25.1
  • php7-mysql >= 7.0.7-25.1
  • php7-odbc >= 7.0.7-25.1
  • php7-opcache >= 7.0.7-25.1
  • php7-openssl >= 7.0.7-25.1
  • php7-pcntl >= 7.0.7-25.1
  • php7-pdo >= 7.0.7-25.1
  • php7-pear >= 7.0.7-25.1
  • php7-pear-Archive_Tar >= 7.0.7-25.1
  • php7-pgsql >= 7.0.7-25.1
  • php7-phar >= 7.0.7-25.1
  • php7-posix >= 7.0.7-25.1
  • php7-pspell >= 7.0.7-25.1
  • php7-shmop >= 7.0.7-25.1
  • php7-snmp >= 7.0.7-25.1
  • php7-soap >= 7.0.7-25.1
  • php7-sockets >= 7.0.7-25.1
  • php7-sqlite >= 7.0.7-25.1
  • php7-sysvmsg >= 7.0.7-25.1
  • php7-sysvsem >= 7.0.7-25.1
  • php7-sysvshm >= 7.0.7-25.1
  • php7-tokenizer >= 7.0.7-25.1
  • php7-wddx >= 7.0.7-25.1
  • php7-xmlreader >= 7.0.7-25.1
  • php7-xmlrpc >= 7.0.7-25.1
  • php7-xmlwriter >= 7.0.7-25.1
  • php7-xsl >= 7.0.7-25.1
  • php7-zip >= 7.0.7-25.1
  • php7-zlib >= 7.0.7-25.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA php7-devel-7.0.7-50.85.1
SUSE-SLE-Module-Web-Scripting-12-2016-1082
SUSE-SLE-Module-Web-Scripting-12-2016-1722
SUSE Linux Enterprise Software Development Kit 12 SP5
  • php7-devel >= 7.0.7-50.85.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA php7-devel-7.0.7-50.85.1
openSUSE Tumbleweed
  • platformsh-cli >= 3.67.2-1.2
Patchnames:
openSUSE Tumbleweed GA platformsh-cli-3.67.2-1.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 php7 Not affected
SUSE Enterprise Storage 7.1 php7 Not affected
SUSE Linux Enterprise High Performance Computing 12 php5 Released
SUSE Linux Enterprise High Performance Computing 12 php7 Released
SUSE Linux Enterprise High Performance Computing 12 php72 Not affected
SUSE Linux Enterprise High Performance Computing 12 php74 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 php5 Released
SUSE Linux Enterprise Module for Web and Scripting 12 php7 Released
SUSE Linux Enterprise Module for Web and Scripting 12 php72 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 php74 Not affected
SUSE Linux Enterprise Server 12 SP5 php5 Released
SUSE Linux Enterprise Server 12 SP5 php7 Released
SUSE Linux Enterprise Server 12 SP5 php72 Not affected
SUSE Linux Enterprise Server 12 SP5 php74 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php5 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php72 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php74 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 php7 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 php72 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 php74 Not affected
SUSE Manager Proxy 4.2 php7 Not affected
SUSE Manager Retail Branch Server 4.2 php7 Not affected
SUSE Manager Server 4.2 php7 Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS php7 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 php7 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP3 php7 Not affected
SUSE Linux Enterprise Server 12 SP4 php5 Released
SUSE Linux Enterprise Server 12 SP4 php7 Released
SUSE Linux Enterprise Server 12 SP4 php72 Not affected
SUSE Linux Enterprise Server 12 SP4 php74 Not affected
SUSE Linux Enterprise Server 15 SP2 php7 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS php7 Not affected
SUSE Linux Enterprise Server 15 SP3 php7 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS php7 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php5 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php72 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php74 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 php7 Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 SP4 php53 Not affected
SUSE Linux Enterprise Desktop 12 php5 Released
SUSE Linux Enterprise Desktop 12 php7 Affected
SUSE Linux Enterprise Desktop 12 SP1 php5 Released
SUSE Linux Enterprise Desktop 12 SP1 php7 Released
SUSE Linux Enterprise Desktop 12 SP2 php5 Released
SUSE Linux Enterprise Desktop 12 SP2 php7 Released
SUSE Linux Enterprise Desktop 12 SP3 php5 Affected
SUSE Linux Enterprise Desktop 12 SP3 php7 Affected
SUSE Linux Enterprise Desktop 12 SP3 php72 Not affected
SUSE Linux Enterprise Desktop 12 SP4 php5 Affected
SUSE Linux Enterprise Desktop 12 SP4 php7 Affected
SUSE Linux Enterprise Desktop 12 SP4 php72 Not affected
SUSE Linux Enterprise Desktop 12 SP4 php74 Not affected
SUSE Linux Enterprise Desktop 15 SP2 php7 Not affected
SUSE Linux Enterprise Desktop 15 SP3 php7 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP2 php7 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 php7 Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS php5 Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS php53 Not affected
SUSE Linux Enterprise Server 11 SP3 php53 Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS php53 Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS php53 Not affected
SUSE Linux Enterprise Server 11 SP4 php53 Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS php53 Not affected
SUSE Linux Enterprise Server 12 php5 Released
SUSE Linux Enterprise Server 12 php7 Released
SUSE Linux Enterprise Server 12 php72 Not affected
SUSE Linux Enterprise Server 12 php74 Not affected
SUSE Linux Enterprise Server 12 SP1 php5 Released
SUSE Linux Enterprise Server 12 SP1 php7 Released
SUSE Linux Enterprise Server 12 SP2 php5 Released
SUSE Linux Enterprise Server 12 SP2 php7 Released
SUSE Linux Enterprise Server 12 SP3 php5 Released
SUSE Linux Enterprise Server 12 SP3 php7 Released
SUSE Linux Enterprise Server 12 SP3 php72 Not affected
SUSE Linux Enterprise Server 12 SP3 php74 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL php7 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 php53 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 php5 Released
SUSE Linux Enterprise Server for SAP Applications 12 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 php72 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 php74 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 php5 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 php5 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php5 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php72 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php74 Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 php53 Not affected
SUSE Linux Enterprise Software Development Kit 12 php5 Released
SUSE Linux Enterprise Software Development Kit 12 php7 Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 php5 Released
SUSE Linux Enterprise Software Development Kit 12 SP1 php7 Released
SUSE Linux Enterprise Software Development Kit 12 SP2 php5 Released
SUSE Linux Enterprise Software Development Kit 12 SP2 php7 Released
SUSE Linux Enterprise Software Development Kit 12 SP3 php5 Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 php7 Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 php72 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 php5 Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 php7 Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 php72 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 php74 Not affected
SUSE Manager Proxy 4.1 php7 Not affected
SUSE Manager Retail Branch Server 4.1 php7 Not affected
SUSE Manager Server 4.1 php7 Not affected


SUSE Timeline for this CVE

CVE page created: Tue Jul 12 09:45:42 2016
CVE page last modified: Tue Mar 7 12:21:11 2023