Upstream information

CVE-2016-5253 at MITRE

Description

The Updater in Mozilla Firefox before 48.0 on Windows allows local users to write to arbitrary files via vectors involving the callback application-path parameter and a hard link.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.7
Vector AV:L/AC:M/Au:N/C:N/I:C/A:N
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Complete
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 4.7
Vector CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
Attack Vector Local
Attack Complexity High
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact High
Availability Impact None
CVSSv3 Version 3
SUSE Bugzilla entry: 991809 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • MozillaFirefox >= 60.6.2-3.32.1
  • MozillaFirefox-devel >= 60.6.2-3.32.1
  • MozillaFirefox-translations-common >= 60.6.2-3.32.1
  • MozillaFirefox-translations-other >= 60.6.2-3.32.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA MozillaFirefox-60.6.2-3.32.1
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • MozillaFirefox >= 78.10.0-8.38.1
  • MozillaFirefox-devel >= 78.10.0-8.38.1
  • MozillaFirefox-translations-common >= 78.10.0-8.38.1
  • MozillaFirefox-translations-other >= 78.10.0-8.38.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA MozillaFirefox-78.10.0-8.38.1
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • MozillaFirefox >= 68.8.0-3.87.1
  • MozillaFirefox-devel >= 68.8.0-3.87.1
  • MozillaFirefox-translations-common >= 68.8.0-3.87.1
  • MozillaFirefox-translations-other >= 68.8.0-3.87.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA MozillaFirefox-68.8.0-3.87.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • MozillaFirefox >= 91.8.0-150200.152.26.1
  • MozillaFirefox-devel >= 91.8.0-150200.152.26.1
  • MozillaFirefox-translations-common >= 91.8.0-150200.152.26.1
  • MozillaFirefox-translations-other >= 91.8.0-150200.152.26.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA MozillaFirefox-91.8.0-150200.152.26.1
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Desktop Applications 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • MozillaFirefox >= 52.7.3-1.35
  • MozillaFirefox-devel >= 52.7.3-1.35
  • MozillaFirefox-translations-common >= 52.7.3-1.35
  • MozillaFirefox-translations-other >= 52.7.3-1.35
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA MozillaFirefox-52.7.3-1.35
openSUSE Leap 15.0
  • MozillaFirefox >= 60.0-lp150.2.2
  • MozillaFirefox-translations-common >= 60.0-lp150.2.2
  • MozillaFirefox-translations-other >= 60.0-lp150.2.2
Patchnames:
openSUSE Leap 15.0 GA MozillaFirefox-60.0-lp150.2.2
openSUSE Leap 15.2
  • MozillaFirefox >= 68.9.0-lp152.1.3
  • MozillaFirefox-translations-common >= 68.9.0-lp152.1.3
  • MozillaFirefox-translations-other >= 68.9.0-lp152.1.3
Patchnames:
openSUSE Leap 15.2 GA MozillaFirefox-68.9.0-lp152.1.1
openSUSE Leap 15.3
  • MozillaFirefox >= 78.10.0-8.38.1
  • MozillaFirefox-translations-common >= 78.10.0-8.38.1
  • MozillaFirefox-translations-other >= 78.10.0-8.38.1
Patchnames:
openSUSE Leap 15.3 GA MozillaFirefox-78.10.0-8.38.1
openSUSE Leap 15.4
  • MozillaFirefox >= 91.8.0-150200.152.26.1
  • MozillaFirefox-translations-common >= 91.8.0-150200.152.26.1
  • MozillaFirefox-translations-other >= 91.8.0-150200.152.26.1
Patchnames:
openSUSE Leap 15.4 GA MozillaFirefox-91.8.0-150200.152.26.1
openSUSE Tumbleweed
  • MozillaFirefox >= 50.1.0-1.1
  • MozillaFirefox-branding-upstream >= 50.1.0-1.1
  • MozillaFirefox-buildsymbols >= 50.1.0-1.1
  • MozillaFirefox-devel >= 50.1.0-1.1
  • MozillaFirefox-translations-common >= 50.1.0-1.1
  • MozillaFirefox-translations-other >= 50.1.0-1.1
Patchnames:
openSUSE Tumbleweed GA MozillaFirefox-50.1.0-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 MozillaFirefox Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 MozillaFirefox Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS MozillaFirefox Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS MozillaFirefox Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS MozillaFirefox Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS MozillaFirefox Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 MozillaFirefox Affected
SUSE Linux Enterprise Server 15 SP1 MozillaFirefox Affected
SUSE Linux Enterprise Server 15 SP1-LTSS MozillaFirefox Affected
SUSE Linux Enterprise Server 15-ESPOS MozillaFirefox Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 MozillaFirefox Affected
SUSE Linux Enterprise Server for SAP Applications 15 MozillaFirefox Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 MozillaFirefox Affected
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 MozillaFirefox Affected
SUSE Enterprise Storage 6 MozillaFirefox Affected
SUSE Linux Enterprise Desktop 15 MozillaFirefox Affected
SUSE Linux Enterprise Desktop 15 SP1 MozillaFirefox Affected
SUSE Linux Enterprise Module for Desktop Applications 15 MozillaFirefox Affected
SUSE Linux Enterprise Server 15 MozillaFirefox Affected
SUSE Linux Enterprise Server 15 SP1-BCL MozillaFirefox Affected
SUSE Linux Enterprise Server 15-LTSS MozillaFirefox Affected
SUSE Manager Proxy 4.0 MozillaFirefox Affected
SUSE Manager Retail Branch Server 4.0 MozillaFirefox Affected
SUSE Manager Server 4.0 MozillaFirefox Affected


SUSE Timeline for this CVE

CVE page created: Wed Aug 3 20:43:36 2016
CVE page last modified: Mon Jan 16 17:25:58 2023