Upstream information

CVE-2016-4738 at MITRE

Description

libxslt in Apple iOS before 10, OS X before 10.12, tvOS before 10, and watchOS before 3 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 9.33 4.30
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Complete Partial
Integrity Impact Complete None
Availability Impact Complete None
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1005591 [RESOLVED / ]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libxslt >= 1.1.28-16.1
  • libxslt-tools >= 1.1.28-16.1
  • libxslt1 >= 1.1.28-16.1
  • libxslt1-32bit >= 1.1.28-16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-793
SUSE Linux Enterprise Desktop 12 SP2
  • libxslt >= 1.1.28-16.1
  • libxslt-tools >= 1.1.28-16.1
  • libxslt1 >= 1.1.28-16.1
  • libxslt1-32bit >= 1.1.28-16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-793
SUSE Linux Enterprise Server 11 SP4
  • libxslt >= 1.1.24-19.33.1
  • libxslt-32bit >= 1.1.24-19.33.1
  • libxslt-x86 >= 1.1.24-19.33.1
Patchnames:
slessp4-libxslt-13104
SUSE Linux Enterprise Server 12 SP1
  • libxslt >= 1.1.28-16.1
  • libxslt-tools >= 1.1.28-16.1
  • libxslt1 >= 1.1.28-16.1
  • libxslt1-32bit >= 1.1.28-16.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-793
SUSE Linux Enterprise Server 12 SP2
  • libxslt >= 1.1.28-16.1
  • libxslt-tools >= 1.1.28-16.1
  • libxslt1 >= 1.1.28-16.1
  • libxslt1-32bit >= 1.1.28-16.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-793
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libxslt >= 1.1.28-16.1
  • libxslt-tools >= 1.1.28-16.1
  • libxslt1 >= 1.1.28-16.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-793
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libxslt >= 1.1.24-19.33.1
  • libxslt-devel >= 1.1.24-19.33.1
  • libxslt-devel-32bit >= 1.1.24-19.33.1
  • libxslt-python >= 1.1.24-19.33.3
Patchnames:
sdksp4-libxslt-13104
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libxslt >= 1.1.28-16.1
  • libxslt-devel >= 1.1.28-16.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-793
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libxslt >= 1.1.28-16.1
  • libxslt-devel >= 1.1.28-16.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-793
openSUSE Leap 42.2
  • libxslt >= 1.1.28-10.3.1
  • libxslt-debugsource >= 1.1.28-10.3.1
  • libxslt-devel >= 1.1.28-10.3.1
  • libxslt-devel-32bit >= 1.1.28-10.3.1
  • libxslt-python >= 1.1.28-10.3.1
  • libxslt-python-debuginfo >= 1.1.28-10.3.1
  • libxslt-python-debugsource >= 1.1.28-10.3.1
  • libxslt-tools >= 1.1.28-10.3.1
  • libxslt-tools-debuginfo >= 1.1.28-10.3.1
  • libxslt1 >= 1.1.28-10.3.1
  • libxslt1-32bit >= 1.1.28-10.3.1
  • libxslt1-debuginfo >= 1.1.28-10.3.1
  • libxslt1-debuginfo-32bit >= 1.1.28-10.3.1
Patchnames:
openSUSE-2017-609


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise SDK 12 GA
  • SUSE Linux Enterprise Server 10 SP4 LTSS
  • SUSE Linux Enterprise Server 11 SP2 LTSS
  • SUSE Linux Enterprise Server 11 SP3 LTSS
  • SUSE Linux Enterprise Server 12 GA
  • SUSE Linux Enterprise Server for SAP 11 SP3
  • SUSE Linux Enterprise Server for SAP 12 GA
libxslt