Upstream information

CVE-2016-4487 at MITRE

Description

Use-after-free vulnerability in libiberty allows remote attackers to cause a denial of service (segmentation fault and crash) via a crafted binary, related to "btypevec."

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 2.6
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:H/Au:N/C:N/I:P/A:N
Access Vector Network Network
Access Complexity Medium High
Authentication None None
Confidentiality Impact None None
Integrity Impact None Partial
Availability Impact Partial None
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack Vector Local
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 978813 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 gcc Not affected
SUSE Enterprise Storage 7.1 gcc Not affected
SUSE Linux Enterprise Desktop 15 SP4 gcc Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 gcc Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 gcc Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 gcc Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP4 gcc Not affected
SUSE Linux Enterprise Module for HPC 12 gcc Affected
SUSE Linux Enterprise Real Time 15 SP3 gcc Not affected
SUSE Linux Enterprise Server 12 SP5 gcc Affected
SUSE Linux Enterprise Server 12-LTSS gcc Affected
SUSE Linux Enterprise Server 15 SP4 gcc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gcc Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 gcc Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 gcc Affected
SUSE Linux Enterprise Workstation Extension 12 SP5 gcc Affected
SUSE Manager Proxy 4.2 gcc Not affected
SUSE Manager Proxy 4.3 gcc Not affected
SUSE Manager Retail Branch Server 4.2 gcc Not affected
SUSE Manager Retail Branch Server 4.3 gcc Not affected
SUSE Manager Server 4.2 gcc Not affected
SUSE Manager Server 4.3 gcc Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP4 gcc Affected
SUSE Linux Enterprise High Performance Computing 15 gcc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 gcc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS gcc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS gcc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 gcc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS gcc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS gcc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 gcc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS gcc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS gcc Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS gcc Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS gcc Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 gcc Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 gcc Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 gcc Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 gcc Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 gcc Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 gcc Not affected
SUSE Linux Enterprise Server 12 SP2-BCL gcc Affected
SUSE Linux Enterprise Server 12 SP4 gcc Affected
SUSE Linux Enterprise Server 12 SP4-LTSS gcc Affected
SUSE Linux Enterprise Server 15 SP1 gcc Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS gcc Not affected
SUSE Linux Enterprise Server 15 SP2 gcc Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS gcc Not affected
SUSE Linux Enterprise Server 15 SP3 gcc Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS gcc Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 gcc Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 gcc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gcc Affected
SUSE Linux Enterprise Server for SAP Applications 15 gcc Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 gcc Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 gcc Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 gcc Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 gcc Affected
SUSE CaaS Platform 4.0 gcc Not affected
SUSE CaaS Platform 4.5 gcc Not affected
SUSE Enterprise Storage 6 gcc Not affected
SUSE Linux Enterprise Desktop 11 SP4 gcc Affected
SUSE Linux Enterprise Desktop 12 gcc Affected
SUSE Linux Enterprise Desktop 12 SP1 gcc Affected
SUSE Linux Enterprise Desktop 12 SP2 gcc Affected
SUSE Linux Enterprise Desktop 12 SP3 gcc Affected
SUSE Linux Enterprise Desktop 12 SP4 gcc Affected
SUSE Linux Enterprise Desktop 15 gcc Not affected
SUSE Linux Enterprise Desktop 15 SP1 gcc Not affected
SUSE Linux Enterprise Desktop 15 SP2 gcc Not affected
SUSE Linux Enterprise Desktop 15 SP3 gcc Not affected
SUSE Linux Enterprise High Performance Computing 12 SP2 gcc Affected
SUSE Linux Enterprise High Performance Computing 12 SP3 gcc Affected
SUSE Linux Enterprise Module for Basesystem 15 gcc Not affected
SUSE Linux Enterprise Module for Development Tools 15 gcc Not affected
SUSE Linux Enterprise Real Time 15 SP2 gcc Not affected
SUSE Linux Enterprise Server 11 SP1 gcc Affected
SUSE Linux Enterprise Server 11 SP2 LTSS gcc Affected
SUSE Linux Enterprise Server 11 SP3 gcc Affected
SUSE Linux Enterprise Server 11 SP3 LTSS gcc Affected
SUSE Linux Enterprise Server 11 SP3-LTSS gcc Affected
SUSE Linux Enterprise Server 11 SP4 gcc Affected
SUSE Linux Enterprise Server 11 SP4-LTSS gcc Affected
SUSE Linux Enterprise Server 12 gcc Affected
SUSE Linux Enterprise Server 12 SP1 gcc Affected
SUSE Linux Enterprise Server 12 SP1-LTSS gcc Affected
SUSE Linux Enterprise Server 12 SP2 gcc Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS gcc Affected
SUSE Linux Enterprise Server 12 SP2-LTSS gcc Affected
SUSE Linux Enterprise Server 12 SP3 gcc Affected
SUSE Linux Enterprise Server 12 SP3-BCL gcc Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS gcc Affected
SUSE Linux Enterprise Server 12 SP3-LTSS gcc Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS gcc Affected
SUSE Linux Enterprise Server 15 gcc Not affected
SUSE Linux Enterprise Server 15 SP1-BCL gcc Not affected
SUSE Linux Enterprise Server 15 SP2-BCL gcc Not affected
SUSE Linux Enterprise Server 15 SP3-BCL gcc Not affected
SUSE Linux Enterprise Server 15-LTSS gcc Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 gcc Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 gcc Affected
SUSE Linux Enterprise Server for SAP Applications 12 gcc Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 gcc Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gcc Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gcc Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 gcc Affected
SUSE Linux Enterprise Software Development Kit 12 gcc Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 gcc Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 gcc Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 gcc Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 gcc Affected
SUSE Linux Enterprise Workstation Extension 12 gcc Affected
SUSE Linux Enterprise Workstation Extension 12 SP1 gcc Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 gcc Affected
SUSE Linux Enterprise Workstation Extension 12 SP3 gcc Affected
SUSE Linux Enterprise Workstation Extension 12 SP4 gcc Affected
SUSE Manager Proxy 4.0 gcc Not affected
SUSE Manager Proxy 4.1 gcc Not affected
SUSE Manager Retail Branch Server 4.0 gcc Not affected
SUSE Manager Retail Branch Server 4.1 gcc Not affected
SUSE Manager Server 4.0 gcc Not affected
SUSE Manager Server 4.1 gcc Not affected
SUSE OpenStack Cloud 7 gcc Affected
SUSE OpenStack Cloud 8 gcc Affected
SUSE OpenStack Cloud 9 gcc Affected
SUSE OpenStack Cloud Crowbar 8 gcc Affected
SUSE OpenStack Cloud Crowbar 9 gcc Affected
Container Status
bci/golang
bci/golang:1.16
bci/golang:1.17
bci/golang:1.18
bci/ruby
bci/rust:1.59
trento/trento-runner
gccNot affected


SUSE Timeline for this CVE

CVE page created: Thu May 5 07:18:35 2016
CVE page last modified: Fri Jan 20 13:00:46 2023