Upstream information

CVE-2016-4472 at MITRE

Description

The overflow protection in Expat is removed by compilers with certain optimization settings, which allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via crafted XML data. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-1283 and CVE-2015-2716.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.1
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High

Note from the SUSE Security Team

The previous updates of expat tracked under CVE-2015-1283 already contained the improved code.

SUSE Bugzilla entries: 1034050 [NEW], 939077 [RESOLVED], 980391 [RESOLVED / FIXED], 983985 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • expat >= 2.2.5-1.140
  • libexpat-devel >= 2.2.5-1.140
  • libexpat1 >= 2.2.5-1.140
  • libexpat1-32bit >= 2.2.5-1.140
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA expat
openSUSE Leap 15.0
  • expat >= 2.2.5-lp150.1.9
  • libexpat1 >= 2.2.5-lp150.1.9
Patchnames:
openSUSE Leap 15.0 GA expat
openSUSE Tumbleweed
  • expat >= 2.2.0-3.1
  • libexpat-devel >= 2.2.0-3.1
  • libexpat-devel-32bit >= 2.2.0-3.1
  • libexpat1 >= 2.2.0-3.1
  • libexpat1-32bit >= 2.2.0-3.1
Patchnames:
openSUSE Tumbleweed GA expat


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 expat Already fixed
OpenStack Cloud Magnum Orchestration 7.0 expat Already fixed
SUSE Linux Enterprise Desktop 12 SP2 expat Already fixed
SUSE Linux Enterprise Desktop 12 SP3 expat Already fixed
SUSE Linux Enterprise SDK 11 SP4 expat Already fixed
SUSE Linux Enterprise SDK 12 SP2 expat Already fixed
SUSE Linux Enterprise SDK 12 SP3 expat Already fixed
SUSE Linux Enterprise Server 11 SP3 LTSS expat Already fixed
SUSE Linux Enterprise Server 11 SP4 expat Already fixed
SUSE Linux Enterprise Server 12 GA LTSS expat Already fixed
SUSE Linux Enterprise Server 12 SP1 LTSS expat Already fixed
SUSE Linux Enterprise Server 12 SP2 expat Already fixed
SUSE Linux Enterprise Server 12 SP3 expat Already fixed
SUSE Studio Onsite 1.3 expat Already fixed