Upstream information

CVE-2016-3709 at MITRE

Description

Possible cross-site scripting vulnerability in libxml after commit 960f0e2.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.1 6.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Changed Unchanged
Confidentiality Impact Low Low
Integrity Impact Low High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1201978 [NEW]

No SUSE Security Announcements cross referenced.

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Micro 5.1
  • libxml2-2 >= 2.9.7-150000.3.49.1
  • libxml2-tools >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise Micro 5.2
  • libxml2-2 >= 2.9.7-150000.3.49.1
  • libxml2-tools >= 2.9.7-150000.3.49.1
  • python3-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libxml2-2 >= 2.9.7-150000.3.49.1
  • libxml2-2-32bit >= 2.9.7-150000.3.49.1
  • libxml2-devel >= 2.9.7-150000.3.49.1
  • libxml2-tools >= 2.9.7-150000.3.49.1
  • python3-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise Server 15 SP3
  • libxml2-2 >= 2.9.7-150000.3.49.1
  • libxml2-2-32bit >= 2.9.7-150000.3.49.1
  • libxml2-devel >= 2.9.7-150000.3.49.1
  • libxml2-tools >= 2.9.7-150000.3.49.1
  • python3-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise Desktop 15 SP3
  • libxml2-2 >= 2.9.7-150000.3.49.1
  • libxml2-2-32bit >= 2.9.7-150000.3.49.1
  • libxml2-devel >= 2.9.7-150000.3.49.1
  • libxml2-tools >= 2.9.7-150000.3.49.1
  • python3-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise Server for SAP Applications 15 SP3
  • libxml2-2 >= 2.9.7-150000.3.49.1
  • libxml2-2-32bit >= 2.9.7-150000.3.49.1
  • libxml2-devel >= 2.9.7-150000.3.49.1
  • libxml2-tools >= 2.9.7-150000.3.49.1
  • python3-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise High Performance Computing 15 SP3
  • libxml2-2 >= 2.9.7-150000.3.49.1
  • libxml2-2-32bit >= 2.9.7-150000.3.49.1
  • libxml2-devel >= 2.9.7-150000.3.49.1
  • libxml2-tools >= 2.9.7-150000.3.49.1
  • python3-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Manager Server 4.2
  • libxml2-2 >= 2.9.7-150000.3.49.1
  • libxml2-2-32bit >= 2.9.7-150000.3.49.1
  • libxml2-devel >= 2.9.7-150000.3.49.1
  • libxml2-tools >= 2.9.7-150000.3.49.1
  • python3-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Manager Proxy 4.2
  • libxml2-2 >= 2.9.7-150000.3.49.1
  • libxml2-2-32bit >= 2.9.7-150000.3.49.1
  • libxml2-devel >= 2.9.7-150000.3.49.1
  • libxml2-tools >= 2.9.7-150000.3.49.1
  • python3-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Manager Retail Branch Server 4.2
  • libxml2-2 >= 2.9.7-150000.3.49.1
  • libxml2-2-32bit >= 2.9.7-150000.3.49.1
  • libxml2-devel >= 2.9.7-150000.3.49.1
  • libxml2-tools >= 2.9.7-150000.3.49.1
  • python3-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise Storage 7.1
  • libxml2-2 >= 2.9.7-150000.3.49.1
  • libxml2-2-32bit >= 2.9.7-150000.3.49.1
  • libxml2-devel >= 2.9.7-150000.3.49.1
  • libxml2-tools >= 2.9.7-150000.3.49.1
  • python3-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise Module for Python 2 15 SP3
  • python2-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise Server 15 SP3
  • python2-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise Desktop 15 SP3
  • python2-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise Server for SAP Applications 15 SP3
  • python2-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise High Performance Computing 15 SP3
  • python2-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Manager Server 4.2
  • python2-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Manager Proxy 4.2
  • python2-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Manager Retail Branch Server 4.2
  • python2-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise Storage 7.1
  • python2-libxml2-python >= 2.9.7-150000.3.49.1
SUSE Linux Enterprise Server 12 SP5
  • libxml2-2 >= 2.9.4-46.57.1
  • libxml2-2-32bit >= 2.9.4-46.57.1
  • libxml2-doc >= 2.9.4-46.57.1
  • libxml2-tools >= 2.9.4-46.57.1
  • python-libxml2 >= 2.9.4-46.57.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libxml2-2 >= 2.9.4-46.57.1
  • libxml2-2-32bit >= 2.9.4-46.57.1
  • libxml2-doc >= 2.9.4-46.57.1
  • libxml2-tools >= 2.9.4-46.57.1
  • python-libxml2 >= 2.9.4-46.57.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libxml2-devel >= 2.9.4-46.57.1
SUSE Linux Enterprise Server 12 SP5
  • libxml2-devel >= 2.9.4-46.57.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libxml2-devel >= 2.9.4-46.57.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 libxml2 In progress
SUSE Enterprise Storage 6 libxml2 In progress
SUSE Enterprise Storage 7 libxml2 In progress
SUSE Linux Enterprise Desktop 15 SP3 libxml2 In progress
SUSE Linux Enterprise Desktop 15 SP3 rubygem-nokogiri Not affected
SUSE Linux Enterprise Desktop 15 SP4 libxml2 Not affected
SUSE Linux Enterprise Desktop 15 SP4 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Availability Extension 15 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Availability Extension 15 SP1 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Availability Extension 15 SP2 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libxml2 In progress
SUSE Linux Enterprise High Performance Computing 15 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS libxml2 In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS libxml2 In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS libxml2 In progress
SUSE Linux Enterprise High Performance Computing 15 SP2 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS libxml2 In progress
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS libxml2 In progress
SUSE Linux Enterprise High Performance Computing 15 SP3 libxml2 In progress
SUSE Linux Enterprise High Performance Computing 15 SP3 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 libxml2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 rubygem-nokogiri Not affected
SUSE Linux Enterprise Micro 5.1 libxml2 In progress
SUSE Linux Enterprise Micro 5.2 libxml2 In progress
SUSE Linux Enterprise Micro 5.3 libxml2 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 libxml2 In progress
SUSE Linux Enterprise Module for Basesystem 15 SP3 rubygem-nokogiri Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 libxml2 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 12 SP2 BCL libxml2 In progress
SUSE Linux Enterprise Server 12 SP3 BCL libxml2 In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS libxml2 In progress
SUSE Linux Enterprise Server 12 SP4 LTSS libxml2 In progress
SUSE Linux Enterprise Server 12 SP5 libxml2 In progress
SUSE Linux Enterprise Server 15 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 15 ESPOS libxml2 In progress
SUSE Linux Enterprise Server 15 LTSS libxml2 In progress
SUSE Linux Enterprise Server 15 SP1 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS libxml2 In progress
SUSE Linux Enterprise Server 15 SP2 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS libxml2 In progress
SUSE Linux Enterprise Server 15 SP3 libxml2 In progress
SUSE Linux Enterprise Server 15 SP3 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 15 SP4 libxml2 Not affected
SUSE Linux Enterprise Server 15 SP4 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libxml2 In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 libxml2 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libxml2 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libxml2 In progress
SUSE Linux Enterprise Server for SAP Applications 15 libxml2 In progress
SUSE Linux Enterprise Server for SAP Applications 15 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libxml2 In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libxml2 In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP2 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libxml2 In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP3 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libxml2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 rubygem-nokogiri Not affected
SUSE Linux Enterprise Storage 7.1 libxml2 In progress
SUSE Linux Enterprise Storage 7.1 rubygem-nokogiri Not affected
SUSE Manager Proxy 4.0 rubygem-nokogiri Not affected
SUSE Manager Proxy 4.1 libxml2 In progress
SUSE Manager Proxy 4.1 rubygem-nokogiri Not affected
SUSE Manager Proxy 4.2 libxml2 In progress
SUSE Manager Proxy 4.2 rubygem-nokogiri Not affected
SUSE Manager Proxy 4.3 libxml2 Not affected
SUSE Manager Proxy 4.3 rubygem-nokogiri Not affected
SUSE Manager Retail Branch Server 4.0 rubygem-nokogiri Not affected
SUSE Manager Retail Branch Server 4.1 libxml2 In progress
SUSE Manager Retail Branch Server 4.1 rubygem-nokogiri Not affected
SUSE Manager Retail Branch Server 4.2 libxml2 In progress
SUSE Manager Retail Branch Server 4.2 rubygem-nokogiri Not affected
SUSE Manager Retail Branch Server 4.3 libxml2 Not affected
SUSE Manager Retail Branch Server 4.3 rubygem-nokogiri Not affected
SUSE Manager Server 4.0 rubygem-nokogiri Not affected
SUSE Manager Server 4.1 libxml2 In progress
SUSE Manager Server 4.1 rubygem-nokogiri Not affected
SUSE Manager Server 4.2 libxml2 In progress
SUSE Manager Server 4.2 rubygem-nokogiri Not affected
SUSE Manager Server 4.3 libxml2 Not affected
SUSE Manager Server 4.3 rubygem-nokogiri Not affected
SUSE OpenStack Cloud 9 libxml2 In progress
SUSE OpenStack Cloud Crowbar 8 rubygem-nokogiri Not affected
SUSE OpenStack Cloud Crowbar 9 libxml2 In progress
SUSE OpenStack Cloud Crowbar 9 rubygem-nokogiri Not affected