Upstream information

CVE-2016-1246 at MITRE

Description

Buffer overflow in the DBD::mysql module before 4.037 for Perl allows context-dependent attackers to cause a denial of service (crash) via vectors related to an error message.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.96 5.10
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low High
Authentication None None
Confidentiality Impact None Partial
Integrity Impact None Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1002626 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP4
  • perl-DBD-mysql >= 4.008-9.1
Patchnames:
slessp4-perl-DBD-mysql-12938
SUSE Linux Enterprise Server 12 SP1
  • perl-DBD-mysql >= 4.021-11.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-65
SUSE Linux Enterprise Server 12 SP2
  • perl-DBD-mysql >= 4.021-11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-65
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • perl-DBD-mysql >= 4.021-11.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-65
SUSE Linux Enterprise Software Development Kit 11 SP4
  • perl-DBD-mysql >= 4.008-9.1
Patchnames:
sdksp4-perl-DBD-mysql-12938
openSUSE Leap 42.1
  • perl-DBD-mysql >= 4.021-13.1
  • perl-DBD-mysql-debuginfo >= 4.021-13.1
  • perl-DBD-mysql-debugsource >= 4.021-13.1
Patchnames:
openSUSE-2017-130
openSUSE Leap 42.2
  • perl-DBD-mysql >= 4.021-14.1
  • perl-DBD-mysql-debuginfo >= 4.021-14.1
  • perl-DBD-mysql-debugsource >= 4.021-14.1
Patchnames:
openSUSE-2017-130
openSUSE Tumbleweed
  • perl-DBD-mysql >= 4.041-2.1
Patchnames:
openSUSE Tumbleweed GA perl-DBD-mysql


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server 10 SP4 LTSS
  • SUSE Linux Enterprise Server 11 SP2 LTSS
  • SUSE Linux Enterprise Server 11 SP3 LTSS
  • SUSE Linux Enterprise Server 12 GA
  • SUSE Linux Enterprise Server for SAP 11 SP3
  • SUSE Linux Enterprise Server for SAP 12 GA
perl-DBD-mysql